summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichele Noberasco <s4t4n@gentoo.org>2004-08-28 21:29:27 +0000
committerMichele Noberasco <s4t4n@gentoo.org>2004-08-28 21:29:27 +0000
commit9c18b476490f2c0f206e246835c67c46d522ed90 (patch)
tree1378572622c2f84efb2f4e286ff6f79ef7bd351b /x11-plugins/wmmemfree/wmmemfree-0.7-r1.ebuild
parentVersion bump. (diff)
downloadhistorical-9c18b476490f2c0f206e246835c67c46d522ed90.tar.gz
historical-9c18b476490f2c0f206e246835c67c46d522ed90.tar.bz2
historical-9c18b476490f2c0f206e246835c67c46d522ed90.zip
Revision bump for x11-plugins/wmmemfree-0.7, adding proper 2.6 kernel support...
Diffstat (limited to 'x11-plugins/wmmemfree/wmmemfree-0.7-r1.ebuild')
-rw-r--r--x11-plugins/wmmemfree/wmmemfree-0.7-r1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/x11-plugins/wmmemfree/wmmemfree-0.7-r1.ebuild b/x11-plugins/wmmemfree/wmmemfree-0.7-r1.ebuild
new file mode 100644
index 000000000000..bf06fa52b66a
--- /dev/null
+++ b/x11-plugins/wmmemfree/wmmemfree-0.7-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmmemfree/wmmemfree-0.7-r1.ebuild,v 1.1 2004/08/28 21:29:27 s4t4n Exp $
+
+inherit eutils
+
+IUSE=""
+DESCRIPTION="A blue WMaker DockApp to see memory usage."
+HOMEPAGE="http://misuceldestept.go.ro/wmmemfree/"
+SRC_URI="ftp://ftp.ibiblio.org/pub/linux/X11/xutils/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+
+DEPEND="virtual/x11"
+
+src_unpack()
+{
+ unpack ${A}
+ cd ${S}
+
+ # Patch to support both 2.4 and 2.6 kernels
+ epatch ${FILESDIR}/${P}-add-kernel-26-support.patch
+}
+
+src_compile()
+{
+ FLAGS=${CFLAGS} make -e || die "Compilation failed"
+}
+
+src_install()
+{
+ dobin wmmemfree
+ doman wmmemfree.1
+ dodoc ChangeLog TODO WMS COPYING INSTALL README THANKS
+}