summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2012-01-31 21:30:05 +0000
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2012-01-31 21:30:05 +0000
commit7109138e3243a9848bbecf352879957a79cbbd00 (patch)
tree99da19ccab4e651c457d2cb25caee1d21a87d06d /x11-proto/glproto/glproto-1.4.15.ebuild
parentVersion bump. (diff)
downloadhistorical-7109138e3243a9848bbecf352879957a79cbbd00.tar.gz
historical-7109138e3243a9848bbecf352879957a79cbbd00.tar.bz2
historical-7109138e3243a9848bbecf352879957a79cbbd00.zip
Version bump.
Package-Manager: portage-2.2.0_alpha84/cvs/Linux x86_64
Diffstat (limited to 'x11-proto/glproto/glproto-1.4.15.ebuild')
-rw-r--r--x11-proto/glproto/glproto-1.4.15.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/x11-proto/glproto/glproto-1.4.15.ebuild b/x11-proto/glproto/glproto-1.4.15.ebuild
new file mode 100644
index 000000000000..1d27efed3ba0
--- /dev/null
+++ b/x11-proto/glproto/glproto-1.4.15.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-proto/glproto/glproto-1.4.15.ebuild,v 1.1 2012/01/31 21:30:05 chithanh Exp $
+
+EAPI=4
+inherit xorg-2
+DESCRIPTION="X.Org GL protocol headers"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x64-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+LICENSE="SGI-B-2.0"
+IUSE=""
+
+RDEPEND=">=app-admin/eselect-opengl-1.2.3"
+DEPEND=""
+
+src_install() {
+ xorg-2_src_install
+ dynamic_libgl_install
+}
+
+pkg_postinst() {
+ xorg-2_pkg_postinst
+ eselect opengl set --ignore-missing --use-old xorg-x11
+}
+
+dynamic_libgl_install() {
+ # next section is to setup the dynamic libGL stuff
+ ebegin "Moving GL files for dynamic switching"
+ dodir /usr/$(get_libdir)/opengl/xorg-x11/include
+ local x=""
+ # glext.h added for #54984
+ for x in "${ED}"/usr/include/GL/{glxtokens.h,glxmd.h,glxproto.h}; do
+ if [[ -f ${x} || -L ${x} ]]; then
+ mv -f "${x}" "${ED}"/usr/$(get_libdir)/opengl/xorg-x11/include
+ fi
+ done
+ eend 0
+}