summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTavis Ormandy <taviso@gentoo.org>2003-11-23 16:16:51 +0000
committerTavis Ormandy <taviso@gentoo.org>2003-11-23 16:16:51 +0000
commitac2353ea0d5723ebf4b1c787c14aa39c632bf55e (patch)
treecb6bdabaa6591a0c323b0b77c615eac6774a1c08 /x11-terms/xvt/xvt-2.1.ebuild
parentinitial import (diff)
downloadhistorical-ac2353ea0d5723ebf4b1c787c14aa39c632bf55e.tar.gz
historical-ac2353ea0d5723ebf4b1c787c14aa39c632bf55e.tar.bz2
historical-ac2353ea0d5723ebf4b1c787c14aa39c632bf55e.zip
initial import
Diffstat (limited to 'x11-terms/xvt/xvt-2.1.ebuild')
-rw-r--r--x11-terms/xvt/xvt-2.1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/x11-terms/xvt/xvt-2.1.ebuild b/x11-terms/xvt/xvt-2.1.ebuild
new file mode 100644
index 000000000000..29bee0226421
--- /dev/null
+++ b/x11-terms/xvt/xvt-2.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-terms/xvt/xvt-2.1.ebuild,v 1.1 2003/11/23 16:16:47 taviso Exp $
+
+inherit ccc
+
+DESCRIPTION="A tiny (~40k) vt100 terminal emulator for X"
+HOMEPAGE="ftp://ftp.x.org/R5contrib/xvt-1.0.README"
+SRC_URI="ftp://ftp.x.org/R5contrib/xvt-1.0.tar.Z"
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~x86 ~alpha"
+IUSE=""
+DEPEND="virtual/x11"
+S=${WORKDIR}/${PN}-1.0
+
+src_unpack() {
+ unpack ${A}
+
+ # this brings the distribution upto version 2.1
+ cd ${S}; epatch ${FILESDIR}/xvt-2.1.diff.gz
+
+ # set the makefile options
+ sed -i 's/#\(ARCH=LINUX\)/\1/g' Makefile
+
+ # set CFLAGS
+ sed -i "s^\(CFLAGS=\)-O^\1${CFLAGS}^g" Makefile
+
+ # add search path for X11 libs.
+ append-ldflags -L/usr/X11R6/lib
+
+ # make gcc quiet.
+ sed -i -e 's/^void$/int/' -e 's/^void\( main\)/int\1/g' xvt.c
+}
+
+src_compile() {
+ # emake -j1 config
+ emake || die
+}
+
+src_install() {
+ dobin xvt
+ doman xvt.1
+ dodoc README COPYING
+}