summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArmando Di Cianno <fafhrd@gentoo.org>2004-12-13 00:05:13 +0000
committerArmando Di Cianno <fafhrd@gentoo.org>2004-12-13 00:05:13 +0000
commit5f98bf5117ea3b5daa8a27e6c31a7d021df04f1e (patch)
treef68100e9a2f5ad3569a7989902bfc2ded6122e7e /x11-themes/windowmaker-themes
parentFix bjam path (diff)
downloadhistorical-5f98bf5117ea3b5daa8a27e6c31a7d021df04f1e.tar.gz
historical-5f98bf5117ea3b5daa8a27e6c31a7d021df04f1e.tar.bz2
historical-5f98bf5117ea3b5daa8a27e6c31a7d021df04f1e.zip
Added use of "offensive" flag for themes that some have complained might get them in trouble at work
Diffstat (limited to 'x11-themes/windowmaker-themes')
-rw-r--r--x11-themes/windowmaker-themes/ChangeLog7
-rw-r--r--x11-themes/windowmaker-themes/Manifest4
-rw-r--r--x11-themes/windowmaker-themes/windowmaker-themes-0.1.ebuild24
3 files changed, 30 insertions, 5 deletions
diff --git a/x11-themes/windowmaker-themes/ChangeLog b/x11-themes/windowmaker-themes/ChangeLog
index 3a4336593baf..9750002a03ae 100644
--- a/x11-themes/windowmaker-themes/ChangeLog
+++ b/x11-themes/windowmaker-themes/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-themes/windowmaker-themes
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-themes/windowmaker-themes/ChangeLog,v 1.8 2004/09/16 18:29:40 fafhrd Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/windowmaker-themes/ChangeLog,v 1.9 2004/12/13 00:05:13 fafhrd Exp $
+
+ 12 Dec 2004; Armando Di Cianno <fafhrd@gentoo.org>
+ windowmaker-themes-0.1.ebuild:
+ Added use of "offensive" flag for themes that some have complained might get
+ them in trouble at work
15 Sep 2004; Armando Di Cianno <fafhrd@gentoo.org>
windowmaker-themes-0.1.ebuild:
diff --git a/x11-themes/windowmaker-themes/Manifest b/x11-themes/windowmaker-themes/Manifest
index a1df3e123ee5..6ba2ef05b127 100644
--- a/x11-themes/windowmaker-themes/Manifest
+++ b/x11-themes/windowmaker-themes/Manifest
@@ -1,4 +1,4 @@
-MD5 71beafd761e597f8263501a30369f581 ChangeLog 1244
-MD5 bf5f472d7ba1aebc000908035b0ec61c windowmaker-themes-0.1.ebuild 3457
+MD5 86846a4570d0a06caf9c741d326889e4 windowmaker-themes-0.1.ebuild 4147
+MD5 e658cada0035113a73d3401049761c6e ChangeLog 1436
MD5 72c8d22e50caaf5dd42b1823f5874206 metadata.xml 160
MD5 bb89e5465704ca83b392bf019badc1a8 files/digest-windowmaker-themes-0.1 4516
diff --git a/x11-themes/windowmaker-themes/windowmaker-themes-0.1.ebuild b/x11-themes/windowmaker-themes/windowmaker-themes-0.1.ebuild
index 76aa8ccf2aed..2ebf81bd463c 100644
--- a/x11-themes/windowmaker-themes/windowmaker-themes-0.1.ebuild
+++ b/x11-themes/windowmaker-themes/windowmaker-themes-0.1.ebuild
@@ -1,12 +1,13 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-themes/windowmaker-themes/windowmaker-themes-0.1.ebuild,v 1.9 2004/09/16 18:29:40 fafhrd Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/windowmaker-themes/windowmaker-themes-0.1.ebuild,v 1.10 2004/12/13 00:05:13 fafhrd Exp $
# TODO: Break themes up by author and into sub-dirs named after
# the author
DESCRIPTION="Collection of Window Maker themes"
HOMEPAGE="http://www.windowmaker.org/"
+
THEME_URI="http://gentoo.asleep.net/windowmaker-themes/"
SRC_URI="${THEME_URI}3white.tar.gz
${THEME_URI}AM.tar.gz
@@ -82,19 +83,35 @@ SRC_URI="${THEME_URI}3white.tar.gz
${THEME_URI}wmfrost.tar.gz
${THEME_URI}yondo.tar.gz"
+# Some people have complained about nearly getting in trouble while at work
+# because some of the themes are either pornographic or even artistic, but
+# "for adults only"; This is a quick hack to no install those themes
+# without the "offensive" use flag on.
+MY_OFFENSIVE="3white.tar.gz
+ Anguish.tar.gz"
+
+IUSE="offensive"
+
SLOT="0"
LICENSE="GPL-2"
KEYWORDS="x86 ppc sparc alpha ~amd64"
DEPEND=""
RDEPEND="x11-wm/windowmaker"
-IUSE=""
src_unpack() {
mkdir ${S}
cd ${S}
for i in ${SRC_URI} ; do
bn=`basename $i`
+ if ! use offensive ; then
+ for j in ${MY_OFFENSIVE} ; do
+ if [ "${bn}" == "${j}" ]; then
+ einfo "Skipping possibly offensive theme: ${bn}"
+ continue 2
+ fi
+ done
+ fi
unpack ${bn}
done
}
@@ -102,6 +119,9 @@ src_unpack() {
src_install () {
dodir /usr/share/WindowMaker/Themes
cp -dpR * ${D}/usr/share/WindowMaker/Themes/
+ # TODO: Need to clean this up at some point ...
+ #mv ${D}/usr/share/WindowMaker/Themes/Themes/* ${D}/usr/share/WindowMaker/Themes
+ #rm -Rf ${D}/usr/share/WindowMaker/Themes/Themes
chown -R root:root ${D}/usr/share/WindowMaker/Themes/
chmod -R o-w ${D}/usr/share/WindowMaker/Themes/
}