summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2010-09-05 15:09:57 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2010-09-05 15:09:57 +0000
commit769c3a570c065dc8e1c35154f265d357cad668b0 (patch)
tree47546bb885a3c25ecea67d93eee24722ccbfd28e /x11-wm/aewm++/files
parentRespect LDFLAGS wrt bug 327335. Thanks to Andreis Vinogradovs ( slepnoga ) <s... (diff)
downloadhistorical-769c3a570c065dc8e1c35154f265d357cad668b0.tar.gz
historical-769c3a570c065dc8e1c35154f265d357cad668b0.tar.bz2
historical-769c3a570c065dc8e1c35154f265d357cad668b0.zip
Respect LDFLAGS wrt bug 336099. Thanks to Diego for the report.
Package-Manager: portage-2.1.9/cvs/Linux x86_64
Diffstat (limited to 'x11-wm/aewm++/files')
-rw-r--r--x11-wm/aewm++/files/aewm++-1.1.5-makefile.patch34
-rw-r--r--x11-wm/aewm++/files/gcc-3.4.patch11
2 files changed, 34 insertions, 11 deletions
diff --git a/x11-wm/aewm++/files/aewm++-1.1.5-makefile.patch b/x11-wm/aewm++/files/aewm++-1.1.5-makefile.patch
new file mode 100644
index 000000000000..8b84a9963469
--- /dev/null
+++ b/x11-wm/aewm++/files/aewm++-1.1.5-makefile.patch
@@ -0,0 +1,34 @@
+Respect CFLAGS, LDFLAGS, don't strip binaries
+
+http://bugs.gentoo.org/show_bug.cgi?id=336099
+
+--- aewm++-1.1.5/Makefile
++++ aewm++-1.1.5/Makefile
+@@ -1,9 +1,6 @@
+ CC = g++
+-ADDITIONAL_CFLAGS = -g -O2 -march=i686 -Wall
+
+ prefix = /usr
+-INCLUDES = -I$/usr/X11R6
+-LDPATH = -L/usr/X11R6/lib
+ LIBS = -lXext -lX11
+
+ # SHAPE = Shape Extension
+@@ -28,14 +25,13 @@
+ all: aewm++
+
+ aewm++: $(OBJS)
+- $(CC) $(OBJS) $(LDPATH) $(LIBS) -o $@
++ $(CXX) $(LDFLAGS) $(OBJS) $(LDPATH) $(LIBS) -o $@
+
+ $(OBJS): %.o: %.cc $(HEADERS)
+- $(CC) $(CFLAGS) $(ADDITIONAL_CFLAGS) $(DEFINES) $(INCLUDES) -c $< -o $@
++ $(CXX) $(CXXFLAGS) $(DEFINES) $(INCLUDES) -c $< -o $@
+
+ install: all
+- mkdir -p $(DESTDIR)$(prefix)/bin
+- install -s aewm++ $(DESTDIR)$(prefix)/bin
++ install -D -m 755 aewm++ $(DESTDIR)$(prefix)/bin/aewm++
+
+ clean:
+ rm -f aewm++ $(OBJS) core
diff --git a/x11-wm/aewm++/files/gcc-3.4.patch b/x11-wm/aewm++/files/gcc-3.4.patch
deleted file mode 100644
index b739f71f89d3..000000000000
--- a/x11-wm/aewm++/files/gcc-3.4.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- windowmanager.cc.old 2005-01-07 15:21:55.949614120 +1100
-+++ windowmanager.cc 2005-01-07 15:19:17.414715088 +1100
-@@ -625,7 +625,7 @@
- {
- if( (unsigned)current_desktop != ks - XK_1 )
- {
-- (unsigned)current_desktop = ks - XK_1;
-+ current_desktop = ks - XK_1;
- goToDesktop(current_desktop);
- }
- }