summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2009-11-03 14:49:26 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2009-11-03 14:49:26 +0000
commit522275db31037127fc2feaebce025491cb7e3695 (patch)
tree8adc86c1454cffb60d2d18101776d6a90deedf1c /x11-wm/afterstep/afterstep-2.2.9.ebuild
parentStable for HPPA (bug #289481). (diff)
downloadhistorical-522275db31037127fc2feaebce025491cb7e3695.tar.gz
historical-522275db31037127fc2feaebce025491cb7e3695.tar.bz2
historical-522275db31037127fc2feaebce025491cb7e3695.zip
Version bump with cleanups, fixes bugs #180765 (bump request), #252119 (stripped files), and #265841 (ldconfig run on install)
Package-Manager: portage-2.2_rc48/cvs/Linux x86_64
Diffstat (limited to 'x11-wm/afterstep/afterstep-2.2.9.ebuild')
-rw-r--r--x11-wm/afterstep/afterstep-2.2.9.ebuild110
1 files changed, 110 insertions, 0 deletions
diff --git a/x11-wm/afterstep/afterstep-2.2.9.ebuild b/x11-wm/afterstep/afterstep-2.2.9.ebuild
new file mode 100644
index 000000000000..c51d040d00a1
--- /dev/null
+++ b/x11-wm/afterstep/afterstep-2.2.9.ebuild
@@ -0,0 +1,110 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/afterstep/afterstep-2.2.9.ebuild,v 1.1 2009/11/03 14:49:26 voyageur Exp $
+
+EAPI=2
+inherit autotools flag-o-matic eutils
+
+DESCRIPTION="AfterStep is a feature rich NeXTish window manager"
+HOMEPAGE="http://www.afterstep.org"
+SRC_URI="ftp://ftp.afterstep.org/stable/AfterStep-${PV}.tar.bz2"
+
+LICENSE="AFTERSTEP"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="alsa debug dbus gif gtk jpeg mmx nls png svg tiff xinerama"
+
+RDEPEND="media-libs/freetype
+ alsa? ( media-libs/alsa-lib )
+ dbus? ( sys-apps/dbus )
+ jpeg? ( >=media-libs/jpeg-6b )
+ gif? ( >=media-libs/giflib-4.1.0 )
+ gtk? ( x11-libs/gtk+:2 )
+ png? ( >=media-libs/libpng-1.2.5 )
+ svg? ( gnome-base/librsvg:2 )
+ tiff? ( >=media-libs/tiff-3.5.7 )
+ x11-libs/libICE
+ x11-libs/libXext
+ x11-libs/libSM
+ x11-libs/libXmu
+ x11-libs/libXt
+ x11-libs/libX11
+ x11-libs/libXpm
+ x11-libs/libXrender
+ xinerama? ( x11-libs/libXinerama )"
+
+DEPEND="${RDEPEND}
+ x11-proto/xextproto
+ x11-proto/xproto
+ xinerama? ( x11-proto/xineramaproto )"
+
+S=${WORKDIR}/AfterStep-${PV}
+
+src_prepare() {
+ epatch "${FILESDIR}"/no-alternatives-${PV}.patch
+
+ # Do not strip binaries, bug #252119
+ sed -e "/STRIP_BINARIES/s/-s//" -i autoconf/configure.in || die "strip sed failed"
+ cd "${S}"/autoconf || die "cd autoconf failed"
+ eautoreconf
+ cp "${S}"/autoconf/autoconf/config.h.in "${S}"/autoconf || die "cp failed"
+ cp "${S}"/autoconf/configure "${S}" || die "cp failed"
+}
+
+src_configure() {
+ local myconf
+
+ use debug && myconf="--enable-gdb --enable-warn --enable-gprof
+ --enable-audit --enable-trace --enable-trace-x"
+
+ #implied intent of debug means you need the frame pointers.
+ use debug && filter-flags -fomit-frame-pointer
+
+ # Explanation of configure options
+ # ================================
+ # --with-helpcommand="xterm -e man" - Avoid installing xiterm
+ # --with-xpm - Contained in xfree
+ # --disable-availability - So we can use complete paths for menuitems
+ # --enable-ascp - The AfterStep ControlPanel is abandoned
+ # LDCONFIG - bug #265841
+
+ LDCONFIG=/bin/true econf \
+ $(use_enable alsa) \
+ $(use_enable mmx mmx-optimization) \
+ $(use_enable nls i18n) \
+ $(use_enable xinerama) \
+ $(use_with dbus dbus1) \
+ $(use_with gif) \
+ $(use_with gtk) \
+ $(use_with jpeg) \
+ $(use_with png) \
+ $(use_with tiff) \
+ $(use_with svg) \
+ --with-helpcommand="xterm -e man" \
+ --disable-availability \
+ --disable-staticlibs \
+ --enable-ascp=no \
+ ${myconf} || die "configure failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+
+ # Create a symlink from MonitorWharf to Wharf
+ rm "${D}"/usr/bin/MonitorWharf
+ dosym /usr/bin/Wharf /usr/bin/MonitorWharf
+
+ # Handle the documentation
+ dodoc ChangeLog INSTALL NEW* README* TEAM UPGRADE
+ cp -pPR "${S}"/TODO "${D}"/usr/share/doc/${PF}/
+ dodir /usr/share/doc/${PF}/html
+ cp -pPR "${S}"/doc/* "${D}"/usr/share/doc/${PF}/html
+ rm "${D}"/usr/share/doc/${PF}/html/{Makefile*,afterstepdoc.in}
+
+ insinto /usr/share/xsessions
+ newins "${S}"/AfterStep.desktop.final AfterStep.desktop
+
+ # For desktop managers like GDM or KDE
+ exeinto /etc/X11/Sessions
+ doexe "${FILESDIR}"/afterstep
+}