summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Hadaway <raker@gentoo.org>2003-10-18 19:59:23 +0000
committerNick Hadaway <raker@gentoo.org>2003-10-18 19:59:23 +0000
commitd832269a1d948b64bf84e305c6712ccf96639047 (patch)
tree4cf36f1307f118796f26c5781543a1fbb08ef758 /x11-wm/afterstep
parentAfterstep is almost 2.0 revisions old! :) (diff)
downloadhistorical-d832269a1d948b64bf84e305c6712ccf96639047.tar.gz
historical-d832269a1d948b64bf84e305c6712ccf96639047.tar.bz2
historical-d832269a1d948b64bf84e305c6712ccf96639047.zip
Afterstep is almost 2.0 revisions old! :)
Diffstat (limited to 'x11-wm/afterstep')
-rw-r--r--x11-wm/afterstep/Manifest4
-rw-r--r--x11-wm/afterstep/afterstep-2.0_beta2.ebuild111
-rw-r--r--x11-wm/afterstep/files/digest-afterstep-2.0_beta21
3 files changed, 114 insertions, 2 deletions
diff --git a/x11-wm/afterstep/Manifest b/x11-wm/afterstep/Manifest
index 8200047fe979..7027f778af76 100644
--- a/x11-wm/afterstep/Manifest
+++ b/x11-wm/afterstep/Manifest
@@ -1,7 +1,7 @@
-MD5 8ef810dcadedf3be5a8b9e98c949838e afterstep-2.0_beta2.ebuild 3312
+MD5 d3b74ba3519df241e44855324609de33 afterstep-2.0_beta2.ebuild 3341
MD5 a32908f7e2101611a17ddb1aad85cf11 afterstep-1.8.11-r2.ebuild 1569
MD5 98d3f2ff8a9e176c8a6e12867bd25e36 afterstep-1.8.11-r1.ebuild 1437
-MD5 726700745bc123373d98e47093669ba5 ChangeLog 2216
+MD5 e730e2803018d02fe83adf1a3862e0cb ChangeLog 2371
MD5 9735d9a9bce29bcbd35792c0c4064ea0 files/digest-afterstep-1.8.11-r1 70
MD5 9735d9a9bce29bcbd35792c0c4064ea0 files/digest-afterstep-1.8.11-r2 70
MD5 f91d4b766b1c70d8c899ab9ffa55f7c2 files/digest-afterstep-2.0_beta2 74
diff --git a/x11-wm/afterstep/afterstep-2.0_beta2.ebuild b/x11-wm/afterstep/afterstep-2.0_beta2.ebuild
new file mode 100644
index 000000000000..4a36e3d53dff
--- /dev/null
+++ b/x11-wm/afterstep/afterstep-2.0_beta2.ebuild
@@ -0,0 +1,111 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/afterstep/afterstep-2.0_beta2.ebuild,v 1.1 2003/10/18 19:59:19 raker Exp $
+
+IUSE="png jpeg gif tiff truetype xinerama debug mmx"
+
+DESCRIPTION="Window manager based on the look and feel of the NeXTStep"
+HOMEPAGE="http://www.afterstep.org"
+SRC_URI="ftp://ftp.afterstep.org/devel/AfterStep-2.00.beta2.tar.bz2"
+
+LICENSE="AFTERSTEP"
+SLOT="0"
+KEYWORDS="~x86"
+
+DEPEND="virtual/glibc
+ virtual/x11
+ png? ( >=media-libs/libpng-1.2.5 )
+ jpeg? ( >=media-libs/jpeg-6b )
+ gif? ( >=media-libs/giflib-4.1.0 )
+ tiff? ( >=media-libs/tiff-3.5.7 )
+ debug? ( >=dev-util/efence-2.2.2 )"
+RDEPEND="${DEPEND}
+ >=media-sound/sox-12.17.3"
+
+S="${WORKDIR}/AfterStep-2.00.beta2"
+
+src_compile() {
+ local myconf
+
+ use nls && myconf="--enable-i18n" \
+ || myconf="--enable-i18n=no"
+
+ use png && myconf="${myconf} --with-png" \
+ || myconf="${myconf} --with-png=no"
+
+ use jpeg && myconf="${myconf} --with-jpeg" \
+ || myconf="${myconf} --with-jpeg=no"
+
+ use gif && myconf="${myconf} --with-gif" \
+ || myconf="${myconf} --with-gif=no"
+
+ use tiff && myconf="${myconf} --with-tiff" \
+ || myconf="${myconf} --with-tiff=no"
+
+ use truetype && myconf="${myconf} --with-ttf --enable-reuse-font=no" \
+ || myconf="${myconf} --with-ttf=no"
+
+ use xinerama && myconf="${myconf} --enable-xinerama" \
+ || myconf="${myconf} --enable-xinerama=no"
+
+ use mmx && myconf="${myconf} --enable-mmx-optimization" \
+ || myconf="${myconf} --enable-mmx-optimization=no"
+
+ use debug && myconf="${myconf} --with-libefence --enable-gdb --enable-warn --enable-gprof --enable-audit --enable-trace --enable-trace-x"
+
+ # Explanation of configure options
+ # ================================
+ # --with-helpcommand="xterm -e man" - Avoid installing xiterm
+ # --with-xpm - Contained in xfree
+ # --with-ungif=no - Use giflib instead of libungif
+ # --disable-availability - So we can use complete paths for menuitems
+ # --enable-ascp - The AfterStep ControlPanel is abandoned
+ #
+
+ econf \
+ --with-helpcommand="xterm -e man" \
+ --with-xpm \
+ --with-ungif=no \
+ --disable-availability \
+ --disable-staticlibs \
+ --enable-ascp=no \
+ ${myconf} || die "configure failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die "make install failed"
+
+ # This fixes a bug with shared libraries
+ rm ${D}/usr/lib/{libAfterImage.a,libAfterBase.a}
+ cp -a ${S}/libAfterImage/libAfterImage.so* ${D}/usr/lib
+ cp -a ${S}/libAfterBase/libAfterBase.so* ${D}/usr/lib
+
+ # Create a symlink from MonitorWharf to Wharf
+ rm ${D}/usr/bin/MonitorWharf
+ dosym /usr/bin/Wharf /usr/bin/MonitorWharf
+
+ # Handle the documentation
+ dodoc COPYRIGHT ChangeLog INSTALL NEW* README* TEAM UPGRADE
+ cp -a ${S}/TODO ${D}/usr/share/doc/${PF}/
+ dodir /usr/share/doc/${PF}/html
+ cp -a ${S}/doc/* ${D}/usr/share/doc/${PF}/html
+ rm ${D}/usr/share/doc/${PF}/html/{Makefile*,afterstepdoc.in}
+
+ # For desktop managers like GDM or KDE
+ exeinto /etc/X11/Sessions
+ doexe ${FILESDIR}/afterstep
+}
+
+pkg_postinst() {
+ echo
+ einfo "To use AfterStep issue the following commands:"
+ einfo "mv ~/.xinitrc ~/xinitrc.old"
+ einfo "echo afterstep > ~/.xinitrc"
+ echo
+ einfo "If you like AfterStep please vote for it at"
+ einfo "http://www.PLiG.org/xwinman/vote.html !"
+ echo
+}
+
diff --git a/x11-wm/afterstep/files/digest-afterstep-2.0_beta2 b/x11-wm/afterstep/files/digest-afterstep-2.0_beta2
new file mode 100644
index 000000000000..59cab41cee6b
--- /dev/null
+++ b/x11-wm/afterstep/files/digest-afterstep-2.0_beta2
@@ -0,0 +1 @@
+MD5 9ce007eb2281840b5473e1155d531fcd AfterStep-2.00.beta2.tar.bz2 4166714