summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2012-10-06 12:33:54 +0000
committerMichael Weber <xmw@gentoo.org>2012-10-06 12:33:54 +0000
commit386c14fbf1baf8a0599a28b8546250e6fc50ddfd (patch)
tree2ec9bf2f642f86d475b68500b1306592e32b5212 /x11-wm/cwm/cwm-9999.ebuild
parentvirtual/awk support and move to /usr/bin (bug #426628) (diff)
downloadhistorical-386c14fbf1baf8a0599a28b8546250e6fc50ddfd.tar.gz
historical-386c14fbf1baf8a0599a28b8546250e6fc50ddfd.tar.bz2
historical-386c14fbf1baf8a0599a28b8546250e6fc50ddfd.zip
Add xmw patches as USE=-vanilla.
Package-Manager: portage-2.1.11.13/cvs/Linux x86_64
Diffstat (limited to 'x11-wm/cwm/cwm-9999.ebuild')
-rw-r--r--x11-wm/cwm/cwm-9999.ebuild17
1 files changed, 11 insertions, 6 deletions
diff --git a/x11-wm/cwm/cwm-9999.ebuild b/x11-wm/cwm/cwm-9999.ebuild
index f7debac1ce83..a6e53cadb16d 100644
--- a/x11-wm/cwm/cwm-9999.ebuild
+++ b/x11-wm/cwm/cwm-9999.ebuild
@@ -1,23 +1,20 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/cwm/cwm-9999.ebuild,v 1.3 2012/06/16 21:56:26 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/cwm/cwm-9999.ebuild,v 1.4 2012/10/06 12:33:54 xmw Exp $
EAPI=4
-EGIT_REPO_URI=https://github.com/chneukirchen/cwm.git
-EGIT_BRANCH=linux
-
inherit flag-o-matic toolchain-funcs git-2
DESCRIPTION="OpenBSD fork of calmwm, a clean and lightweight window manager"
HOMEPAGE="http://www.openbsd.org/cgi-bin/cvsweb/xenocara/app/cwm/
http://github.com/chneukirchen/cwm"
-SRC_URI=""
+EGIT_BRANCH=linux
LICENSE="ISC"
SLOT="0"
KEYWORDS=""
-IUSE=""
+IUSE="vanilla"
RDEPEND="x11-libs/libXft
x11-libs/libXinerama
@@ -26,6 +23,14 @@ DEPEND="${RDEPEND}
virtual/pkgconfig
sys-devel/bison"
+pkg_setup() {
+ if use vanilla ; then
+ EGIT_REPO_URI="https://github.com/chneukirchen/cwm.git"
+ else
+ EGIT_REPO_URI="https://github.com/xmw/cwm.git"
+ fi
+}
+
src_compile() {
#append-cflags -D_GNU_SOURCE #bug 417047
emake CFLAGS="${CFLAGS} -D_GNU_SOURCE" CC="$(tc-getCC)"