summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Robbins <drobbins@gentoo.org>2003-11-12 16:24:04 +0000
committerDaniel Robbins <drobbins@gentoo.org>2003-11-12 16:24:04 +0000
commitbb9edbe31a53533484d41f83117d7986b72871d3 (patch)
treece84d1feef8d9496d671408aa263d3380030f7b6 /x11-wm/enlightenment/enlightenment-0.16.6.ebuild
parentfetch restriction on (diff)
downloadhistorical-bb9edbe31a53533484d41f83117d7986b72871d3.tar.gz
historical-bb9edbe31a53533484d41f83117d7986b72871d3.tar.bz2
historical-bb9edbe31a53533484d41f83117d7986b72871d3.zip
export USER=root fix to allow GRP building
Diffstat (limited to 'x11-wm/enlightenment/enlightenment-0.16.6.ebuild')
-rw-r--r--x11-wm/enlightenment/enlightenment-0.16.6.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/x11-wm/enlightenment/enlightenment-0.16.6.ebuild b/x11-wm/enlightenment/enlightenment-0.16.6.ebuild
index ab0b65f9278b..a4bb4abf6b6b 100644
--- a/x11-wm/enlightenment/enlightenment-0.16.6.ebuild
+++ b/x11-wm/enlightenment/enlightenment-0.16.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/enlightenment/enlightenment-0.16.6.ebuild,v 1.5 2003/11/12 04:13:31 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/enlightenment/enlightenment-0.16.6.ebuild,v 1.6 2003/11/12 16:24:02 drobbins Exp $
DESCRIPTION="Enlightenment Window Manager"
HOMEPAGE="http://www.enlightenment.org/"
@@ -37,10 +37,16 @@ src_compile() {
--enable-fsstd \
--enable-zoom \
|| die
+ #enlightenment's makefile uses the $USER env var (bad), which may not be
+ #set correctly if you did a "su" to get root before emerging. Normally,
+ #your $USER will still exist when you su (unless you enter a chroot,) but
+ #will cause perms to be wrong. This fixes this:
+ export USER=root
emake || die
}
src_install() {
+ export USER=root
emake install DESTDIR=${D} || die
exeinto /etc/X11/Sessions
doexe ${FILESDIR}/enlightenment