summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Robbins <drobbins@gentoo.org>2000-10-28 03:56:42 +0000
committerDaniel Robbins <drobbins@gentoo.org>2000-10-28 03:56:42 +0000
commitd4565e8d743debb813d98b655a47437893166b25 (patch)
treeef12c9a6e1120e0233b829fc4abde10e4f6aa493 /x11-wm/sawfish
parentmisc fix/upgrade (diff)
downloadhistorical-d4565e8d743debb813d98b655a47437893166b25.tar.gz
historical-d4565e8d743debb813d98b655a47437893166b25.tar.bz2
historical-d4565e8d743debb813d98b655a47437893166b25.zip
little fixes
Diffstat (limited to 'x11-wm/sawfish')
-rw-r--r--x11-wm/sawfish/files/digest-sawfish-0.321
-rw-r--r--x11-wm/sawfish/sawfish-0.32.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/x11-wm/sawfish/files/digest-sawfish-0.32 b/x11-wm/sawfish/files/digest-sawfish-0.32
new file mode 100644
index 000000000000..e9122bc16622
--- /dev/null
+++ b/x11-wm/sawfish/files/digest-sawfish-0.32
@@ -0,0 +1 @@
+MD5 cfbf988a645810cc0fd8a670f0652250 sawfish-0.32.tar.gz
diff --git a/x11-wm/sawfish/sawfish-0.32.ebuild b/x11-wm/sawfish/sawfish-0.32.ebuild
new file mode 100644
index 000000000000..43796e0b3d68
--- /dev/null
+++ b/x11-wm/sawfish/sawfish-0.32.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/sawfish/sawfish-0.32.ebuild,v 1.1 2000/10/28 03:56:42 drobbins Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="Extensible window manager using a Lisp-based scripting language"
+SRC_URI="ftp://sawmill.sourceforge.net/pub/sawmill/"${A}
+HOMEPAGE="http://sawmill.sourceforge.net/"
+DEPEND="dev-libs/gmp dev-libs/librep dev-libs/rep-gtk x11-libs/gtk+ media-libs/audiofile media-sound/esound media-libs/imlib gnome? ( gnome-base/gnome-core )"
+
+src_unpack() {
+ unpack ${A}
+}
+
+src_compile() {
+ cd ${S}
+ if [ -n "`use gnome`" ]
+ then
+ try ./configure --host=${CHOST} --prefix=/usr/X11R6 --with-audiofile --with-esd --with-gnome-prefix=/opt/gnome
+ else
+ try ./configure --host=${CHOST} --prefix=/usr/X11R6 --with-audiofile --with-esd
+ fi
+ try pmake
+}
+
+src_install() {
+ cd ${S}
+ try make DESTDIR=${D} install
+ prepinfo /usr/X11R6
+ dodoc AUTHORS BUGS COPYING ChangeLog DOC FAQ NEWS README THANKS TODO
+}
+
+
+