summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2003-10-20 12:24:47 +0000
committerMamoru Komachi <usata@gentoo.org>2003-10-20 12:24:47 +0000
commitb6af5be3a023f6c55e320695d7d7504bbd8b40cb (patch)
tree9983a28304b06b05f57a50a2751ed90490624722 /x11-wm/wm2/wm2-4.ebuild
parentNew ebuild, closing Bug #17129. (diff)
downloadhistorical-b6af5be3a023f6c55e320695d7d7504bbd8b40cb.tar.gz
historical-b6af5be3a023f6c55e320695d7d7504bbd8b40cb.tar.bz2
historical-b6af5be3a023f6c55e320695d7d7504bbd8b40cb.zip
New ebuild, closing Bug #17129.
Diffstat (limited to 'x11-wm/wm2/wm2-4.ebuild')
-rw-r--r--x11-wm/wm2/wm2-4.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/x11-wm/wm2/wm2-4.ebuild b/x11-wm/wm2/wm2-4.ebuild
new file mode 100644
index 000000000000..62d2e844402a
--- /dev/null
+++ b/x11-wm/wm2/wm2-4.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/wm2/wm2-4.ebuild,v 1.1 2003/10/20 12:24:43 usata Exp $
+
+IUSE=""
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Small, unconfigurable window manager"
+HOMEPAGE="http://www.all-day-breakfast.com/wm2/"
+SRC_URI="http://www.all-day-breakfast.com/wm2/${P}.tar.gz"
+
+DEPEND="virtual/x11"
+
+SLOT="0"
+LICENSE="freedist"
+KEYWORDS="~x86"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ EPATCH_OPTS="-R"
+ epatch ${FILESDIR}/${PF}-gentoo.patch
+
+ sed 's/^#//' Config.h > wm2.conf
+ if [ -e "/etc/wm2.conf" ]; then
+ echo "#undef _CONFIG_H_" >> Config.h
+ awk '/^[^/]/{print "#" $0}' /etc/wm2.conf >> Config.h
+ fi
+}
+
+src_compile() {
+ make CFLAGS="${CFLAGS}" || die
+}
+
+src_install() {
+ exeinto /usr/bin
+ doexe wm2
+ insinto /etc
+ doins wm2.conf
+ dodoc README
+}
+
+pkg_postinst() {
+ einfo
+ einfo "wm2 is unconfigurable after you have installed. If you want to"
+ einfo "change settings of wm2, please have a look at /etc/wm2.conf"
+ einfo "and rewrite it, then emerge wm2 again (wm2 ebuild uses settings"
+ einfo "from that file automatically). If you think wm2 lacks some important"
+ einfo "features that you want to use (such as background pixmaps),"
+ einfo "consider using wmx, written by the same author."
+ einfo
+}