summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-11-02 08:20:45 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-11-02 08:20:45 +0000
commitea94f0dc01e784be4aebae5d71ad85c4a8118579 (patch)
treefe06ab5f24c3454149a79775265330222ca95cfe /x11-wm
parentchase latest; #9967 (diff)
downloadhistorical-ea94f0dc01e784be4aebae5d71ad85c4a8118579.tar.gz
historical-ea94f0dc01e784be4aebae5d71ad85c4a8118579.tar.bz2
historical-ea94f0dc01e784be4aebae5d71ad85c4a8118579.zip
doc directory fix
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/icewm/ChangeLog11
-rw-r--r--x11-wm/icewm/files/digest-icewm-1.2.2-r11
-rw-r--r--x11-wm/icewm/files/digest-icewm-1.2.3_pre1-r11
-rw-r--r--x11-wm/icewm/icewm-1.2.2-r1.ebuild98
-rw-r--r--x11-wm/icewm/icewm-1.2.3_pre1-r1.ebuild94
5 files changed, 204 insertions, 1 deletions
diff --git a/x11-wm/icewm/ChangeLog b/x11-wm/icewm/ChangeLog
index 852ae08a7afe..d42035d7fc76 100644
--- a/x11-wm/icewm/ChangeLog
+++ b/x11-wm/icewm/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for x11-wm/icewm
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/icewm/ChangeLog,v 1.13 2002/11/01 08:16:34 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/icewm/ChangeLog,v 1.14 2002/11/02 08:20:45 seemant Exp $
+
+*icewm-1.2.3_pre1-r1 icewm-1.2.2-r1 (02 Nov 2002)
+
+ 02 Nov 2002; Seemant Kulleen <seemant@gentoo.org> icewm-1.2.3_pre1-r1.ebuild
+ icewm-1.2.2-r1.ebuild files/digest-icewm-1.2.4_pre1-r1
+ files/digest-icewm-1.2.2-r1 :
+
+ pez@apocalyptech.com (CJ Kucera) in bug #10057 pointed out that an extra
+ sed was needed for icewm to know its doc directory.
*icewm-1.2.3_pre1 (01 Nov 2002)
diff --git a/x11-wm/icewm/files/digest-icewm-1.2.2-r1 b/x11-wm/icewm/files/digest-icewm-1.2.2-r1
new file mode 100644
index 000000000000..2a49f82a2f16
--- /dev/null
+++ b/x11-wm/icewm/files/digest-icewm-1.2.2-r1
@@ -0,0 +1 @@
+MD5 7550e2e7822184d92ecc43e115b2f2d9 icewm-1.2.2.tar.gz 734435
diff --git a/x11-wm/icewm/files/digest-icewm-1.2.3_pre1-r1 b/x11-wm/icewm/files/digest-icewm-1.2.3_pre1-r1
new file mode 100644
index 000000000000..238b2db6552d
--- /dev/null
+++ b/x11-wm/icewm/files/digest-icewm-1.2.3_pre1-r1
@@ -0,0 +1 @@
+MD5 a0752120edda07b7dc49ddbbb482f64f icewm-1.2.3pre1.tar.gz 735955
diff --git a/x11-wm/icewm/icewm-1.2.2-r1.ebuild b/x11-wm/icewm/icewm-1.2.2-r1.ebuild
new file mode 100644
index 000000000000..d37044ca7bab
--- /dev/null
+++ b/x11-wm/icewm/icewm-1.2.2-r1.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/icewm/icewm-1.2.2-r1.ebuild,v 1.1 2002/11/02 08:20:45 seemant Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Ice Window Manager"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+HOMEPAGE="http://www.icewm.org"
+IUSE="esd nls imlib truetype gnome"
+
+DEPEND="virtual/x11
+ sys-apps/supersed
+ esd? ( media-sound/esound )
+ nls? ( sys-devel/gettext )
+ imlib? ( >=media-libs/imlib-1.9.10-r1 )
+ truetype? ( >=media-libs/freetype-2.0.9 )"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 ~ppc ~sparc ~sparc64"
+
+src_unpack(){
+ unpack ${A}
+
+ cd ${S}
+
+ patch -p1< ${FILESDIR}/${PN}-gcc31-gentoo.patch || die
+
+ # icewm's doc dir layout is un-gentoo-like. To fix it, we have
+ # "make install" skip the docs install, and do it ourselves. That also
+ # means we have to adjust the Makefile so that it can find the help files
+ # when you choose the 'help' item out of its menu.
+ ssed -i 's:icewm-$(VERSION)::' Makefile.in
+
+ ssed -i 's:icewm-$(VERSION)::' Makefile
+
+ cd ${S}/src
+ ssed -i 's:icewm-$(VERSION)::' Makefile
+
+ ssed -i 's:icewm-$(VERSION)::' Makefile.in
+}
+
+src_compile(){
+
+ use esd \
+ && myconf="${myconf} --with-esd-config=/usr/bin/esd-config"
+
+ use nls \
+ && myconf="${myconf} --enable-nls --enable-i18n" \
+ || myconf="${myconf} --disable-nls --disable-i18n"
+
+ use imlib \
+ && myconf="${myconf} --with-imlib --without-xpm" \
+ || myconf="${myconf} --without-imlib --with-xpm"
+
+ use truetype \
+ && myconf="${myconf} --enable-gradients" \
+ || myconf="${myconf} --disable-xfreetype"
+
+ use x86 \
+ && myconf="${myconf} --enable-x86-asm" \
+ || myconf="${myconf} --disable-x86-asm"
+
+ use gnome \
+ && myconf="${myconf} --with-gnome-menus" \
+ || myconf="${myconf} --without-gnome-menus"
+
+ CXXFLAGS="${CXXFLAGS}" econf \
+ --with-xpm \
+ --with-libdir=/usr/lib/icewm \
+ --with-cfgdir=/etc/icewm \
+ --with-docdir=/usr/share/doc/${PF}/html \
+ ${myconf} || die "configure failed"
+
+ emake || die "emake failed"
+}
+
+src_install(){
+# make \
+# PREFIX=${D}/usr \
+# BINDIR=${D}/usr/bin \
+# LIBDIR=${D}/usr/lib/icewm \
+# CFGDIR=${D}/etc/icewm \
+# LOCDIR=${D}/usr/share/locale \
+# DOCDIR=${S}/share/doc/${PF} \
+# KDEDIR=${D}/usr/share \
+# install || die "make install failed"
+
+ make DESTDIR=${D} install || die
+
+ dodoc AUTHORS BUGS CHANGES COPYING FAQ PLATFORMS README* TODO VERSION
+ dohtml -a html,sgml doc/*
+
+ echo "#!/bin/bash" > icewm
+ echo "/usr/bin/icewm" >> icewm
+ exeinto /etc/X11/Sessions
+ doexe icewm
+}
diff --git a/x11-wm/icewm/icewm-1.2.3_pre1-r1.ebuild b/x11-wm/icewm/icewm-1.2.3_pre1-r1.ebuild
new file mode 100644
index 000000000000..b88b98c0abcd
--- /dev/null
+++ b/x11-wm/icewm/icewm-1.2.3_pre1-r1.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/icewm/icewm-1.2.3_pre1-r1.ebuild,v 1.1 2002/11/02 08:20:45 seemant Exp $
+
+MY_P="icewm-1.2.3pre1"
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="Ice Window Manager"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+HOMEPAGE="http://www.icewm.org"
+IUSE="esd gnome imlib nls spell truetype"
+
+DEPEND="virtual/x11
+ sys-apps/supersed
+ esd? ( media-sound/esound )
+ gnome? ( gnome-base/gnome )
+ imlib? ( >=media-libs/imlib-1.9.10-r1 )
+ nls? ( sys-devel/gettext )
+ truetype? ( >=media-libs/freetype-2.0.9 )"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~sparc64"
+
+src_unpack(){
+ unpack ${A}
+
+ cd ${S}
+
+ patch -p1< ${FILESDIR}/${P}-gcc31-gentoo.patch || die
+ patch -p1< ${FILESDIR}/${P}-aapm-gentoo.patch || die
+
+ # icewm's doc dir layout is un-gentoo-like. To fix it, we have
+ # "make install" skip the docs install, and do it ourselves. That also
+ # means we have to adjust the Makefile so that it can find the help files
+ # when you choose the 'help' item out of its menu.
+ ssed -i 's:icewm-$(VERSION)::' Makefile.in
+ ssed -i 's:icewm-$(VERSION)::' Makefile
+
+ cd ${S}/src
+ ssed -i 's:icewm-$(VERSION)::' Makefile.in
+ ssed -i 's:icewm-$(VERSION)::' Makefile
+
+}
+
+src_compile(){
+
+ use esd \
+ && myconf="${myconf} --with-esd-config=/usr/bin/esd-config"
+
+ use nls \
+ && myconf="${myconf} --enable-nls --enable-i18n" \
+ || myconf="${myconf} --disable-nls --disable-i18n"
+
+ use imlib \
+ && myconf="${myconf} --with-imlib --without-xpm" \
+ || myconf="${myconf} --without-imlib --with-xpm"
+
+ use spell \
+ && myconf="${myconf} --enable-GtkSpell" \
+ || myconf="${myconf} --disable-GtkSpell"
+
+ use truetype \
+ && myconf="${myconf} --enable-gradients" \
+ || myconf="${myconf} --disable-xfreetype"
+
+ use x86 \
+ && myconf="${myconf} --enable-x86-asm" \
+ || myconf="${myconf} --disable-x86-asm"
+
+ use gnome \
+ && myconf="${myconf} --with-gnome-menus" \
+ || myconf="${myconf} --without-gnome-menus"
+
+ CXXFLAGS="${CXXFLAGS}" econf \
+ --with-xpm \
+ --with-libdir=/usr/lib/icewm \
+ --with-cfgdir=/etc/icewm \
+ --with-docdir=/usr/share/doc/${PF}/html \
+ ${myconf} || die "configure failed"
+
+ emake || die "emake failed"
+}
+
+src_install(){
+ make DESTDIR=${D} install || die
+
+ dodoc AUTHORS BUGS CHANGES COPYING FAQ PLATFORMS README* TODO VERSION
+ dohtml -a html,sgml doc/*
+
+ echo "#!/bin/bash" > icewm
+ echo "/usr/bin/icewm" >> icewm
+ exeinto /etc/X11/Sessions
+ doexe icewm
+}