summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2007-11-18 07:09:33 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2007-11-18 07:09:33 +0000
commitc2a7063156ea285e57befadb72a8c978f12214aa (patch)
treef872b83b42935d11965ede08671df41ebdfb837a /xfce-base/xfdesktop/xfdesktop-4.4.2.ebuild
parent- fixed the lib64 patch that was breaking on amd64 32ul. (diff)
downloadhistorical-c2a7063156ea285e57befadb72a8c978f12214aa.tar.gz
historical-c2a7063156ea285e57befadb72a8c978f12214aa.tar.bz2
historical-c2a7063156ea285e57befadb72a8c978f12214aa.zip
Version bump.
Package-Manager: portage-2.1.3.19
Diffstat (limited to 'xfce-base/xfdesktop/xfdesktop-4.4.2.ebuild')
-rw-r--r--xfce-base/xfdesktop/xfdesktop-4.4.2.ebuild75
1 files changed, 75 insertions, 0 deletions
diff --git a/xfce-base/xfdesktop/xfdesktop-4.4.2.ebuild b/xfce-base/xfdesktop/xfdesktop-4.4.2.ebuild
new file mode 100644
index 000000000000..300cc1ea2ded
--- /dev/null
+++ b/xfce-base/xfdesktop/xfdesktop-4.4.2.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfdesktop/xfdesktop-4.4.2.ebuild,v 1.1 2007/11/18 07:04:49 drac Exp $
+
+inherit eutils xfce44
+
+XFCE_VERSION=4.4.2
+xfce44
+xfce44_core_package
+
+DESCRIPTION="Desktop manager"
+HOMEPAGE="http://www.xfce.org/projects/xfdesktop"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="dbus debug doc minimal"
+
+LANG="be ca cs da de el es et eu fi fr he hu it ja ko nb_NO nl pa pl pt_BR ro ru sk sv tr uk vi zh_CN zh_TW"
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libSM
+ >=dev-libs/glib-2.6
+ >=x11-libs/gtk+-2.6
+ gnome-base/librsvg
+ >=xfce-base/libxfce4mcs-${XFCE_MASTER_VERSION}
+ >=xfce-base/libxfce4util-${XFCE_MASTER_VERSION}
+ >=xfce-base/libxfcegui4-${XFCE_MASTER_VERSION}
+ >=xfce-base/xfce-mcs-manager-${XFCE_MASTER_VERSION}
+ dbus? ( dev-libs/dbus-glib >=xfce-base/thunar-${THUNAR_MASTER_VERSION} )
+ !minimal? ( >=xfce-base/xfce4-panel-${XFCE_MASTER_VERSION}
+ >=xfce-extra/exo-0.3.2 )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ dev-util/intltool"
+
+for X in ${LANG}; do
+ IUSE="${IUSE} linguas_${X}"
+done
+
+XFCE_CONFIG="${XFCE_CONFIG} $(use_enable doc xsltproc)"
+DOCS="AUTHORS ChangeLog NEWS TODO README"
+XFCE_LOCALIZED_CONFIGS="/etc/xdg/xfce4/desktop/xfce-registered-categories.xml
+ /etc/xdg/xfce4/desktop/menu.xml"
+
+pkg_setup() {
+ if use dbus; then
+ XFCE_CONFIG="${XFCE_CONFIG} --enable-thunarx --enable-file-icons"
+ else
+ XFCE_CONFIG="${XFCE_CONFIG} --disable-thunarx --disable-file-icons"
+ fi
+
+ if use minimal; then
+ XFCE_CONFIG="${XFCE_CONFIG} --disable-desktop-icons --disable-exo --disable-panel-plugin"
+ else
+ XFCE_CONFIG="${XFCE_CONFIG} --enable-desktop-icons --enable-exo --enable-panel-plugin"
+ fi
+}
+
+src_install() {
+ xfce44_src_install
+
+ # clean out the config files that don't affect us
+ local config lang
+ for config in ${XFCE_LOCALIZED_CONFIGS}; do
+ for lang in ${LANG}; do
+ local localized_config="${D}/${config}.${lang}"
+ if [[ -f ${localized_config} ]]; then
+ use "linguas_${lang}" || rm ${localized_config}
+ fi
+ done
+ done
+}
+
+pkg_postinst() {
+ xfce44_pkg_postinst
+ use dbus || elog "You need USE=\"dbus\" to enable desktop icons."
+}