summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-01-02 15:30:52 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-01-02 15:30:52 +0000
commit1e8030b4648b5e305f844ad49c2ec2481c0e2843 (patch)
tree1af45e296e16297e15348c0474542ea8e08a56cb /xfce-base
parentStable on alpha, bug #347223 (diff)
downloadhistorical-1e8030b4648b5e305f844ad49c2ec2481c0e2843.tar.gz
historical-1e8030b4648b5e305f844ad49c2ec2481c0e2843.tar.bz2
historical-1e8030b4648b5e305f844ad49c2ec2481c0e2843.zip
Version bump.
Package-Manager: portage-2.2.0_alpha10/cvs/Linux x86_64
Diffstat (limited to 'xfce-base')
-rw-r--r--xfce-base/xfce-utils/ChangeLog9
-rw-r--r--xfce-base/xfce-utils/xfce-utils-4.7.4.ebuild60
-rw-r--r--xfce-base/xfconf/ChangeLog9
-rw-r--r--xfce-base/xfconf/xfconf-4.7.5.ebuild55
-rw-r--r--xfce-base/xfwm4/ChangeLog9
-rw-r--r--xfce-base/xfwm4/xfwm4-4.7.4.ebuild53
6 files changed, 189 insertions, 6 deletions
diff --git a/xfce-base/xfce-utils/ChangeLog b/xfce-base/xfce-utils/ChangeLog
index d6803fd038fb..1be2229f3966 100644
--- a/xfce-base/xfce-utils/ChangeLog
+++ b/xfce-base/xfce-utils/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for xfce-base/xfce-utils
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfce-utils/ChangeLog,v 1.168 2010/12/05 16:24:45 ssuominen Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfce-utils/ChangeLog,v 1.169 2011/01/02 15:26:58 ssuominen Exp $
+
+*xfce-utils-4.7.4 (02 Jan 2011)
+
+ 02 Jan 2011; Samuli Suominen <ssuominen@gentoo.org> +xfce-utils-4.7.4.ebuild:
+ Version bump.
*xfce-utils-4.7.3 (05 Dec 2010)
diff --git a/xfce-base/xfce-utils/xfce-utils-4.7.4.ebuild b/xfce-base/xfce-utils/xfce-utils-4.7.4.ebuild
new file mode 100644
index 000000000000..eef1b83ab2ba
--- /dev/null
+++ b/xfce-base/xfce-utils/xfce-utils-4.7.4.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfce-utils/xfce-utils-4.7.4.ebuild,v 1.1 2011/01/02 15:26:58 ssuominen Exp $
+
+EAPI=3
+inherit xfconf
+
+DESCRIPTION="Xfce's utilities"
+HOMEPAGE="http://www.xfce.org/projects/xfce-utils/"
+SRC_URI="mirror://xfce/src/xfce/${PN}/4.7/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="dbus debug +lock"
+
+COMMON_DEPEND="x11-libs/libX11
+ >=x11-libs/gtk+-2.10:2
+ >=xfce-base/libxfce4util-4.6
+ >=xfce-base/libxfce4ui-4.7
+ >=xfce-base/xfconf-4.6
+ dbus? ( >=dev-libs/dbus-glib-0.70 )"
+RDEPEND="${COMMON_DEPEND}
+ x11-apps/xrdb
+ x11-misc/xdg-user-dirs
+ lock? ( || ( x11-misc/xscreensaver
+ gnome-extra/gnome-screensaver
+ x11-misc/xlockmore
+ x11-misc/slock ) )"
+DEPEND="${COMMON_DEPEND}
+ dev-util/intltool
+ dev-util/pkgconfig
+ sys-devel/gettext"
+
+pkg_setup() {
+ XFCONF=(
+ --docdir="${EPREFIX}"/usr/share/doc/${PF}
+ --disable-dependency-tracking
+ --disable-xfconf-migration
+ $(use_enable dbus)
+ $(xfconf_use_debug)
+ --with-vendor-info=Gentoo
+ --with-xsession-prefix="${EPREFIX}"/usr
+ )
+
+ DOCS="AUTHORS ChangeLog NEWS"
+}
+
+src_install() {
+ xfconf_src_install
+
+ rm -f "${ED}"/usr/share/applications/xfhelp4.desktop
+
+ insinto /usr/share/xfce4
+ doins "${FILESDIR}"/Gentoo || die
+
+ echo startxfce4 > "${T}"/Xfce4
+ exeinto /etc/X11/Sessions
+ doexe "${T}"/Xfce4 || die
+}
diff --git a/xfce-base/xfconf/ChangeLog b/xfce-base/xfconf/ChangeLog
index 1235aaf2a206..e3cf45c6439f 100644
--- a/xfce-base/xfconf/ChangeLog
+++ b/xfce-base/xfconf/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for xfce-base/xfconf
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfconf/ChangeLog,v 1.43 2010/12/03 21:35:48 ssuominen Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfconf/ChangeLog,v 1.44 2011/01/02 15:25:10 ssuominen Exp $
+
+*xfconf-4.7.5 (02 Jan 2011)
+
+ 02 Jan 2011; Samuli Suominen <ssuominen@gentoo.org> +xfconf-4.7.5.ebuild:
+ Version bump.
*xfconf-4.7.4 (03 Dec 2010)
diff --git a/xfce-base/xfconf/xfconf-4.7.5.ebuild b/xfce-base/xfconf/xfconf-4.7.5.ebuild
new file mode 100644
index 000000000000..b2d58c612114
--- /dev/null
+++ b/xfce-base/xfconf/xfconf-4.7.5.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfconf/xfconf-4.7.5.ebuild,v 1.1 2011/01/02 15:25:10 ssuominen Exp $
+
+EAPI=3
+inherit xfconf
+
+DESCRIPTION="Xfce's configuration storage system"
+HOMEPAGE="http://www.xfce.org/"
+SRC_URI="mirror://xfce/src/xfce/xfconf/4.7/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~x64-solaris"
+IUSE="debug perl"
+
+RDEPEND=">=dev-libs/dbus-glib-0.72
+ >=dev-libs/glib-2.18:2
+ >=xfce-base/libxfce4util-4.6
+ perl? ( dev-perl/glib-perl )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ dev-util/intltool
+ sys-devel/gettext
+ perl? ( dev-perl/extutils-depends
+ dev-perl/extutils-pkgconfig )"
+
+RESTRICT="test"
+
+pkg_setup() {
+ XFCONF=(
+ --disable-dependency-tracking
+ --disable-static
+ $(use_enable perl perl-bindings)
+ $(xfconf_use_debug)
+ $(use_enable debug checks)
+ --with-perl-options=INSTALLDIRS=vendor
+ --with-html-dir="${EPREFIX}"/usr/share/doc/${PF}/html
+ )
+
+ DOCS="AUTHORS ChangeLog NEWS TODO"
+}
+
+src_compile() {
+ emake OTHERLDFLAGS="${LDFLAGS}" || die
+}
+
+src_install() {
+ xfconf_src_install
+
+ if use perl; then
+ find "${ED}" -type f -name perllocal.pod -delete
+ find "${ED}" -depth -mindepth 1 -type d -empty -delete
+ fi
+}
diff --git a/xfce-base/xfwm4/ChangeLog b/xfce-base/xfwm4/ChangeLog
index bc8ac007b946..b60555732e91 100644
--- a/xfce-base/xfwm4/ChangeLog
+++ b/xfce-base/xfwm4/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for xfce-base/xfwm4
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfwm4/ChangeLog,v 1.156 2010/12/05 16:13:31 ssuominen Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfwm4/ChangeLog,v 1.157 2011/01/02 15:30:51 ssuominen Exp $
+
+*xfwm4-4.7.4 (02 Jan 2011)
+
+ 02 Jan 2011; Samuli Suominen <ssuominen@gentoo.org> +xfwm4-4.7.4.ebuild:
+ Version bump.
*xfwm4-4.7.3 (05 Dec 2010)
diff --git a/xfce-base/xfwm4/xfwm4-4.7.4.ebuild b/xfce-base/xfwm4/xfwm4-4.7.4.ebuild
new file mode 100644
index 000000000000..0e897abdaaae
--- /dev/null
+++ b/xfce-base/xfwm4/xfwm4-4.7.4.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfwm4/xfwm4-4.7.4.ebuild,v 1.1 2011/01/02 15:30:52 ssuominen Exp $
+
+EAPI=3
+inherit xfconf
+
+DESCRIPTION="Xfce's window manager"
+HOMEPAGE="http://www.xfce.org/projects/xfwm4/"
+SRC_URI="mirror://xfce/src/xfce/${PN}/4.7/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="debug startup-notification +xcomposite"
+
+RDEPEND=">=dev-libs/glib-2.10:2
+ >=x11-libs/gtk+-2.14:2
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXrandr
+ x11-libs/libXrender
+ x11-libs/libXpm
+ x11-libs/pango
+ >=x11-libs/libwnck-2.22
+ >=xfce-base/libxfce4util-4.6
+ >=xfce-base/libxfce4ui-4.7.5
+ >=xfce-base/xfconf-4.6
+ startup-notification? ( x11-libs/startup-notification )
+ xcomposite? ( x11-libs/libXcomposite
+ x11-libs/libXdamage
+ x11-libs/libXfixes )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ dev-util/pkgconfig
+ sys-devel/gettext"
+
+pkg_setup() {
+ XFCONF=(
+ --docdir="${EPREFIX}"/usr/share/doc/${PF}
+ --disable-dependency-tracking
+ $(use_enable startup-notification)
+ --enable-xsync
+ --enable-render
+ --enable-randr
+ $(use_enable xcomposite compositor)
+ $(xfconf_use_debug)
+ )
+
+ DOCS="AUTHORS ChangeLog COMPOSITOR NEWS README TODO"
+}