summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-08-24 09:51:48 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-08-24 09:51:48 +0000
commitfd4d2ac7b760f587c66a7cea23f2ea7c591c0ae0 (patch)
tree88e369107d783a6c75b23988bf8bdd5869492427 /xfce-extra
parentFix source directory. (diff)
downloadhistorical-fd4d2ac7b760f587c66a7cea23f2ea7c591c0ae0.tar.gz
historical-fd4d2ac7b760f587c66a7cea23f2ea7c591c0ae0.tar.bz2
historical-fd4d2ac7b760f587c66a7cea23f2ea7c591c0ae0.zip
Initial commit.
Package-Manager: portage-2.2_rc39/cvs/Linux x86_64
Diffstat (limited to 'xfce-extra')
-rw-r--r--xfce-extra/xfswitch-plugin/ChangeLog10
-rw-r--r--xfce-extra/xfswitch-plugin/Manifest4
-rw-r--r--xfce-extra/xfswitch-plugin/metadata.xml5
-rw-r--r--xfce-extra/xfswitch-plugin/xfswitch-plugin-0.0.1.ebuild29
4 files changed, 48 insertions, 0 deletions
diff --git a/xfce-extra/xfswitch-plugin/ChangeLog b/xfce-extra/xfswitch-plugin/ChangeLog
new file mode 100644
index 000000000000..de8c219fa0fa
--- /dev/null
+++ b/xfce-extra/xfswitch-plugin/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for xfce-extra/xfswitch-plugin
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfswitch-plugin/ChangeLog,v 1.1 2009/08/24 09:51:48 ssuominen Exp $
+
+*xfswitch-plugin-0.0.1 (24 Aug 2009)
+
+ 24 Aug 2009; Samuli Suominen <ssuominen@gentoo.org>
+ +xfswitch-plugin-0.0.1.ebuild:
+ Initial commit.
+
diff --git a/xfce-extra/xfswitch-plugin/Manifest b/xfce-extra/xfswitch-plugin/Manifest
new file mode 100644
index 000000000000..193607381ff5
--- /dev/null
+++ b/xfce-extra/xfswitch-plugin/Manifest
@@ -0,0 +1,4 @@
+DIST xfswitch-plugin-0.0.1.tar.gz 314589 RMD160 555632725ec9bdfea19cea24ef6abfdb6c58ecd1 SHA1 98d48a836493fbbf72188d74afba7c2505579b4a SHA256 44fede57f181b507277ae406a6e56f215bb4ba29b60442e6ccd166e7df98a738
+EBUILD xfswitch-plugin-0.0.1.ebuild 773 RMD160 02b1f8bc7603b97cbe9e47dd1bac3253fec75690 SHA1 786cb36670f8c4df62faba4029a36645ca3b8600 SHA256 b473d4676ed0eb09af86c7101e228bbf297a7301ea2fe10cab4d5e935432ec03
+MISC ChangeLog 372 RMD160 5ae9bc2e7d7fbd9c06021c33b33cb3f9c9913df9 SHA1 74de5a0eef5d928c2e1f041abe460ff7130ced5b SHA256 704e80976a23a86bb29e396cb98328fd6581438b1684199ab55a006df9e11b48
+MISC metadata.xml 159 RMD160 43722935bd7b4db7fe8db681054f2e53c4a5f7ce SHA1 15958ad72e234ba572c9534533c21532eb6bc0fd SHA256 900ea49b6703fce452e205b85226bf1f994725963e5840da501182e7487d0e63
diff --git a/xfce-extra/xfswitch-plugin/metadata.xml b/xfce-extra/xfswitch-plugin/metadata.xml
new file mode 100644
index 000000000000..d56729e92f8e
--- /dev/null
+++ b/xfce-extra/xfswitch-plugin/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>xfce</herd>
+</pkgmetadata>
diff --git a/xfce-extra/xfswitch-plugin/xfswitch-plugin-0.0.1.ebuild b/xfce-extra/xfswitch-plugin/xfswitch-plugin-0.0.1.ebuild
new file mode 100644
index 000000000000..7a7317b34862
--- /dev/null
+++ b/xfce-extra/xfswitch-plugin/xfswitch-plugin-0.0.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfswitch-plugin/xfswitch-plugin-0.0.1.ebuild,v 1.1 2009/08/24 09:51:48 ssuominen Exp $
+
+EAPI=2
+inherit xfconf
+
+DESCRIPTION="a user switching plugin for the Xfce4 Panel"
+HOMEPAGE="http://www.xfce.org/"
+SRC_URI="mirror://xfce/src/panel-plugins/${PN}/0.0/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="debug"
+
+RDEPEND=">=x11-libs/gtk+-2.12:2
+ >=xfce-base/libxfce4util-4.4
+ >=xfce-base/libxfcegui4-4.4
+ >=xfce-base/xfce4-panel-4.4"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ dev-util/intltool"
+
+pkg_setup() {
+ DOCS="AUTHORS ChangeLog NEWS README"
+ XFCONF="--disable-dependency-tracking
+ $(use_enable debug)"
+}