summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-editors/quanta/files/digest-quanta-2.0_pre11
-rw-r--r--app-editors/quanta/quanta-2.0_pre1.ebuild34
-rw-r--r--kde-apps/quanta/files/digest-quanta-2.0_pre11
-rw-r--r--kde-apps/quanta/quanta-2.0_pre1.ebuild34
4 files changed, 70 insertions, 0 deletions
diff --git a/app-editors/quanta/files/digest-quanta-2.0_pre1 b/app-editors/quanta/files/digest-quanta-2.0_pre1
new file mode 100644
index 000000000000..e41f2d2ffb86
--- /dev/null
+++ b/app-editors/quanta/files/digest-quanta-2.0_pre1
@@ -0,0 +1 @@
+MD5 dec00150b247d40162fa3941b56c3b93 quanta-2.0-pr1.tar.bz2
diff --git a/app-editors/quanta/quanta-2.0_pre1.ebuild b/app-editors/quanta/quanta-2.0_pre1.ebuild
new file mode 100644
index 000000000000..7539ce7b9f17
--- /dev/null
+++ b/app-editors/quanta/quanta-2.0_pre1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Philippe Namias <pnamias@gentoo.org>
+
+A=${PN}-2.0-pr1.tar.bz2
+S=${WORKDIR}/quanta
+DESCRIPTION="HTML editor for KDE2"
+SRC_URI="http://prdownloads.sourceforge.net/quanta/${A}"
+HOMEPAGE="http://quanta.sourceforge.net"
+DEPEND=">=kde-base/kdelibs-2.1.1"
+
+RDEPEND=$DEPEND
+
+src_compile() {
+ local myconf
+ if [ "`use qtmt`" ]
+ then
+ myconf="--enable-mt"
+ fi
+ if [ "`use mitshm`" ]
+ then
+ myconf="$myconf --enable-mitshm"
+ fi
+ try ./configure --prefix=${KDEDIR} --host=${CHOST} $myconf
+ try make
+
+}
+
+src_install () {
+
+ try make DESTDIR=${D} install
+ dodoc AUTHORS COPYING ChangeLog NEWS README TODO
+}
+
diff --git a/kde-apps/quanta/files/digest-quanta-2.0_pre1 b/kde-apps/quanta/files/digest-quanta-2.0_pre1
new file mode 100644
index 000000000000..e41f2d2ffb86
--- /dev/null
+++ b/kde-apps/quanta/files/digest-quanta-2.0_pre1
@@ -0,0 +1 @@
+MD5 dec00150b247d40162fa3941b56c3b93 quanta-2.0-pr1.tar.bz2
diff --git a/kde-apps/quanta/quanta-2.0_pre1.ebuild b/kde-apps/quanta/quanta-2.0_pre1.ebuild
new file mode 100644
index 000000000000..7539ce7b9f17
--- /dev/null
+++ b/kde-apps/quanta/quanta-2.0_pre1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Philippe Namias <pnamias@gentoo.org>
+
+A=${PN}-2.0-pr1.tar.bz2
+S=${WORKDIR}/quanta
+DESCRIPTION="HTML editor for KDE2"
+SRC_URI="http://prdownloads.sourceforge.net/quanta/${A}"
+HOMEPAGE="http://quanta.sourceforge.net"
+DEPEND=">=kde-base/kdelibs-2.1.1"
+
+RDEPEND=$DEPEND
+
+src_compile() {
+ local myconf
+ if [ "`use qtmt`" ]
+ then
+ myconf="--enable-mt"
+ fi
+ if [ "`use mitshm`" ]
+ then
+ myconf="$myconf --enable-mitshm"
+ fi
+ try ./configure --prefix=${KDEDIR} --host=${CHOST} $myconf
+ try make
+
+}
+
+src_install () {
+
+ try make DESTDIR=${D} install
+ dodoc AUTHORS COPYING ChangeLog NEWS README TODO
+}
+