summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-office/gnucash/ChangeLog7
-rw-r--r--app-office/gnucash/files/digest-gnucash-1.6.6-r11
-rw-r--r--app-office/gnucash/gnucash-1.6.6-r1.ebuild59
3 files changed, 66 insertions, 1 deletions
diff --git a/app-office/gnucash/ChangeLog b/app-office/gnucash/ChangeLog
index 62517172a4e6..91f638c0e21a 100644
--- a/app-office/gnucash/ChangeLog
+++ b/app-office/gnucash/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-office/gnucash
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-office/gnucash/ChangeLog,v 1.3 2002/07/25 19:29:33 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/gnucash/ChangeLog,v 1.4 2002/08/08 03:23:31 leonardop Exp $
+
+*gnucash-1.6.6-r1 (07 Aug 2002)
+
+ 07 Aug 2002; L. Boshell <leonardop@gentoo.org> gnucash-1.6.6-r1.ebuild:
+ Reworked dependencies. Add support for PostgreSQL.
*gnucash-1.6.6 (28 Mar 2002)
diff --git a/app-office/gnucash/files/digest-gnucash-1.6.6-r1 b/app-office/gnucash/files/digest-gnucash-1.6.6-r1
new file mode 100644
index 000000000000..58d55d3e6dd2
--- /dev/null
+++ b/app-office/gnucash/files/digest-gnucash-1.6.6-r1
@@ -0,0 +1 @@
+MD5 f934bae9a81524502f8bbfa360c0b879 gnucash-1.6.6.tar.gz 14182135
diff --git a/app-office/gnucash/gnucash-1.6.6-r1.ebuild b/app-office/gnucash/gnucash-1.6.6-r1.ebuild
new file mode 100644
index 000000000000..072a363ed152
--- /dev/null
+++ b/app-office/gnucash/gnucash-1.6.6-r1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/gnucash/gnucash-1.6.6-r1.ebuild,v 1.1 2002/08/08 03:23:32 leonardop Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A personal finance manager"
+SRC_URI="http://download.sourceforge.net/${PN}/${P}.tar.gz"
+HOMEPAGE="http://www.gnucash.org/"
+KEYWORDS="x86"
+SLOT="0"
+LICENSE="GPL-2"
+
+RDEPEND=">=gnome-base/gnome-libs-1.4.1.2-r1
+ >=dev-libs/libxml-1.8.3
+ >=gnome-extra/gtkhtml-0.14.0-r1
+ >=gnome-extra/gal-0.13-r1
+ >=gnome-extra/guppi-0.35.5-r2
+ >=gnome-base/gnome-print-0.21
+ postgres? ( dev-db/postgresql )"
+
+DEPEND="${RDEPEND}
+ >=sys-devel/perl-5
+ >=dev-libs/slib-2.3.8
+ >=dev-lang/swig-1.3_alpha4
+ >=dev-libs/g-wrap-1.1.5
+ <gnome-base/libglade-2
+ media-libs/gdk-pixbuf
+ dev-util/guile
+ gnome-base/libghttp
+ nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}/src/guile
+ cp argv-list-converters.c argv-list-converters.c.old
+ sed -e "s,printf,g_print,g" \
+ argv-list-converters.c.old > argv-list-converters.c
+ rm argv-list-converters.c.old
+}
+
+src_compile() {
+ local myconf=""
+
+ use nls || myconf="--disable-nls"
+ use postgres && myconf="$myconf --enable-sql"
+
+ econf --enable-profile \
+ --enable-rpc \
+ $myconf || die "Configuration failed"
+
+ make || die # Doesn't work with make -j 4 (hallski)
+}
+
+src_install () {
+ einstall || die "Installation failed"
+
+ dodoc ABOUT-NLS AUTHORS COPYING ChangeLog HACKING NEWS README* TODO
+}