summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-arch/xar/ChangeLog9
-rw-r--r--app-arch/xar/Manifest4
-rw-r--r--app-arch/xar/files/digest-xar-200504231
-rw-r--r--app-arch/xar/metadata.xml10
-rw-r--r--app-arch/xar/xar-20050423.ebuild32
5 files changed, 56 insertions, 0 deletions
diff --git a/app-arch/xar/ChangeLog b/app-arch/xar/ChangeLog
new file mode 100644
index 000000000000..221b5de87edb
--- /dev/null
+++ b/app-arch/xar/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for app-arch/xar
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/xar/ChangeLog,v 1.1 2005/04/24 04:57:07 kito Exp $
+
+*xar-20050423 (23 Apr 2005)
+
+ 23 Apr 2005; Kito <kito@gentoo.org> +metadata.xml, +xar-20050423.ebuild:
+ initial import, ~amd64 ~ppc ~ppc64 ~ppc-macos ~sparc ~x86 keywords.
+
diff --git a/app-arch/xar/Manifest b/app-arch/xar/Manifest
new file mode 100644
index 000000000000..09885c018ef8
--- /dev/null
+++ b/app-arch/xar/Manifest
@@ -0,0 +1,4 @@
+MD5 153b9d7d8858d0390f9a35e774ac2830 ChangeLog 370
+MD5 66261856e93724759f19cabcb0e3e3cc metadata.xml 933
+MD5 b5b187ae4e69f07d3dd506345664e792 xar-20050423.ebuild 884
+MD5 659c72ad6f5348b02f615073bc38f5f8 files/digest-xar-20050423 64
diff --git a/app-arch/xar/files/digest-xar-20050423 b/app-arch/xar/files/digest-xar-20050423
new file mode 100644
index 000000000000..8d8c1c2e75f1
--- /dev/null
+++ b/app-arch/xar/files/digest-xar-20050423
@@ -0,0 +1 @@
+MD5 90cbd54e52ecd915ed4f3b5cd57ef757 xar-20050423.tar.gz 108502
diff --git a/app-arch/xar/metadata.xml b/app-arch/xar/metadata.xml
new file mode 100644
index 000000000000..ffc87fe58ea1
--- /dev/null
+++ b/app-arch/xar/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+ <email>kito@gentoo.org</email>
+<description>The XAR project aims to provide an easily extensible archive format. </description>
+</maintainer>
+<longdescription>The XAR project aims to provide an easily extensible archive format. Important design decisions include an easily extensible XML table of contents for random access to archived files, storing the toc at the beginning of the archive to allow for efficient handling of streamed archives, the ability to handle files of arbitrarily large sizes, the ability to choose independent encodings for individual files in the archive, the ability to store checksums for individual files in both compressed and uncompressed form, and the ability to query the table of content's rich meta-data.</longdescription>
+</pkgmetadata>
diff --git a/app-arch/xar/xar-20050423.ebuild b/app-arch/xar/xar-20050423.ebuild
new file mode 100644
index 000000000000..220b71ad83dc
--- /dev/null
+++ b/app-arch/xar/xar-20050423.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/xar/xar-20050423.ebuild,v 1.1 2005/04/24 04:57:07 kito Exp $
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="The XAR project aims to provide an easily extensible archive format."
+HOMEPAGE="http://www.opendarwin.org/projects/xar/"
+SRC_URI="http://www.opendarwin.org/projects/xar/${P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~ppc-macos ~sparc ~x86"
+IUSE="debug"
+
+RDEPEND="virtual/libc"
+DEPEND="${RDEPEND}
+ dev-libs/openssl
+ dev-libs/libxml2
+ sys-libs/zlib"
+
+src_compile() {
+ use debug && myconf="${myconf} --enable-symbols"
+ use ppc64 && myconf="${myconf} --enable-64bit"
+ use sparc && myconf="${myconf} --enable-64bit-vis"
+ econf ${myconf} || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+}