summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--mail-client/roundcube/ChangeLog7
-rw-r--r--mail-client/roundcube/Manifest4
-rw-r--r--mail-client/roundcube/roundcube-0.2.1.ebuild83
3 files changed, 92 insertions, 2 deletions
diff --git a/mail-client/roundcube/ChangeLog b/mail-client/roundcube/ChangeLog
index 20805fd4284f..676caf1064b4 100644
--- a/mail-client/roundcube/ChangeLog
+++ b/mail-client/roundcube/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for mail-client/roundcube
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/roundcube/ChangeLog,v 1.3 2009/01/28 14:57:13 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/roundcube/ChangeLog,v 1.4 2009/04/13 08:27:00 hollow Exp $
+
+*roundcube-0.2.1 (13 Apr 2009)
+
+ 13 Apr 2009; Benedikt Böhm <hollow@gentoo.org> +roundcube-0.2.1.ebuild:
+ version bump wrt #262894
28 Jan 2009; Peter Volkov <pva@gentoo.org> roundcube-0.2.ebuild:
Fixed typo. For spell checking we need spell in php, not ssl.
diff --git a/mail-client/roundcube/Manifest b/mail-client/roundcube/Manifest
index 53459d6da623..1708a295004f 100644
--- a/mail-client/roundcube/Manifest
+++ b/mail-client/roundcube/Manifest
@@ -1,5 +1,7 @@
AUX postinstall-en.txt 2513 RMD160 c2a04efcdd4007642221797a10877c2fc57ad874 SHA1 8bc888b2944694bbbadeddfe6f193c3a8a995a87 SHA256 5c1fa9d43f29158521188aae417654f968fb41662c46721b8183728df37eb4c4
DIST roundcubemail-0.2-stable.tar.gz 1672535 RMD160 13f252bf334d7fb7f84d3ba92d72ce54c595a4ca SHA1 8abefd7b442e0fa95b72d757091d60979054d624 SHA256 86de36fec5cfc4217d5376fa74e27645d3c414ad18fa8554abc909709f1a9107
+DIST roundcubemail-0.2.1.tar.gz 1664897 RMD160 2114012a4ec4359c35256f2ef51861ded2d12efd SHA1 3d1e7bb256c56aac6434e10590692a61bae2553a SHA256 44562941bd08091b3b8a106ea3256c42acc688433c856e406b3e5347d3cf01bd
+EBUILD roundcube-0.2.1.ebuild 2602 RMD160 4a028040bc3a6d8c6fe7efe30bb0d80a4c40d8d6 SHA1 db9adc1c866c9d4b54f6664c8a8b76d8acf8b4fb SHA256 ef2c22d046a38c39fe2d9a837f13cb4056a65a2f7d7092b3376d508ae502472b
EBUILD roundcube-0.2.ebuild 2604 RMD160 66142f6df5054c4f394bfb84696679be03644df5 SHA1 808a2081b37ee678c5918290dfca1e0f3401214b SHA256 6d285eb0e5d2b28f25b1ccb8793edaced6c6dc63a50491ceff184537656cf06f
-MISC ChangeLog 634 RMD160 8427929ff1574eed84227abd43044a49c68a5bbb SHA1 3cab5ec7c5e97dec9c8749f7faa8d5389568d46b SHA256 cdcaa93a16d6d7aff65e5c1dc78a11fe23683744f6a66f406027e45110d231a8
+MISC ChangeLog 772 RMD160 7a9ecfa3de2906abf5a3627aeb8feef6aa96f93b SHA1 54cff5295ef4dd9b7d2aeb9dc9b01ed5c10c47e9 SHA256 2bec8fd7c6577963d2ae3f9c2d01cf76842f1ad6fd260e78ba627cc278fc0544
MISC metadata.xml 161 RMD160 d47e924599b33a35a50f4c9f5564d325c271f83b SHA1 5b91a6d8d06d3dca2d774425befba30caca51507 SHA256 9cd891fcf0af580e98b62d2f4ded9e53671599f5a7aafd5dce692b996d2a83f4
diff --git a/mail-client/roundcube/roundcube-0.2.1.ebuild b/mail-client/roundcube/roundcube-0.2.1.ebuild
new file mode 100644
index 000000000000..2b9ebaea086d
--- /dev/null
+++ b/mail-client/roundcube/roundcube-0.2.1.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/roundcube/roundcube-0.2.1.ebuild,v 1.1 2009/04/13 08:27:00 hollow Exp $
+
+MY_PN="${PN}mail"
+MY_P="${MY_PN}-${PV}"
+
+inherit eutils webapp depend.php depend.apache
+
+DESCRIPTION="A browser-based multilingual IMAP client with an application-like user interface"
+HOMEPAGE="http://roundcube.net"
+SRC_URI="mirror://sourceforge/${MY_PN}/${MY_P}.tar.gz"
+
+# roundcube is GPL-licensed, the rest of the licenses here are
+# for bundled PEAR components, googiespell and utf8.class.php
+LICENSE="GPL-2 BSD PHP-2.02 PHP-3 MIT public-domain"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="ldap mysql postgres sqlite ssl spell"
+
+DEPEND=""
+RDEPEND="dev-php/PEAR-PEAR"
+
+need_httpd_cgi
+need_php_httpd
+
+S=${WORKDIR}/${MY_P}
+
+pkg_setup() {
+ local flags="crypt iconv imap pcre session unicode"
+ use ldap && flags="${flags} ldap"
+ use ssl && flags="${flags} ssl"
+ use spell && flags="${flags} curl spell"
+
+ # check for required PHP features
+ if ! use mysql && ! use postgres && ! use sqlite ; then
+ local dbflags="mysql mysqli postgres sqlite"
+ if ! PHPCHECKNODIE="yes" require_php_with_use ${flags} || \
+ ! PHPCHECKNODIE="yes" require_php_with_any_use ${dbflags} ; then
+ die "Re-install ${PHP_PKG} with ${flags} and at least one of ${dbflags} in USE."
+ fi
+ else
+ for db in postgres sqlite ; do
+ use ${db} && flags="${flags} ${db}"
+ done
+ if ! PHPCHECKNODIE="yes" require_php_with_use ${flags} || \
+ ( use mysql && ! PHPCHECKNODIE="yes" require_php_with_any_use mysql mysqli ) ; then
+ local diemsg="Re-install ${PHP_PKG} with ${flags}"
+ use mysql && diemsg="${diemsg} and at least one of mysql mysqli"
+ die "${diemsg} in USE"
+ fi
+ fi
+
+ # add some warnings about optional functionality
+ if ! PHPCHECKNODIE="yes" require_php_with_any_use gd gd-external ; then
+ ewarn "IMAP quota display will not work correctly without GD support in PHP."
+ ewarn "Recompile PHP with either gd or gd-external in USE if you want this feature."
+ ewarn
+ fi
+
+ webapp_pkg_setup
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ mv config/db.inc.php{.dist,}
+ mv config/main.inc.php{.dist,}
+}
+
+src_install () {
+ webapp_src_preinst
+ dodoc CHANGELOG INSTALL README UPGRADING
+
+ cp -R [[:lower:]]* SQL "${D}/${MY_HTDOCSDIR}"
+
+ webapp_serverowned "${MY_HTDOCSDIR}"/logs
+ webapp_serverowned "${MY_HTDOCSDIR}"/temp
+
+ webapp_configfile "${MY_HTDOCSDIR}"/config/{db,main}.inc.php
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+ webapp_postupgrade_txt en UPGRADING
+ webapp_src_install
+}