summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-libs/qt-gui/ChangeLog8
-rw-r--r--x11-libs/qt-gui/metadata.xml16
-rw-r--r--x11-libs/qt-gui/qt-gui-4.7.0.ebuild159
-rw-r--r--x11-libs/qt-multimedia/ChangeLog8
-rw-r--r--x11-libs/qt-multimedia/qt-multimedia-4.7.0.ebuild49
-rw-r--r--x11-libs/qt-opengl/ChangeLog8
-rw-r--r--x11-libs/qt-opengl/metadata.xml2
-rw-r--r--x11-libs/qt-opengl/qt-opengl-4.7.0.ebuild48
-rw-r--r--x11-libs/qt-phonon/ChangeLog8
-rw-r--r--x11-libs/qt-phonon/qt-phonon-4.7.0.ebuild39
-rw-r--r--x11-libs/qt-qt3support/ChangeLog8
-rw-r--r--x11-libs/qt-qt3support/qt-qt3support-4.7.0.ebuild40
-rw-r--r--x11-libs/qt-script/ChangeLog8
-rw-r--r--x11-libs/qt-script/metadata.xml2
-rw-r--r--x11-libs/qt-script/qt-script-4.7.0.ebuild46
-rw-r--r--x11-libs/qt-sql/ChangeLog8
-rw-r--r--x11-libs/qt-sql/qt-sql-4.7.0.ebuild71
-rw-r--r--x11-libs/qt-test/ChangeLog8
-rw-r--r--x11-libs/qt-test/qt-test-4.7.0.ebuild34
-rw-r--r--x11-libs/qt-webkit/ChangeLog8
-rw-r--r--x11-libs/qt-webkit/qt-webkit-4.7.0.ebuild48
-rw-r--r--x11-libs/qt-xmlpatterns/ChangeLog8
-rw-r--r--x11-libs/qt-xmlpatterns/qt-xmlpatterns-4.7.0.ebuild36
23 files changed, 652 insertions, 18 deletions
diff --git a/x11-libs/qt-gui/ChangeLog b/x11-libs/qt-gui/ChangeLog
index 01dba3491515..4e1545c884fe 100644
--- a/x11-libs/qt-gui/ChangeLog
+++ b/x11-libs/qt-gui/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/qt-gui
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-gui/ChangeLog,v 1.111 2010/09/13 21:20:24 klausman Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-gui/ChangeLog,v 1.112 2010/09/21 14:55:53 tampakrap Exp $
+
+*qt-gui-4.7.0 (21 Sep 2010)
+
+ 21 Sep 2010; Theo Chatzimichos <tampakrap@gentoo.org>
+ +qt-gui-4.7.0.ebuild:
+ Version bump
13 Sep 2010; Tobias Klausmann <klausman@gentoo.org> qt-gui-4.6.2.ebuild:
Stable on alpha, bug #297299
diff --git a/x11-libs/qt-gui/metadata.xml b/x11-libs/qt-gui/metadata.xml
index e82f687f2484..ec335884371d 100644
--- a/x11-libs/qt-gui/metadata.xml
+++ b/x11-libs/qt-gui/metadata.xml
@@ -3,17 +3,17 @@
<pkgmetadata>
<herd>qt</herd>
<use>
+ <flag name='egl'>Use EGL instead of default GLX to manage OpenGL
+ contexts on the desktop</flag>
<flag name='exceptions'>Add support for exceptions - like catching them
inside the event loop (recommended by Nokia)</flag>
- <flag name='glib'>
- Enable <pkg>dev-libs/glib</pkg> eventloop support
- </flag>
+ <flag name='glib'>Enable <pkg>dev-libs/glib</pkg> eventloop support</flag>
<flag name='qt3support'>Enable the Qt3Support libraries for Qt4. Note that
- this does not mean you can compile pure Qt3 programs with Qt4.
- </flag>
- <flag name='raster'>
- Use the alternative raster graphicssystem as default rendering engine
- </flag>
+ this does not mean you can compile pure Qt3 programs with Qt4.</flag>
+ <flag name="private-headers">Install Qt declarative private headers
+ required by Qt-creator QmlDesigner and QmlInspector plugins"</flag>
+ <flag name='raster'>Use the alternative raster graphicssystem as default
+ rendering engine</flag>
<flag name='trace'>
Build the new 'trace' graphicsssytem engine which allows to record
all drawing operations into a trace buffer. Later it can be replayed
diff --git a/x11-libs/qt-gui/qt-gui-4.7.0.ebuild b/x11-libs/qt-gui/qt-gui-4.7.0.ebuild
new file mode 100644
index 000000000000..7c7410bdce87
--- /dev/null
+++ b/x11-libs/qt-gui/qt-gui-4.7.0.ebuild
@@ -0,0 +1,159 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-gui/qt-gui-4.7.0.ebuild,v 1.1 2010/09/21 14:55:53 tampakrap Exp $
+
+EAPI="2"
+inherit confutils qt4-build
+
+DESCRIPTION="The GUI module for the Qt toolkit"
+SLOT="4"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE="+accessibility cups dbus egl +glib gtk mng nas nis +raster tiff trace
+private-headers qt3support xinerama"
+
+RDEPEND="media-libs/fontconfig
+ media-libs/freetype:2
+ media-libs/jpeg:0
+ media-libs/libpng
+ sys-libs/zlib
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXrandr
+ x11-libs/libXcursor
+ x11-libs/libXfont
+ x11-libs/libSM
+ x11-libs/libXi
+ ~x11-libs/qt-core-${PV}[debug=,glib=,qt3support=]
+ ~x11-libs/qt-script-${PV}[debug=]
+ cups? ( net-print/cups )
+ dbus? ( ~x11-libs/qt-dbus-${PV}[debug=] )
+ gtk? ( x11-libs/gtk+:2 )
+ mng? ( >=media-libs/libmng-1.0.9 )
+ nas? ( >=media-libs/nas-1.5 )
+ tiff? ( media-libs/tiff )
+ xinerama? ( x11-libs/libXinerama )"
+DEPEND="${RDEPEND}
+ xinerama? ( x11-proto/xineramaproto )
+ x11-proto/xextproto
+ x11-proto/inputproto"
+PDEPEND="qt3support? ( ~x11-libs/qt-qt3support-${PV}[debug=] )"
+
+pkg_setup() {
+ if ! use qt3support; then
+ ewarn "WARNING: if you need 'qtconfig', you _must_ enable qt3support."
+ fi
+
+ confutils_use_depend_all gtk glib
+
+ QT4_TARGET_DIRECTORIES="
+ src/gui
+ src/scripttools
+ tools/designer
+ tools/linguist/linguist
+ src/plugins/imageformats/gif
+ src/plugins/imageformats/ico
+ src/plugins/imageformats/jpeg
+ src/plugins/inputmethods"
+
+ QT4_EXTRACT_DIRECTORIES="
+ include
+ src
+ tools/linguist/phrasebooks
+ tools/linguist/shared
+ tools/shared"
+
+ use dbus && QT4_TARGET_DIRECTORIES="${QT4_TARGET_DIRECTORIES} tools/qdbus/qdbusviewer"
+ use mng && QT4_TARGET_DIRECTORIES="${QT4_TARGET_DIRECTORIES} src/plugins/imageformats/mng"
+ use tiff && QT4_TARGET_DIRECTORIES="${QT4_TARGET_DIRECTORIES} src/plugins/imageformats/tiff"
+ use accessibility && QT4_TARGET_DIRECTORIES="${QT4_TARGET_DIRECTORIES} src/plugins/accessible/widgets"
+ use trace && QT4_TARGET_DIRECTORIES="${QT4_TARGET_DIRECTORIES} src/plugins/graphicssystems/trace"
+
+ QT4_EXTRACT_DIRECTORIES="${QT4_TARGET_DIRECTORIES} ${QT4_EXTRACT_DIRECTORIES}"
+
+ qt4-build_pkg_setup
+}
+
+src_prepare() {
+ qt4-build_src_prepare
+
+ # Don't build plugins this go around, because they depend on qt3support lib
+ sed -i -e "s:CONFIG(shared:# &:g" "${S}"/tools/designer/src/src.pro
+}
+
+src_configure() {
+ export PATH="${S}/bin:${PATH}"
+ export LD_LIBRARY_PATH="${S}/lib:${LD_LIBRARY_PATH}"
+
+ myconf="$(qt_use accessibility)
+ $(qt_use cups)
+ $(qt_use glib)
+ $(qt_use mng libmng system)
+ $(qt_use nis)
+ $(qt_use tiff libtiff system)
+ $(qt_use dbus qdbus)
+ $(qt_use dbus)
+ $(qt_use egl)
+ $(qt_use qt3support)
+ $(qt_use gtk gtkstyle)
+ $(qt_use xinerama)"
+
+ use nas && myconf="${myconf} -system-nas-sound"
+ use raster && myconf="${myconf} -graphicssystem raster"
+
+ myconf="${myconf} -qt-gif -system-libpng -system-libjpeg
+ -no-sql-mysql -no-sql-psql -no-sql-ibase -no-sql-sqlite -no-sql-sqlite2
+ -no-sql-odbc -xrender -xrandr -xkb -xshape -sm -no-svg -no-webkit
+ -no-phonon -no-opengl"
+
+ qt4-build_src_configure
+}
+
+src_install() {
+ QCONFIG_ADD="x11sm xshape xcursor xfixes xrandr xrender xkb fontconfig
+ $(usev accessibility) $(usev xinerama) $(usev cups) $(usev nas)
+ gif png system-png system-jpeg
+ $(use mng && echo system-mng)
+ $(use tiff && echo system-tiff)"
+ QCONFIG_REMOVE="no-gif no-png"
+ QCONFIG_DEFINE="$(use accessibility && echo QT_ACCESSIBILITY)
+ $(use cups && echo QT_CUPS) QT_FONTCONFIG QT_IMAGEFORMAT_JPEG
+ $(use mng && echo QT_IMAGEFORMAT_MNG)
+ $(use nas && echo QT_NAS)
+ $(use nis && echo QT_NIS) QT_IMAGEFORMAT_PNG QT_SESSIONMANAGER QT_SHAPE
+ $(use tiff && echo QT_IMAGEFORMAT_TIFF) QT_XCURSOR
+ $(use xinerama && echo QT_XINERAMA) QT_XFIXES QT_XKB QT_XRANDR QT_XRENDER"
+
+ qt4-build_src_install
+
+ # remove some unnecessary headers
+ rm -f "${D}${QTHEADERDIR}"/{Qt,QtGui}/{qmacstyle_mac.h,qwindowdefs_win.h} \
+ "${D}${QTHEADERDIR}"/QtGui/QMacStyle
+
+ # qt-creator
+ # some qt-creator headers are located
+ # under /usr/include/qt4/QtDesigner/private.
+ # those headers are just includes of the headers
+ # which are located under tools/designer/src/lib/*
+ # So instead of installing both, we create the private folder
+ # and drop tools/designer/src/lib/* headers in it.
+ dodir /usr/include/qt4/QtDesigner/private/ || die
+ insinto /usr/include/qt4/QtDesigner/private/
+ doins "${S}"/tools/designer/src/lib/shared/* || die
+ doins "${S}"/tools/designer/src/lib/sdk/* || die
+ #install private headers
+ if use private-headers; then
+ insinto ${QTHEADERDIR}/QtGui/private
+ find "${S}"/src/gui -type f -name "*_p.h" -exec doins {} \;
+ fi
+
+ # install correct designer and linguist icons, bug 241208
+ doicon tools/linguist/linguist/images/icons/linguist-128-32.png \
+ tools/designer/src/designer/images/designer.png || die
+ # Note: absolute image path required here!
+ make_desktop_entry /usr/bin/linguist Linguist \
+ /usr/share/pixmaps/linguist-128-32.png \
+ 'Qt;Development;GUIDesigner' || die
+ make_desktop_entry /usr/bin/designer Designer \
+ /usr/share/pixmaps/designer.png \
+ 'Qt;Development;GUIDesigner' || die
+}
diff --git a/x11-libs/qt-multimedia/ChangeLog b/x11-libs/qt-multimedia/ChangeLog
index 358ba2887a85..dea04a6f0d39 100644
--- a/x11-libs/qt-multimedia/ChangeLog
+++ b/x11-libs/qt-multimedia/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/qt-multimedia
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-multimedia/ChangeLog,v 1.23 2010/09/13 21:20:47 klausman Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-multimedia/ChangeLog,v 1.24 2010/09/21 14:52:12 tampakrap Exp $
+
+*qt-multimedia-4.7.0 (21 Sep 2010)
+
+ 21 Sep 2010; Theo Chatzimichos <tampakrap@gentoo.org>
+ +qt-multimedia-4.7.0.ebuild:
+ Version bump
13 Sep 2010; Tobias Klausmann <klausman@gentoo.org>
qt-multimedia-4.6.2.ebuild:
diff --git a/x11-libs/qt-multimedia/qt-multimedia-4.7.0.ebuild b/x11-libs/qt-multimedia/qt-multimedia-4.7.0.ebuild
new file mode 100644
index 000000000000..c6affb7bfa59
--- /dev/null
+++ b/x11-libs/qt-multimedia/qt-multimedia-4.7.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-multimedia/qt-multimedia-4.7.0.ebuild,v 1.1 2010/09/21 14:52:12 tampakrap Exp $
+
+EAPI="2"
+inherit qt4-build
+
+DESCRIPTION="The Qt multimedia module"
+SLOT="4"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="iconv"
+
+DEPEND="media-libs/alsa-lib
+ ~x11-libs/qt-core-${PV}[debug=]
+ ~x11-libs/qt-gui-${PV}[debug=]"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ QT4_TARGET_DIRECTORIES="src/multimedia"
+ QT4_EXTRACT_DIRECTORIES="${QT4_TARGET_DIRECTORIES}
+ include/Qt/
+ include/QtCore/
+ include/QtGui/
+ include/QtMultimedia/
+ include/QtNetwork/
+ src/src.pro
+ src/3rdparty/
+ src/corelib/
+ src/gui/
+ src/network/
+ src/plugins/
+ src/tools/"
+
+ qt4-build_pkg_setup
+}
+
+src_configure() {
+ myconf="${myconf} $(qt_use iconv) -no-xkb -no-fontconfig -no-xrender
+ -no-xrandr -no-xfixes -no-xcursor -no-xinerama -no-xshape -no-sm
+ -no-opengl -no-nas-sound -no-dbus -no-cups -no-nis -no-gif -no-libpng
+ -no-libmng -no-libjpeg -no-openssl -system-zlib -no-webkit -no-phonon
+ -no-xmlpatterns -no-freetype -no-libtiff -no-accessibility
+ -no-fontconfig -no-sql-mysql -no-sql-psql -no-sql-ibase -no-sql-sqlite
+ -no-sql-sqlite2 -no-sql-odbc -no-glib -no-opengl -no-svg -no-gtkstyle
+ -no-phonon-backend -no-script -no-scripttools -no-cups -no-xsync
+ -no-xinput"
+
+ qt4-build_src_configure
+}
diff --git a/x11-libs/qt-opengl/ChangeLog b/x11-libs/qt-opengl/ChangeLog
index 95835849d5f7..11002db9a47a 100644
--- a/x11-libs/qt-opengl/ChangeLog
+++ b/x11-libs/qt-opengl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/qt-opengl
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-opengl/ChangeLog,v 1.70 2010/09/17 11:10:53 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-opengl/ChangeLog,v 1.71 2010/09/21 14:58:11 tampakrap Exp $
+
+*qt-opengl-4.7.0 (21 Sep 2010)
+
+ 21 Sep 2010; Theo Chatzimichos <tampakrap@gentoo.org>
+ +qt-opengl-4.7.0.ebuild:
+ Version bump
17 Sep 2010; Tomáš Chvátal <scarabeus@gentoo.org>
qt-opengl-4.5.3-r1.ebuild, qt-opengl-4.6.2.ebuild, qt-opengl-4.6.3.ebuild:
diff --git a/x11-libs/qt-opengl/metadata.xml b/x11-libs/qt-opengl/metadata.xml
index 753c3c20a9d3..dcffcd29a32d 100644
--- a/x11-libs/qt-opengl/metadata.xml
+++ b/x11-libs/qt-opengl/metadata.xml
@@ -3,6 +3,8 @@
<pkgmetadata>
<herd>qt</herd>
<use>
+ <flag name='egl'>Use EGL instead of default GLX to manage OpenGL
+ contexts on the desktop</flag>
<flag name='exceptions'>Add support for exceptions - like catching them
inside the event loop (recommended by Nokia)</flag>
<flag name='qt3support'>Enable the Qt3Support libraries for Qt4</flag>
diff --git a/x11-libs/qt-opengl/qt-opengl-4.7.0.ebuild b/x11-libs/qt-opengl/qt-opengl-4.7.0.ebuild
new file mode 100644
index 000000000000..13bc499ff157
--- /dev/null
+++ b/x11-libs/qt-opengl/qt-opengl-4.7.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-opengl/qt-opengl-4.7.0.ebuild,v 1.1 2010/09/21 14:58:11 tampakrap Exp $
+
+EAPI="2"
+inherit qt4-build
+
+DESCRIPTION="The OpenGL module for the Qt toolkit"
+SLOT="4"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE="egl qt3support"
+
+DEPEND="~x11-libs/qt-core-${PV}[debug=,qt3support=]
+ ~x11-libs/qt-gui-${PV}[debug=,egl=,qt3support=]
+ virtual/opengl"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ QT4_TARGET_DIRECTORIES="
+ src/opengl
+ src/plugins/graphicssystems/opengl"
+
+ QT4_EXTRACT_DIRECTORIES="
+ include/QtCore
+ include/QtGui
+ include/QtOpenGL
+ src/corelib
+ src/gui
+ src/opengl
+ src/plugins
+ src/3rdparty"
+
+ QCONFIG_ADD="opengl"
+ QCONFIG_DEFINE="QT_OPENGL"
+
+ qt4-build_pkg_setup
+}
+
+src_configure() {
+ myconf="${myconf} -opengl
+ $(qt_use qt3support)
+ $(qt_use egl)"
+
+ qt4-build_src_configure
+
+ # Not building tools/designer/src/plugins/tools/view3d as it's
+ # commented out of the build in the source
+}
diff --git a/x11-libs/qt-phonon/ChangeLog b/x11-libs/qt-phonon/ChangeLog
index 3a2228abe56c..ca911b95691e 100644
--- a/x11-libs/qt-phonon/ChangeLog
+++ b/x11-libs/qt-phonon/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/qt-phonon
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-phonon/ChangeLog,v 1.74 2010/09/13 21:21:34 klausman Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-phonon/ChangeLog,v 1.75 2010/09/21 14:57:13 tampakrap Exp $
+
+*qt-phonon-4.7.0 (21 Sep 2010)
+
+ 21 Sep 2010; Theo Chatzimichos <tampakrap@gentoo.org>
+ +qt-phonon-4.7.0.ebuild:
+ Version bump
13 Sep 2010; Tobias Klausmann <klausman@gentoo.org>
qt-phonon-4.6.2.ebuild:
diff --git a/x11-libs/qt-phonon/qt-phonon-4.7.0.ebuild b/x11-libs/qt-phonon/qt-phonon-4.7.0.ebuild
new file mode 100644
index 000000000000..87ad8d3a0225
--- /dev/null
+++ b/x11-libs/qt-phonon/qt-phonon-4.7.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-phonon/qt-phonon-4.7.0.ebuild,v 1.1 2010/09/21 14:57:13 tampakrap Exp $
+
+EAPI="2"
+inherit qt4-build
+
+DESCRIPTION="The Phonon module for the Qt toolkit"
+SLOT="4"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE="dbus"
+
+DEPEND="~x11-libs/qt-gui-${PV}[debug=,glib,qt3support]
+ !kde-base/phonon-kde
+ !kde-base/phonon-xine
+ !media-sound/phonon
+ media-libs/gstreamer
+ media-plugins/gst-plugins-meta
+ dbus? ( ~x11-libs/qt-dbus-${PV}[debug=] )"
+RDEPEND="${DEPEND}"
+
+QT4_TARGET_DIRECTORIES="
+ src/phonon
+ src/plugins/phonon
+ tools/designer/src/plugins/phononwidgets"
+QT4_EXTRACT_DIRECTORIES="${QT4_TARGET_DIRECTORIES}
+ include/
+ src
+ tools"
+
+QCONFIG_ADD="phonon"
+QCONFIG_DEFINE="QT_GSTREAMER"
+
+src_configure() {
+ myconf="${myconf} -phonon -phonon-backend -no-opengl -no-svg
+ $(qt_use dbus qdbus)"
+
+ qt4-build_src_configure
+}
diff --git a/x11-libs/qt-qt3support/ChangeLog b/x11-libs/qt-qt3support/ChangeLog
index 6908d225442f..6ef11bbbd97d 100644
--- a/x11-libs/qt-qt3support/ChangeLog
+++ b/x11-libs/qt-qt3support/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/qt-qt3support
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-qt3support/ChangeLog,v 1.74 2010/09/13 21:21:57 klausman Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-qt3support/ChangeLog,v 1.75 2010/09/21 14:59:27 tampakrap Exp $
+
+*qt-qt3support-4.7.0 (21 Sep 2010)
+
+ 21 Sep 2010; Theo Chatzimichos <tampakrap@gentoo.org>
+ +qt-qt3support-4.7.0.ebuild:
+ Version bump
13 Sep 2010; Tobias Klausmann <klausman@gentoo.org>
qt-qt3support-4.6.2.ebuild:
diff --git a/x11-libs/qt-qt3support/qt-qt3support-4.7.0.ebuild b/x11-libs/qt-qt3support/qt-qt3support-4.7.0.ebuild
new file mode 100644
index 000000000000..82331c127277
--- /dev/null
+++ b/x11-libs/qt-qt3support/qt-qt3support-4.7.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-qt3support/qt-qt3support-4.7.0.ebuild,v 1.1 2010/09/21 14:59:27 tampakrap Exp $
+
+EAPI="2"
+inherit qt4-build
+
+DESCRIPTION="The Qt3 support module for the Qt toolkit"
+SLOT="4"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE="+accessibility kde phonon"
+
+DEPEND="~x11-libs/qt-core-${PV}[debug=,qt3support]
+ ~x11-libs/qt-gui-${PV}[accessibility=,debug=,qt3support]
+ ~x11-libs/qt-sql-${PV}[debug=,qt3support]
+ phonon? (
+ !kde? ( || ( ~x11-libs/qt-phonon-${PV}[debug=]
+ media-sound/phonon[gstreamer] ) )
+ kde? ( media-sound/phonon[gstreamer] ) )"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ QT4_TARGET_DIRECTORIES="
+ src/qt3support
+ src/tools/uic3
+ tools/designer/src/plugins/widgets
+ tools/qtconfig
+ tools/porting"
+ QT4_EXTRACT_DIRECTORIES="src include tools"
+
+ qt4-build_pkg_setup
+}
+
+src_configure() {
+ myconf="${myconf} -qt3support
+ $(qt_use phonon gstreamer)
+ $(qt_use phonon)
+ $(qt_use accessibility)"
+ qt4-build_src_configure
+}
diff --git a/x11-libs/qt-script/ChangeLog b/x11-libs/qt-script/ChangeLog
index cddaf09ec67f..bb4eb9a6a2f4 100644
--- a/x11-libs/qt-script/ChangeLog
+++ b/x11-libs/qt-script/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/qt-script
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-script/ChangeLog,v 1.73 2010/09/13 21:22:19 klausman Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-script/ChangeLog,v 1.74 2010/09/21 15:01:32 tampakrap Exp $
+
+*qt-script-4.7.0 (21 Sep 2010)
+
+ 21 Sep 2010; Theo Chatzimichos <tampakrap@gentoo.org>
+ +qt-script-4.7.0.ebuild:
+ Version bump
13 Sep 2010; Tobias Klausmann <klausman@gentoo.org>
qt-script-4.6.2.ebuild:
diff --git a/x11-libs/qt-script/metadata.xml b/x11-libs/qt-script/metadata.xml
index e34a8eb7ed3e..b7e05cc84676 100644
--- a/x11-libs/qt-script/metadata.xml
+++ b/x11-libs/qt-script/metadata.xml
@@ -5,5 +5,7 @@
<use>
<flag name='exceptions'>Add support for exceptions - like catching them
inside the event loop (recommended by Nokia)</flag>
+ <flag name="private-headers">Install Qt declarative private headers
+ required by Qt-creator QmlDesigner and QmlInspector plugins"</flag>
</use>
</pkgmetadata>
diff --git a/x11-libs/qt-script/qt-script-4.7.0.ebuild b/x11-libs/qt-script/qt-script-4.7.0.ebuild
new file mode 100644
index 000000000000..158bb810c375
--- /dev/null
+++ b/x11-libs/qt-script/qt-script-4.7.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-script/qt-script-4.7.0.ebuild,v 1.1 2010/09/21 15:01:32 tampakrap Exp $
+
+EAPI="2"
+inherit qt4-build
+
+DESCRIPTION="The ECMAScript module for the Qt toolkit"
+SLOT="4"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE="iconv private-headers"
+
+DEPEND="~x11-libs/qt-core-${PV}[debug=]"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ QT4_TARGET_DIRECTORIES="src/script/"
+ QT4_EXTRACT_DIRECTORIES="${QT4_TARGET_DIRECTORIES}
+ include/Qt/
+ include/QtCore/
+ include/QtScript/
+ src/3rdparty/javascriptcore/
+ src/corelib/"
+
+ qt4-build_pkg_setup
+}
+
+src_configure() {
+ myconf="${myconf} $(qt_use iconv) -no-xkb -no-fontconfig -no-xrender
+ -no-xrandr -no-xfixes -no-xcursor -no-xinerama -no-xshape -no-sm
+ -no-opengl -no-nas-sound -no-dbus -no-cups -no-nis -no-gif -no-libpng
+ -no-libmng -no-libjpeg -no-openssl -system-zlib -no-webkit -no-phonon
+ -no-qt3support -no-xmlpatterns -no-freetype -no-libtiff
+ -no-accessibility -no-fontconfig -no-glib -no-opengl -no-svg
+ -no-gtkstyle"
+ qt4-build_src_configure
+}
+
+src_install() {
+ qt4-build_src_install
+ #install private headers
+ if use private-headers; then
+ insinto ${QTHEADERDIR}/QtScript/private
+ find "${S}"/src/script -type f -name "*_p.h" -exec doins {} \;
+ fi
+}
diff --git a/x11-libs/qt-sql/ChangeLog b/x11-libs/qt-sql/ChangeLog
index 2f66e221c378..48d948c84ef9 100644
--- a/x11-libs/qt-sql/ChangeLog
+++ b/x11-libs/qt-sql/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/qt-sql
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-sql/ChangeLog,v 1.89 2010/09/13 21:22:42 klausman Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-sql/ChangeLog,v 1.90 2010/09/21 15:02:47 tampakrap Exp $
+
+*qt-sql-4.7.0 (21 Sep 2010)
+
+ 21 Sep 2010; Theo Chatzimichos <tampakrap@gentoo.org>
+ +qt-sql-4.7.0.ebuild:
+ Version bump
13 Sep 2010; Tobias Klausmann <klausman@gentoo.org> qt-sql-4.6.2.ebuild:
Stable on alpha, bug #297299
diff --git a/x11-libs/qt-sql/qt-sql-4.7.0.ebuild b/x11-libs/qt-sql/qt-sql-4.7.0.ebuild
new file mode 100644
index 000000000000..47513af46954
--- /dev/null
+++ b/x11-libs/qt-sql/qt-sql-4.7.0.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-sql/qt-sql-4.7.0.ebuild,v 1.1 2010/09/21 15:02:47 tampakrap Exp $
+
+EAPI="2"
+inherit qt4-build
+
+DESCRIPTION="The SQL module for the Qt toolkit"
+SLOT="4"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE="firebird freetds iconv mysql odbc postgres qt3support +sqlite"
+
+DEPEND="~x11-libs/qt-core-${PV}[debug=,qt3support=]
+ firebird? ( dev-db/firebird )
+ freetds? ( dev-db/freetds )
+ mysql? ( virtual/mysql )
+ odbc? ( dev-db/unixODBC )
+ postgres? ( dev-db/postgresql-base )
+ sqlite? ( dev-db/sqlite:3 )"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ QT4_TARGET_DIRECTORIES="src/sql src/plugins/sqldrivers"
+ QT4_EXTRACT_DIRECTORIES="${QT4_TARGET_DIRECTORIES}
+ include/Qt/
+ include/QtCore/
+ include/QtSql/
+ include/QtScript/
+ src/src.pro
+ src/corelib/
+ src/plugins
+ src/3rdparty
+ src/tools"
+
+ if ! ( use firebird || use freetds || use mysql || use odbc || use postgres || use sqlite );
+ then
+ ewarn "You need to enable at least one SQL driver. Enable at least"
+ ewarn "one of these USE flags: \"firebird freetds mysql odbc postgres sqlite tds\"."
+ die "Enable at least one SQL driver."
+ fi
+
+ qt4-build_pkg_setup
+}
+
+src_prepare() {
+ qt4-build_src_prepare
+
+ sed -e '/pg_config --libs/d' -i "${S}"/configure \
+ || die "sed to fix postgresql usage in ./configure failed"
+}
+
+src_configure() {
+ # Don't support sqlite2 anymore
+ myconf="${myconf} -no-sql-sqlite2
+ $(qt_use mysql sql-mysql plugin) $(use mysql && echo "-I/usr/include/mysql -L/usr/$(get_libdir)/mysql ")
+ $(qt_use postgres sql-psql plugin) $(use postgres && echo "-I/usr/include/postgresql/pgsql ")
+ $(qt_use sqlite sql-sqlite plugin) $(use sqlite && echo '-system-sqlite')
+ $(qt_use odbc sql-odbc plugin)
+ $(qt_use freetds sql-tds plugin)
+ $(qt_use firebird sql-ibase plugin)
+ $(qt_use qt3support)"
+
+ myconf="${myconf} $(qt_use iconv) -no-xkb -no-fontconfig -no-xrender
+ -no-xrandr -no-xfixes -no-xcursor -no-xinerama -no-xshape -no-sm
+ -no-opengl -no-nas-sound -no-dbus -no-cups -no-nis -no-gif -no-libpng
+ -no-libmng -no-libjpeg -no-openssl -system-zlib -no-webkit -no-phonon
+ -no-xmlpatterns -no-freetype -no-libtiff -no-accessibility
+ -no-fontconfig -no-glib -no-opengl -no-svg -no-gtkstyle"
+
+ qt4-build_src_configure
+}
diff --git a/x11-libs/qt-test/ChangeLog b/x11-libs/qt-test/ChangeLog
index 50db68827986..804597ef637f 100644
--- a/x11-libs/qt-test/ChangeLog
+++ b/x11-libs/qt-test/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/qt-test
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-test/ChangeLog,v 1.70 2010/09/13 21:23:29 klausman Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-test/ChangeLog,v 1.71 2010/09/21 15:05:31 tampakrap Exp $
+
+*qt-test-4.7.0 (21 Sep 2010)
+
+ 21 Sep 2010; Theo Chatzimichos <tampakrap@gentoo.org>
+ +qt-test-4.7.0.ebuild:
+ Version bump
13 Sep 2010; Tobias Klausmann <klausman@gentoo.org> qt-test-4.6.2.ebuild:
Stable on alpha, bug #297299
diff --git a/x11-libs/qt-test/qt-test-4.7.0.ebuild b/x11-libs/qt-test/qt-test-4.7.0.ebuild
new file mode 100644
index 000000000000..fec65d8d3fbf
--- /dev/null
+++ b/x11-libs/qt-test/qt-test-4.7.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-test/qt-test-4.7.0.ebuild,v 1.1 2010/09/21 15:05:31 tampakrap Exp $
+
+EAPI="2"
+inherit qt4-build
+
+DESCRIPTION="The testing framework module for the Qt toolkit"
+SLOT="4"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE="iconv"
+
+DEPEND="~x11-libs/qt-core-${PV}[debug=]"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ QT4_TARGET_DIRECTORIES="src/testlib"
+ QT4_EXTRACT_DIRECTORIES="${QT4_TARGET_DIRECTORIES}
+ include/QtTest/
+ include/QtCore/
+ src/corelib/"
+
+ qt4-build_pkg_setup
+}
+
+src_configure() {
+ myconf="${myconf} $(qt_use iconv) -no-xkb -no-fontconfig -no-xrender
+ -no-xrandr -no-xfixes -no-xcursor -no-xinerama -no-xshape -no-sm
+ -no-opengl -no-nas-sound -no-dbus -no-cups -no-nis -no-gif -no-libpng
+ -no-libmng -no-libjpeg -no-openssl -system-zlib -no-webkit -no-phonon
+ -no-qt3support -no-xmlpatterns -no-freetype -no-libtiff
+ -no-accessibility -no-fontconfig -no-glib -no-opengl -no-svg"
+ qt4-build_src_configure
+}
diff --git a/x11-libs/qt-webkit/ChangeLog b/x11-libs/qt-webkit/ChangeLog
index ebffc587ccc4..1cdd408c0c47 100644
--- a/x11-libs/qt-webkit/ChangeLog
+++ b/x11-libs/qt-webkit/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/qt-webkit
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-webkit/ChangeLog,v 1.100 2010/09/13 21:23:54 klausman Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-webkit/ChangeLog,v 1.101 2010/09/21 15:07:37 tampakrap Exp $
+
+*qt-webkit-4.7.0 (21 Sep 2010)
+
+ 21 Sep 2010; Theo Chatzimichos <tampakrap@gentoo.org>
+ +qt-webkit-4.7.0.ebuild:
+ Version bump
13 Sep 2010; Tobias Klausmann <klausman@gentoo.org>
qt-webkit-4.6.2.ebuild:
diff --git a/x11-libs/qt-webkit/qt-webkit-4.7.0.ebuild b/x11-libs/qt-webkit/qt-webkit-4.7.0.ebuild
new file mode 100644
index 000000000000..06efa94c559f
--- /dev/null
+++ b/x11-libs/qt-webkit/qt-webkit-4.7.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-webkit/qt-webkit-4.7.0.ebuild,v 1.1 2010/09/21 15:07:37 tampakrap Exp $
+
+EAPI="2"
+inherit qt4-build
+
+DESCRIPTION="The Webkit module for the Qt toolkit"
+SLOT="4"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 -sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE="dbus kde"
+
+DEPEND="~x11-libs/qt-core-${PV}[debug=,ssl]
+ ~x11-libs/qt-gui-${PV}[dbus?,debug=]
+ ~x11-libs/qt-multimedia-${PV}[debug=]
+ ~x11-libs/qt-xmlpatterns-${PV}[debug=]
+ dbus? ( ~x11-libs/qt-dbus-${PV}[debug=] )
+ !kde? ( || ( ~x11-libs/qt-phonon-${PV}:${SLOT}[dbus=,debug=]
+ media-sound/phonon ) )
+ kde? ( media-sound/phonon )"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ QT4_TARGET_DIRECTORIES="
+ src/3rdparty/webkit/JavaScriptCore
+ src/3rdparty/webkit/WebCore
+ tools/designer/src/plugins/qwebview"
+ QT4_EXTRACT_DIRECTORIES="
+ include/
+ src/
+ tools/"
+
+ QCONFIG_ADD="webkit"
+ QCONFIG_DEFINE="QT_WEBKIT"
+
+ qt4-build_pkg_setup
+}
+
+src_prepare() {
+ [[ $(tc-arch) == "ppc64" ]] && append-flags -mminimal-toc #241900
+
+ qt4-build_src_prepare
+}
+
+src_configure() {
+ myconf="${myconf} -webkit $(qt_use dbus qdbus)"
+ qt4-build_src_configure
+}
diff --git a/x11-libs/qt-xmlpatterns/ChangeLog b/x11-libs/qt-xmlpatterns/ChangeLog
index e0e56555ee46..6fe4b4269ee2 100644
--- a/x11-libs/qt-xmlpatterns/ChangeLog
+++ b/x11-libs/qt-xmlpatterns/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/qt-xmlpatterns
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-xmlpatterns/ChangeLog,v 1.70 2010/09/13 21:24:17 klausman Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-xmlpatterns/ChangeLog,v 1.71 2010/09/21 15:09:06 tampakrap Exp $
+
+*qt-xmlpatterns-4.7.0 (21 Sep 2010)
+
+ 21 Sep 2010; Theo Chatzimichos <tampakrap@gentoo.org>
+ +qt-xmlpatterns-4.7.0.ebuild:
+ Version bump
13 Sep 2010; Tobias Klausmann <klausman@gentoo.org>
qt-xmlpatterns-4.6.2.ebuild:
diff --git a/x11-libs/qt-xmlpatterns/qt-xmlpatterns-4.7.0.ebuild b/x11-libs/qt-xmlpatterns/qt-xmlpatterns-4.7.0.ebuild
new file mode 100644
index 000000000000..1b3d97434bcb
--- /dev/null
+++ b/x11-libs/qt-xmlpatterns/qt-xmlpatterns-4.7.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-xmlpatterns/qt-xmlpatterns-4.7.0.ebuild,v 1.1 2010/09/21 15:09:06 tampakrap Exp $
+
+EAPI="2"
+inherit qt4-build
+
+DESCRIPTION="The patternist module for the Qt toolkit"
+SLOT="4"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+DEPEND="~x11-libs/qt-core-${PV}[debug=,exceptions]"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ QT4_TARGET_DIRECTORIES="src/xmlpatterns tools/xmlpatterns"
+ QT4_EXTRACT_DIRECTORIES="${QT4_TARGET_DIRECTORIES}
+ include/QtCore
+ include/QtNetwork
+ include/QtXml
+ include/QtXmlPatterns
+ src/network/
+ src/xml/
+ src/corelib/"
+
+ QCONFIG_ADD="xmlpatterns"
+ QCONFIG_DEFINE="QT_XMLPATTERNS"
+
+ qt4-build_pkg_setup
+}
+
+src_configure() {
+ myconf="${myconf} -xmlpatterns"
+ qt4-build_src_configure
+}