summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-admin/apg/apg-2.1.0.ebuild9
-rw-r--r--app-admin/apg/apg-2.2.3.ebuild8
-rw-r--r--app-admin/apg/apg-2.3.0b.ebuild8
-rw-r--r--app-admin/ccze/ccze-0.2.1.ebuild4
-rw-r--r--app-admin/chkrootkit/chkrootkit-0.37.ebuild5
-rw-r--r--app-admin/chkrootkit/chkrootkit-0.42b.ebuild13
-rw-r--r--app-admin/chkrootkit/chkrootkit-0.43.ebuild13
-rw-r--r--app-admin/cronolog/cronolog-1.6.2-r1.ebuild7
-rw-r--r--app-admin/cronolog/cronolog-1.6.2.ebuild7
-rw-r--r--app-admin/fpm/fpm-0.59.ebuild30
-rw-r--r--app-admin/fpm/fpm-0.60.ebuild26
-rw-r--r--app-admin/genromfs/genromfs-0.5.1.ebuild4
-rw-r--r--app-admin/gentoo-rsync-mirror/gentoo-rsync-mirror-1.0-r2.ebuild15
-rw-r--r--app-admin/gentoo-rsync-mirror/gentoo-rsync-mirror-1.0-r3.ebuild15
-rw-r--r--app-admin/hddtemp/hddtemp-0.2.ebuild6
-rw-r--r--app-admin/hddtemp/hddtemp-0.3_beta10.ebuild6
-rw-r--r--app-admin/hddtemp/hddtemp-0.3_beta11.ebuild6
-rw-r--r--app-admin/hddtemp/hddtemp-0.3_beta8.ebuild6
18 files changed, 90 insertions, 98 deletions
diff --git a/app-admin/apg/apg-2.1.0.ebuild b/app-admin/apg/apg-2.1.0.ebuild
index 96d577d0b384..cdbd714cb1af 100644
--- a/app-admin/apg/apg-2.1.0.ebuild
+++ b/app-admin/apg/apg-2.1.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/apg/apg-2.1.0.ebuild,v 1.5 2004/06/24 21:23:08 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/apg/apg-2.1.0.ebuild,v 1.6 2004/06/25 16:04:19 vapier Exp $
DESCRIPTION="Another Password Generator"
HOMEPAGE="http://www.adel.nursat.kz/apg/"
@@ -11,8 +11,7 @@ SLOT="0"
KEYWORDS="x86 ppc"
IUSE=""
-RDEPEND=""
-DEPEND="virtual/glibc"
+DEPEND="virtual/libc"
src_compile() {
cp Makefile Makefile.orig
@@ -22,9 +21,9 @@ src_compile() {
}
src_install() {
- exeinto /usr/bin ; doexe apg apgbfm
+ dobin apg apgbfm || die
dodoc CHANGES INSTALL README THANKS TODO
- cd ${S}/doc
+ cd doc
doman man/apg.1
dodoc APG_TIPS pronun.txt rfc0972.txt rfc1750.txt
}
diff --git a/app-admin/apg/apg-2.2.3.ebuild b/app-admin/apg/apg-2.2.3.ebuild
index 201c985207c5..d1699ab003d6 100644
--- a/app-admin/apg/apg-2.2.3.ebuild
+++ b/app-admin/apg/apg-2.2.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/apg/apg-2.2.3.ebuild,v 1.4 2004/06/24 21:23:08 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/apg/apg-2.2.3.ebuild,v 1.5 2004/06/25 16:04:19 vapier Exp $
DESCRIPTION="Another Password Generator"
HOMEPAGE="http://www.adel.nursat.kz/apg/"
@@ -11,7 +11,7 @@ SLOT="0"
KEYWORDS="x86 ~ppc ~sparc"
IUSE=""
-DEPEND="virtual/glibc"
+DEPEND="virtual/libc"
src_compile() {
cp Makefile Makefile.orig
@@ -21,9 +21,9 @@ src_compile() {
}
src_install() {
- exeinto /usr/bin ; doexe apg apgbfm
+ dobin apg apgbfm || die
dodoc CHANGES INSTALL README THANKS TODO
- cd ${S}/doc
+ cd doc
doman man/apg.1
dodoc APG_TIPS pronun.txt rfc0972.txt rfc1750.txt
}
diff --git a/app-admin/apg/apg-2.3.0b.ebuild b/app-admin/apg/apg-2.3.0b.ebuild
index 2407cefaa9ee..595558945d94 100644
--- a/app-admin/apg/apg-2.3.0b.ebuild
+++ b/app-admin/apg/apg-2.3.0b.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/apg/apg-2.3.0b.ebuild,v 1.7 2004/06/24 21:23:08 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/apg/apg-2.3.0b.ebuild,v 1.8 2004/06/25 16:04:19 vapier Exp $
DESCRIPTION="Another Password Generator"
HOMEPAGE="http://www.adel.nursat.kz/apg/"
@@ -11,7 +11,7 @@ SLOT="0"
KEYWORDS="~x86 ~ppc ~sparc amd64"
IUSE=""
-DEPEND="virtual/glibc"
+DEPEND="virtual/libc"
src_unpack() {
unpack ${A}
@@ -27,9 +27,9 @@ src_compile() {
}
src_install() {
- dobin apg apgbfm bfconvert/bfconvert
+ dobin apg apgbfm bfconvert/bfconvert || die
dodoc CHANGES INSTALL README THANKS TODO
- cd ${S}/doc
+ cd doc
doman man/apg.1 man/apgbfm.1
dodoc APG_TIPS pronun.txt rfc0972.txt rfc1750.txt
}
diff --git a/app-admin/ccze/ccze-0.2.1.ebuild b/app-admin/ccze/ccze-0.2.1.ebuild
index e96a9997ef1a..5fe624555a96 100644
--- a/app-admin/ccze/ccze-0.2.1.ebuild
+++ b/app-admin/ccze/ccze-0.2.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/ccze/ccze-0.2.1.ebuild,v 1.6 2004/06/24 21:23:53 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/ccze/ccze-0.2.1.ebuild,v 1.7 2004/06/25 16:04:48 vapier Exp $
DESCRIPTION="A flexible and fast logfile colorizer"
HOMEPAGE="http://bonehunter.rulez.org/CCZE.html"
@@ -11,7 +11,7 @@ SLOT="0"
KEYWORDS="x86 sparc"
IUSE=""
-DEPEND="virtual/glibc
+DEPEND="virtual/libc
sys-libs/ncurses
dev-libs/libpcre"
diff --git a/app-admin/chkrootkit/chkrootkit-0.37.ebuild b/app-admin/chkrootkit/chkrootkit-0.37.ebuild
index fb336634e987..5c179929e709 100644
--- a/app-admin/chkrootkit/chkrootkit-0.37.ebuild
+++ b/app-admin/chkrootkit/chkrootkit-0.37.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/chkrootkit/chkrootkit-0.37.ebuild,v 1.16 2004/06/24 21:24:02 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/chkrootkit/chkrootkit-0.37.ebuild,v 1.17 2004/06/25 16:06:10 vapier Exp $
inherit eutils
@@ -12,7 +12,8 @@ LICENSE="AMS"
SLOT="0"
KEYWORDS="x86 ppc sparc alpha"
IUSE=""
-DEPEND="virtual/glibc"
+
+DEPEND="virtual/libc"
src_unpack() {
unpack ${A}
diff --git a/app-admin/chkrootkit/chkrootkit-0.42b.ebuild b/app-admin/chkrootkit/chkrootkit-0.42b.ebuild
index 4a6dd540c51c..f3721c60b425 100644
--- a/app-admin/chkrootkit/chkrootkit-0.42b.ebuild
+++ b/app-admin/chkrootkit/chkrootkit-0.42b.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/chkrootkit/chkrootkit-0.42b.ebuild,v 1.11 2004/06/24 21:24:02 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/chkrootkit/chkrootkit-0.42b.ebuild,v 1.12 2004/06/25 16:06:10 vapier Exp $
inherit eutils flag-o-matic
@@ -13,14 +13,12 @@ SLOT="0"
KEYWORDS="x86 ~ppc sparc alpha ~ia64 amd64"
IUSE=""
-DEPEND="virtual/glibc"
+DEPEND="virtual/libc"
src_unpack() {
unpack ${A}
cd ${S}
-
epatch ${FILESDIR}/${P}-gentoo.diff
-
sed -i 's:${head} -:${head} -n :' chkrootkit
}
@@ -31,8 +29,7 @@ src_compile() {
}
src_install() {
- into /usr
- dosbin check_wtmpx chklastlog chkproc chkrootkit chkwtmp ifpromisc
- newsbin strings strings-static
- dodoc COPYRIGHT README README.chklastlog README.chkwtmp
+ dosbin check_wtmpx chklastlog chkproc chkrootkit chkwtmp ifpromisc || die
+ newsbin strings strings-static || die
+ dodoc README README.chklastlog README.chkwtmp
}
diff --git a/app-admin/chkrootkit/chkrootkit-0.43.ebuild b/app-admin/chkrootkit/chkrootkit-0.43.ebuild
index 00c55d4a0e5c..b7bdd96e1c25 100644
--- a/app-admin/chkrootkit/chkrootkit-0.43.ebuild
+++ b/app-admin/chkrootkit/chkrootkit-0.43.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/chkrootkit/chkrootkit-0.43.ebuild,v 1.9 2004/06/24 21:24:02 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/chkrootkit/chkrootkit-0.43.ebuild,v 1.10 2004/06/25 16:06:10 vapier Exp $
inherit eutils
@@ -13,14 +13,12 @@ SLOT="0"
KEYWORDS="x86 ~ppc sparc alpha ~ia64 amd64"
IUSE=""
-DEPEND="virtual/glibc"
+DEPEND="virtual/libc"
src_unpack() {
unpack ${A}
cd ${S}
-
epatch ${FILESDIR}/${P}-gentoo.diff
-
sed -i 's:${head} -:${head} -n :' chkrootkit
}
@@ -30,8 +28,7 @@ src_compile() {
}
src_install() {
- into /usr
- dosbin check_wtmpx chklastlog chkproc chkrootkit chkwtmp ifpromisc
- newsbin strings strings-static
- dodoc COPYRIGHT README README.chklastlog README.chkwtmp
+ dosbin check_wtmpx chklastlog chkproc chkrootkit chkwtmp ifpromisc || die
+ newsbin strings strings-static || die
+ dodoc README README.chklastlog README.chkwtmp
}
diff --git a/app-admin/cronolog/cronolog-1.6.2-r1.ebuild b/app-admin/cronolog/cronolog-1.6.2-r1.ebuild
index 773cffa65daa..4a44525b9a02 100644
--- a/app-admin/cronolog/cronolog-1.6.2-r1.ebuild
+++ b/app-admin/cronolog/cronolog-1.6.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/cronolog/cronolog-1.6.2-r1.ebuild,v 1.6 2004/06/24 21:24:45 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/cronolog/cronolog-1.6.2-r1.ebuild,v 1.7 2004/06/25 16:06:53 vapier Exp $
inherit eutils
@@ -13,8 +13,9 @@ SLOT="0"
KEYWORDS="x86 ~ppc amd64"
IUSE=""
-DEPEND="virtual/glibc"
-RDEPEND="${DEPEND} net-www/apache"
+DEPEND="virtual/libc"
+RDEPEND="${DEPEND}
+ net-www/apache"
src_unpack() {
local a
diff --git a/app-admin/cronolog/cronolog-1.6.2.ebuild b/app-admin/cronolog/cronolog-1.6.2.ebuild
index 875e6cad6561..ac986c2da560 100644
--- a/app-admin/cronolog/cronolog-1.6.2.ebuild
+++ b/app-admin/cronolog/cronolog-1.6.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/cronolog/cronolog-1.6.2.ebuild,v 1.8 2004/06/24 21:24:45 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/cronolog/cronolog-1.6.2.ebuild,v 1.9 2004/06/25 16:06:53 vapier Exp $
DESCRIPTION="Cronolog apache logfile rotator"
HOMEPAGE="http://cronolog.org/"
@@ -11,8 +11,9 @@ SLOT="0"
KEYWORDS="x86 ~ppc ~ia64"
IUSE=""
-DEPEND="virtual/glibc"
-RDEPEND="${DEPEND} net-www/apache"
+DEPEND="virtual/libc"
+RDEPEND="${DEPEND}
+ net-www/apache"
src_install() {
make DESTDIR=${D} install || die
diff --git a/app-admin/fpm/fpm-0.59.ebuild b/app-admin/fpm/fpm-0.59.ebuild
index 40a81462df12..d87729ccae49 100644
--- a/app-admin/fpm/fpm-0.59.ebuild
+++ b/app-admin/fpm/fpm-0.59.ebuild
@@ -1,26 +1,24 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/fpm/fpm-0.59.ebuild,v 1.5 2004/06/24 21:26:08 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/fpm/fpm-0.59.ebuild,v 1.6 2004/06/25 16:08:05 vapier Exp $
-DESCRIPTION="A password manager for gnome."
+DESCRIPTION="A password manager for gnome"
+HOMEPAGE="http://fpm.sourceforge.net/"
SRC_URI="mirror://sourceforge/fpm/${P}.tar.gz"
-HOMEPAGE="http://fpm.sourceforge.net"
-KEYWORDS="x86"
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
IUSE="nls"
-DEPEND="virtual/glibc
- gnome-base/gnome-libs
- >=dev-libs/libxml2-2.5.7-r2
- x11-libs/gtk+
- dev-libs/glib
- nls? ( sys-devel/gettext )"
-RDEPEND="${DEPEND}
- dev-util/cvs"
-
-S="${WORKDIR}/${P}"
+DEPEND="virtual/libc
+ gnome-base/gnome-libs
+ >=dev-libs/libxml2-2.5.7-r2
+ x11-libs/gtk+
+ dev-libs/glib
+ nls? ( sys-devel/gettext )"
+DEPEND="${DEPEND}
+ dev-util/cvs"
src_compile() {
./autogen.sh --prefix=/usr \
@@ -29,6 +27,6 @@ src_compile() {
}
src_install() {
- make prefix=${D}/usr install
+ make prefix=${D}/usr install || die
dodoc NEWS README ChangeLog TODO
}
diff --git a/app-admin/fpm/fpm-0.60.ebuild b/app-admin/fpm/fpm-0.60.ebuild
index ad99558d7b7a..1cbb2f26e27b 100644
--- a/app-admin/fpm/fpm-0.60.ebuild
+++ b/app-admin/fpm/fpm-0.60.ebuild
@@ -1,24 +1,24 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/fpm/fpm-0.60.ebuild,v 1.5 2004/06/24 21:26:08 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/fpm/fpm-0.60.ebuild,v 1.6 2004/06/25 16:08:05 vapier Exp $
-DESCRIPTION="A password manager for gnome."
-SRC_URI="mirror://sourceforge/fpm/${P}.tar.gz"
+DESCRIPTION="A password manager for gnome"
HOMEPAGE="http://fpm.sourceforge.net"
+SRC_URI="mirror://sourceforge/fpm/${P}.tar.gz"
-KEYWORDS="x86 ~amd64"
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 ~amd64"
IUSE="nls"
-DEPEND="virtual/glibc
- gnome-base/gnome-libs
- >=dev-libs/libxml2-2.5.7-r2
- x11-libs/gtk+
- dev-libs/glib
- nls? ( sys-devel/gettext )"
+DEPEND="virtual/libc
+ gnome-base/gnome-libs
+ >=dev-libs/libxml2-2.5.7-r2
+ x11-libs/gtk+
+ dev-libs/glib
+ nls? ( sys-devel/gettext )"
RDEPEND="${DEPEND}
- dev-util/cvs"
+ dev-util/cvs"
src_compile() {
./configure --prefix=/usr
@@ -26,6 +26,6 @@ src_compile() {
}
src_install() {
- make prefix=${D}/usr install
+ make prefix=${D}/usr install || die
dodoc NEWS README ChangeLog TODO
}
diff --git a/app-admin/genromfs/genromfs-0.5.1.ebuild b/app-admin/genromfs/genromfs-0.5.1.ebuild
index 03dfc0390852..36c9fcc3cf3c 100644
--- a/app-admin/genromfs/genromfs-0.5.1.ebuild
+++ b/app-admin/genromfs/genromfs-0.5.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/genromfs/genromfs-0.5.1.ebuild,v 1.15 2004/06/24 21:26:35 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/genromfs/genromfs-0.5.1.ebuild,v 1.16 2004/06/25 16:08:28 vapier Exp $
DESCRIPTION="Create space-efficient, small, read-only romfs filesystems"
HOMEPAGE="http://romfs.sourceforge.net/"
@@ -11,7 +11,7 @@ SLOT="0"
KEYWORDS="x86 ppc sparc s390"
IUSE=""
-DEPEND="virtual/glibc"
+DEPEND="virtual/libc"
src_unpack() {
unpack ${A}; cd ${S}
diff --git a/app-admin/gentoo-rsync-mirror/gentoo-rsync-mirror-1.0-r2.ebuild b/app-admin/gentoo-rsync-mirror/gentoo-rsync-mirror-1.0-r2.ebuild
index 5d0161b07824..853f278f985e 100644
--- a/app-admin/gentoo-rsync-mirror/gentoo-rsync-mirror-1.0-r2.ebuild
+++ b/app-admin/gentoo-rsync-mirror/gentoo-rsync-mirror-1.0-r2.ebuild
@@ -1,18 +1,18 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/gentoo-rsync-mirror/gentoo-rsync-mirror-1.0-r2.ebuild,v 1.7 2004/06/24 21:26:49 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/gentoo-rsync-mirror/gentoo-rsync-mirror-1.0-r2.ebuild,v 1.8 2004/06/25 16:10:15 vapier Exp $
-IUSE=""
-S=${WORKDIR}/gentoo-rsync-mirror-${PV}
DESCRIPTION="Ebuild for setting up a Gentoo rsync mirror"
HOMEPAGE="http://www.gentoo.org/doc/en/rsync.xml"
-DEPEND="virtual/glibc"
-RDEPEND="net-misc/rsync
- dev-lang/perl"
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="x86 ppc sparc alpha amd64"
+IUSE=""
+
+DEPEND="virtual/libc"
+RDEPEND="net-misc/rsync
+ dev-lang/perl"
src_install() {
dodir /opt/gentoo-rsync
@@ -40,4 +40,3 @@ pkg_postinst() {
einfo
einfo "For more information visit: http://www.gentoo.org/doc/en/rsync.xml"
}
-
diff --git a/app-admin/gentoo-rsync-mirror/gentoo-rsync-mirror-1.0-r3.ebuild b/app-admin/gentoo-rsync-mirror/gentoo-rsync-mirror-1.0-r3.ebuild
index 8271d908f145..cdfc77fa443b 100644
--- a/app-admin/gentoo-rsync-mirror/gentoo-rsync-mirror-1.0-r3.ebuild
+++ b/app-admin/gentoo-rsync-mirror/gentoo-rsync-mirror-1.0-r3.ebuild
@@ -1,18 +1,18 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/gentoo-rsync-mirror/gentoo-rsync-mirror-1.0-r3.ebuild,v 1.4 2004/06/24 21:26:49 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/gentoo-rsync-mirror/gentoo-rsync-mirror-1.0-r3.ebuild,v 1.5 2004/06/25 16:10:15 vapier Exp $
-IUSE=""
-S=${WORKDIR}/gentoo-rsync-mirror-${PV}
DESCRIPTION="Ebuild for setting up a Gentoo rsync mirror"
HOMEPAGE="http://www.gentoo.org/doc/en/rsync.xml"
-DEPEND="virtual/glibc"
-RDEPEND="net-misc/rsync
- dev-lang/perl"
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="x86 ppc sparc alpha amd64"
+IUSE=""
+
+DEPEND="virtual/libc"
+RDEPEND="net-misc/rsync
+ dev-lang/perl"
src_install() {
dodir /opt/gentoo-rsync
@@ -49,4 +49,3 @@ pkg_postinst() {
einfo
einfo "For more information visit: http://www.gentoo.org/doc/en/rsync.xml"
}
-
diff --git a/app-admin/hddtemp/hddtemp-0.2.ebuild b/app-admin/hddtemp/hddtemp-0.2.ebuild
index 92228058623a..a4f40761ce62 100644
--- a/app-admin/hddtemp/hddtemp-0.2.ebuild
+++ b/app-admin/hddtemp/hddtemp-0.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/hddtemp/hddtemp-0.2.ebuild,v 1.21 2004/06/24 21:28:55 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/hddtemp/hddtemp-0.2.ebuild,v 1.22 2004/06/25 16:12:01 vapier Exp $
inherit eutils
@@ -14,7 +14,7 @@ SLOT="0"
KEYWORDS="x86 ppc sparc"
IUSE=""
-DEPEND="virtual/glibc"
+DEPEND="virtual/libc"
src_unpack() {
unpack ${A} ; cd ${S}
@@ -33,7 +33,7 @@ src_compile() {
}
src_install() {
- dobin hddtemp
+ dobin hddtemp || die
insinto /usr/share/hddtemp
doins ${DISTDIR}/hddtemp.db
dodoc README
diff --git a/app-admin/hddtemp/hddtemp-0.3_beta10.ebuild b/app-admin/hddtemp/hddtemp-0.3_beta10.ebuild
index 6914e3232b4d..1f6dd8a7887a 100644
--- a/app-admin/hddtemp/hddtemp-0.3_beta10.ebuild
+++ b/app-admin/hddtemp/hddtemp-0.3_beta10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/hddtemp/hddtemp-0.3_beta10.ebuild,v 1.5 2004/06/24 21:28:55 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/hddtemp/hddtemp-0.3_beta10.ebuild,v 1.6 2004/06/25 16:12:01 vapier Exp $
MY_P=${P/_beta/-beta}
@@ -13,7 +13,7 @@ SLOT="0"
KEYWORDS="~x86 ~ppc -sparc -amd64"
IUSE=""
-DEPEND="virtual/glibc
+DEPEND="virtual/libc
net-misc/wget"
S=${WORKDIR}/${MY_P}
@@ -37,7 +37,7 @@ src_compile() {
}
src_install() {
- make DESTDIR=${D} install
+ make DESTDIR=${D} install || die
dodoc README TODO Changelog
insinto /usr/share/hddtemp
diff --git a/app-admin/hddtemp/hddtemp-0.3_beta11.ebuild b/app-admin/hddtemp/hddtemp-0.3_beta11.ebuild
index 6cc357cf02ff..4a4660d7b2a4 100644
--- a/app-admin/hddtemp/hddtemp-0.3_beta11.ebuild
+++ b/app-admin/hddtemp/hddtemp-0.3_beta11.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/hddtemp/hddtemp-0.3_beta11.ebuild,v 1.6 2004/06/24 21:28:55 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/hddtemp/hddtemp-0.3_beta11.ebuild,v 1.7 2004/06/25 16:12:01 vapier Exp $
MY_P=${P/_beta/-beta}
@@ -13,7 +13,7 @@ SLOT="0"
KEYWORDS="x86 ~ppc -sparc amd64"
IUSE=""
-DEPEND="virtual/glibc
+DEPEND="virtual/libc
net-misc/wget"
S=${WORKDIR}/${MY_P}
@@ -37,7 +37,7 @@ src_compile() {
}
src_install() {
- make DESTDIR=${D} install
+ make DESTDIR=${D} install || die
dodoc README TODO Changelog
insinto /usr/share/hddtemp
diff --git a/app-admin/hddtemp/hddtemp-0.3_beta8.ebuild b/app-admin/hddtemp/hddtemp-0.3_beta8.ebuild
index a7b263f565ec..8380bc8dc59b 100644
--- a/app-admin/hddtemp/hddtemp-0.3_beta8.ebuild
+++ b/app-admin/hddtemp/hddtemp-0.3_beta8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/hddtemp/hddtemp-0.3_beta8.ebuild,v 1.11 2004/06/24 21:28:55 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/hddtemp/hddtemp-0.3_beta8.ebuild,v 1.12 2004/06/25 16:12:01 vapier Exp $
MY_P=${P/_beta/-beta}
@@ -13,7 +13,7 @@ SLOT="0"
KEYWORDS="x86 ~ppc sparc amd64"
IUSE=""
-DEPEND="virtual/glibc
+DEPEND="virtual/libc
net-misc/wget"
S=${WORKDIR}/${MY_P}
@@ -36,7 +36,7 @@ src_compile() {
}
src_install() {
- make DESTDIR=${D} install
+ make DESTDIR=${D} install || die
dodoc README TODO Changelog
insinto /usr/share/hddtemp