summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-sports/xmoto/ChangeLog8
-rw-r--r--games-sports/xmoto/files/digest-xmoto-0.2.23
-rw-r--r--games-sports/xmoto/xmoto-0.2.2.ebuild41
3 files changed, 51 insertions, 1 deletions
diff --git a/games-sports/xmoto/ChangeLog b/games-sports/xmoto/ChangeLog
index a1a61befa193..88aa349acd0e 100644
--- a/games-sports/xmoto/ChangeLog
+++ b/games-sports/xmoto/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-sports/xmoto
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-sports/xmoto/ChangeLog,v 1.6 2006/09/15 23:41:23 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-sports/xmoto/ChangeLog,v 1.7 2006/10/02 23:10:59 genstef Exp $
+
+*xmoto-0.2.2 (02 Oct 2006)
+
+ 02 Oct 2006; Stefan Schweizer <genstef@gentoo.org> -xmoto-0.2.1.ebuild,
+ +xmoto-0.2.2.ebuild:
+ version bump, parallel make problems still present, mailed upstream again
15 Sep 2006; Stefan Schweizer <genstef@gentoo.org> xmoto-0.2.1.ebuild:
workaround bug 147725, thanks Kyle Hunter <keletmaster@gmail.com>
diff --git a/games-sports/xmoto/files/digest-xmoto-0.2.2 b/games-sports/xmoto/files/digest-xmoto-0.2.2
new file mode 100644
index 000000000000..f86dd5405352
--- /dev/null
+++ b/games-sports/xmoto/files/digest-xmoto-0.2.2
@@ -0,0 +1,3 @@
+MD5 bbf2f0c02ba2ffe1f65e4ca78b0a0bd3 xmoto-0.2.2-src.tar.gz 5938064
+RMD160 c86df47c61f5755858e3294d12ad3ecee6b16aec xmoto-0.2.2-src.tar.gz 5938064
+SHA256 478b9f54c79878f3ff384298b8679f6aece1069b8d41bcdd66dc1951fe803648 xmoto-0.2.2-src.tar.gz 5938064
diff --git a/games-sports/xmoto/xmoto-0.2.2.ebuild b/games-sports/xmoto/xmoto-0.2.2.ebuild
new file mode 100644
index 000000000000..c0c8f452e65d
--- /dev/null
+++ b/games-sports/xmoto/xmoto-0.2.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-sports/xmoto/xmoto-0.2.2.ebuild,v 1.1 2006/10/02 23:10:59 genstef Exp $
+
+inherit eutils games
+
+DESCRIPTION="A challenging 2D motocross platform game"
+HOMEPAGE="http://xmoto.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}-src.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="media-libs/jpeg
+ media-libs/libpng
+ sys-libs/zlib
+ app-arch/bzip2
+ media-libs/libsdl
+ media-libs/sdl-mixer
+ net-misc/curl
+ dev-lang/lua
+ dev-games/ode
+ virtual/opengl"
+
+src_compile() {
+ egamesconf || die "egamesconf failed"
+ emake -j1 || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc README TODO ChangeLog
+
+ doicon extra/xmoto.xpm
+ domenu extra/xmoto{,-edit}.desktop
+
+ prepgamesdirs
+}