summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch/file-roller/file-roller-2.30.1.1.ebuild')
-rw-r--r--app-arch/file-roller/file-roller-2.30.1.1.ebuild69
1 files changed, 69 insertions, 0 deletions
diff --git a/app-arch/file-roller/file-roller-2.30.1.1.ebuild b/app-arch/file-roller/file-roller-2.30.1.1.ebuild
new file mode 100644
index 000000000000..961e151e62d0
--- /dev/null
+++ b/app-arch/file-roller/file-roller-2.30.1.1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/file-roller/file-roller-2.30.1.1.ebuild,v 1.1 2010/06/13 19:22:40 pacho Exp $
+
+EAPI="2"
+GCONF_DEBUG="no"
+
+inherit eutils gnome2
+
+DESCRIPTION="archive manager for GNOME"
+HOMEPAGE="http://fileroller.sourceforge.net/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux"
+IUSE="nautilus"
+
+RDEPEND=">=dev-libs/glib-2.16.0
+ >=x11-libs/gtk+-2.16
+ gnome-base/gconf
+ nautilus? ( gnome-base/nautilus )"
+DEPEND="${RDEPEND}
+ gnome-base/gnome-common
+ sys-devel/gettext
+ dev-util/intltool
+ dev-util/pkgconfig
+ app-text/gnome-doc-utils"
+
+DOCS="AUTHORS ChangeLog HACKING MAINTAINERS NEWS README TODO"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ --disable-dependency-tracking
+ --disable-scrollkeeper
+ --disable-run-in-place
+ --disable-static
+ $(use_enable nautilus nautilus-actions)"
+}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # Use absolute path to GNU tar since star doesn't have the same
+ # options. On Gentoo, star is /usr/bin/tar, GNU tar is /bin/tar
+ epatch "${FILESDIR}"/${PN}-2.10.3-use_bin_tar.patch
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+
+ elog "${PN} is a frontend for several archiving utilities. If you want a"
+ elog "particular achive format support, see ${HOMEPAGE}"
+ elog "and install the relevant package."
+ elog
+ elog "for example:"
+ elog " 7-zip - app-arch/p7zip"
+ elog " ace - app-arch/unace"
+ elog " arj - app-arch/arj"
+ elog " lzma - app-arch/xz-utils"
+ elog " lzop - app-arch/lzop"
+ elog " cpio - app-arch/cpio"
+ elog " iso - app-cdr/cdrtools"
+ elog " jar,zip - app-arch/zip and app-arch/unzip"
+ elog " lha - app-arch/lha"
+ elog " rar - app-arch/unrar"
+ elog " rpm - app-arch/rpm"
+ elog " unstuff - app-arch/stuffit"
+ elog " zoo - app-arch/zoo"
+}