summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-benchmarks/cpuburn/cpuburn-1.4.ebuild')
-rw-r--r--app-benchmarks/cpuburn/cpuburn-1.4.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/app-benchmarks/cpuburn/cpuburn-1.4.ebuild b/app-benchmarks/cpuburn/cpuburn-1.4.ebuild
index 21bbeac4a6bd..c32bb906f3b9 100644
--- a/app-benchmarks/cpuburn/cpuburn-1.4.ebuild
+++ b/app-benchmarks/cpuburn/cpuburn-1.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/cpuburn/cpuburn-1.4.ebuild,v 1.8 2004/09/17 04:58:29 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/cpuburn/cpuburn-1.4.ebuild,v 1.9 2004/09/30 03:00:44 vapier Exp $
MY_P="${PV/./_}"
DESCRIPTION="designed to heavily load CPU chips [testing purposes]"
@@ -20,6 +20,11 @@ src_unpack() {
# for some reason he has it _tar instead of .tar ...
unpack ${A}
tar -xf cpuburn_${MY_P}_tar || die
+
+ if use amd64 ; then #65719
+ cd ${S}
+ sed -i 's:gcc -s:gcc -m32 -s:' Makefile || die "sed failed"
+ fi
}
src_compile() {