summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-benchmarks/stress/stress-0.18.8.ebuild')
-rw-r--r--app-benchmarks/stress/stress-0.18.8.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/app-benchmarks/stress/stress-0.18.8.ebuild b/app-benchmarks/stress/stress-0.18.8.ebuild
new file mode 100644
index 000000000000..68fb1a89bff2
--- /dev/null
+++ b/app-benchmarks/stress/stress-0.18.8.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/stress/stress-0.18.8.ebuild,v 1.1 2007/01/17 20:48:00 antarus Exp $
+
+inherit flag-o-matic
+
+MY_P="${PN}-${PV/_/}"
+S="${WORKDIR}/${MY_P}"
+DESCRIPTION="Imposes stressful loads on different aspects of the system."
+HOMEPAGE="http://weather.ou.edu/~apw/projects/stress"
+SRC_URI="http://weather.ou.edu/~apw/projects/stress/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="static"
+
+DEPEND="virtual/libc"
+
+src_compile() {
+ use static && append-ldflags -static
+ econf || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc ChangeLog AUTHORS README
+}