summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/scsign/scsign-0.0.5.ebuild')
-rw-r--r--app-crypt/scsign/scsign-0.0.5.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-crypt/scsign/scsign-0.0.5.ebuild b/app-crypt/scsign/scsign-0.0.5.ebuild
new file mode 100644
index 000000000000..ab3de8fe8074
--- /dev/null
+++ b/app-crypt/scsign/scsign-0.0.5.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/scsign/scsign-0.0.5.ebuild,v 1.1 2005/01/12 08:13:29 dragonheart Exp $
+
+inherit toolchain-funcs eutils
+
+DESCRIPTION="Scsign - a command-line utility to digitally sign a file"
+HOMEPAGE="http://opensignature.sourceforge.net/"
+SRC_URI="mirror://sourceforge/opensignature/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+S=${WORKDIR}
+
+DEPEND=">=dev-libs/opensc-0.8.1
+ dev-libs/openssl
+ sys-apps/pcsc-lite"
+
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/${P}-printid.patch || die "patch failed"
+}
+
+src_compile() {
+ $(tc-getCC) ${CFLAGS} -lcrypto -lpcsclite -lpthread -lopensc main.c libscsign.c -o scsign || die
+}
+
+src_install() {
+ dobin scsign
+}