summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/gedit/files/gedit-2.18.2-libattr.patch')
-rw-r--r--app-editors/gedit/files/gedit-2.18.2-libattr.patch28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-editors/gedit/files/gedit-2.18.2-libattr.patch b/app-editors/gedit/files/gedit-2.18.2-libattr.patch
new file mode 100644
index 000000000000..19d8c34c8747
--- /dev/null
+++ b/app-editors/gedit/files/gedit-2.18.2-libattr.patch
@@ -0,0 +1,28 @@
+Author: Doug Goldstein <cardoe@gentoo.org>
+Date: Thr Sep 13 10:08:24 2007 +0400
+ remove shadow depend on libattr and make it user config'd
+
+ removes the shadow depend on libattr and makes it user configurable.
+ leaves the default to yes as is currently in gedit, however it fails
+ if libattr is not found so that it's not a shadow depend.
+
+--- gedit-2.18.2/configure.ac.old 2007-06-24 12:06:30.000000000 -0400
++++ gedit-2.18.2/configure.ac 2007-09-13 10:21:12.000000000 -0400
+@@ -138,8 +138,15 @@
+ dnl ================================================================
+ dnl libattr checks
+ dnl ================================================================
+-
+-AC_CHECK_LIB(attr, attr_copy_fd)
++AC_ARG_WITH([attr],
++ AS_HELP_STRING([--without-attr],[Don't use libattr support]),
++ [],
++ [with_attr=yes])
++
++if test "x$with_attr" = "xyes"; then
++ AC_CHECK_LIB([attr], [attr_copy_fd], [],
++ AC_MSG_ERROR([*** attr library (libattr) not found]))
++fi
+
+ dnl ================================================================
+ dnl Start of pkg-config checks