summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/scite/scite-1.6.0.ebuild')
-rw-r--r--app-editors/scite/scite-1.6.0.ebuild8
1 files changed, 5 insertions, 3 deletions
diff --git a/app-editors/scite/scite-1.6.0.ebuild b/app-editors/scite/scite-1.6.0.ebuild
index 7204b3fc755b..ff1a41d7d68a 100644
--- a/app-editors/scite/scite-1.6.0.ebuild
+++ b/app-editors/scite/scite-1.6.0.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/scite/scite-1.6.0.ebuild,v 1.6 2004/09/21 23:40:56 pythonhead Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/scite/scite-1.6.0.ebuild,v 1.7 2004/10/27 05:00:36 pythonhead Exp $
+
+inherit toolchain-funcs
MY_PV=${PV//./}
@@ -23,7 +25,7 @@ src_unpack() {
sed -i makefile \
-e "s#^CXXFLAGS=#CXXFLAGS=${CXXFLAGS} #" \
-e "s#^\(CXXFLAGS=.*\)-Os#\1#" \
- -e "s#^CC =\(.*\)#CC = ${CXX:-g++}#" \
+ -e "s#^CC =\(.*\)#CC = $(tc-getCXX)#" \
|| die "error patching makefile"
cd ${S}
@@ -32,7 +34,7 @@ src_unpack() {
-e 's#/gnome/apps/Applications#/applications#' \
-e "s#^CXXFLAGS=#CXXFLAGS=${CXXFLAGS} #" \
-e "s#^\(CXXFLAGS=.*\)-Os#\1#" \
- -e "s#^CC =\(.*\)#CC = ${CXX:-g++}#" \
+ -e "s#^CC =\(.*\)#CC = $(tc-getCXX)#" \
-e 's#${D}##' \
|| die "error patching makefile"