summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/riece/riece-0.2.0.ebuild')
-rw-r--r--app-emacs/riece/riece-0.2.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/app-emacs/riece/riece-0.2.0.ebuild b/app-emacs/riece/riece-0.2.0.ebuild
new file mode 100644
index 000000000000..7f3ceb8577c2
--- /dev/null
+++ b/app-emacs/riece/riece-0.2.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/riece/riece-0.2.0.ebuild,v 1.1 2004/03/08 19:13:04 usata Exp $
+
+inherit elisp
+
+IUSE=""
+
+DESCRIPTION="Riece is a redisgn of Liece IRC client"
+HOMEPAGE="http://wiliki.designflaw.org/riece.cgi"
+SRC_URI="http://wiliki.designflaw.org/riece/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~alpha"
+
+DEPEND="virtual/emacs"
+
+S=${WORKDIR}/${P}
+SITEFILE=50riece-gentoo.el
+
+src_compile() {
+
+ econf --with-lispdir=${SITELISP} || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install () {
+
+ einstall lispdir=${D}/${SITELISP} || die "einstall failed"
+ elisp-site-file-install ${FILESDIR}/${SITEFILE}
+
+ dodoc AUTHORS ChangeLog INSTALL NEWS README
+}