summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/vmware-console/vmware-console-3.0.0.7592.ebuild')
-rw-r--r--app-emulation/vmware-console/vmware-console-3.0.0.7592.ebuild83
1 files changed, 64 insertions, 19 deletions
diff --git a/app-emulation/vmware-console/vmware-console-3.0.0.7592.ebuild b/app-emulation/vmware-console/vmware-console-3.0.0.7592.ebuild
index c7c9e229e675..54b1202f939b 100644
--- a/app-emulation/vmware-console/vmware-console-3.0.0.7592.ebuild
+++ b/app-emulation/vmware-console/vmware-console-3.0.0.7592.ebuild
@@ -1,43 +1,88 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/vmware-console/vmware-console-3.0.0.7592.ebuild,v 1.1 2004/05/21 19:09:03 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/vmware-console/vmware-console-3.0.0.7592.ebuild,v 1.2 2004/06/04 03:39:06 jmglov Exp $
-MY_PN="VMware-console-3.0.0-7592.tar.gz"
+MY_PN="VMware-console"
+MY_PV=`echo ${PV} | sed -e 's/\.\([0-9]\+\)$/-\1/'`
+MY_P="${MY_PN}-${MY_PV}"
+FN="${MY_P}.tar.gz"
S="${WORKDIR}/vmware-console-distrib"
DESCRIPTION="VMware Remote Console for Linux"
HOMEPAGE="http://www.vmware.com/"
-SRC_URI="${MY_PN}"
+SRC_URI="${FN}"
-LICENSE="vmware-console"
+LICENSE="vmware"
SLOT="0"
KEYWORDS="~x86"
RESTRICT="fetch nostrip"
-IUSE=""
+IUSE="esx"
DEPEND="virtual/glibc
virtual/x11"
pkg_nofetch() {
- einfo "Please place ${FN} in ${DISTDIR}"
+ einfo "Please obtain ${FN} and place it in ${DISTDIR}"
}
src_install () {
- dodir /opt/vmware/bin
- cp -a bin/* ${D}/opt/vmware/bin/
+ # Set up config database
+ echo 'libdir = "/opt/vmware-console/lib"' >etc/config
+ cat >etc/locations <<EOF
+file /opt/vmware-console/etc/locations
+answer BINDIR /opt/vmware-console/bin
+answer LIBDIR /opt/vmware-console/lib
+answer DOCDIR /usr/share/doc/${P}
+answer MANDIR /usr/share/man
+file /opt/vmware-console/etc/not_configured 1085493247
+file /opt/vmware-console/etc/config 1085493247
+EOF
- dodir /opt/vmware/lib
- cp -dr lib/* ${D}/opt/vmware/lib/
+ # Install docs and man pages
+ dodoc doc/*
+ find man -name \*.\?.gz | xargs doman
+ dohtml -r lib/help lib/help-guestinstall lib/help-manual
+ wd=`pwd`
+ cd ${D}/usr/share/doc/${P}/html
+ for i in help help-guestinstall help-manual; do
+ cd $i
+ if use esx; then
+ for j in esx/*; do
+ ln -s $j
+ done
+ else
+ for j in gsx/*; do
+ ln -s $j
+ done
+ fi
+ cd ..
+ done
+ cd ${wd}
- dodir /opt/vmware/doc
- cp -a doc/* ${D}/opt/vmware/doc/
+ # Install everything else
+ into /opt/vmware-console
+ dobin bin/*
+ dodir /opt/vmware-console/etc
+ cp -dr etc/* ${D}/opt/vmware-console/etc/
+ dodir /etc
+ dosym /opt/vmware-console/etc /etc/vmware-console
- dodir /opt/vmware/man/
- cp -a man/* ${D}/opt/vmware/man/
-
- dodir /usr/bin
- dosym /opt/vmware/bin/vmware-console /usr/bin/vmware-console
+ # We already installed the HTML docs, so we can use symlinks
+ dodir /opt/vmware-console/lib
+ rm -rf lib/help lib/help-guestinstall lib/help-manual
+ cp -dr lib/* ${D}/opt/vmware-console/lib/
+ dosym /usr/share/doc/${P}/html/help /opt/vmware-console/lib/help
+ dosym /usr/share/doc/${P}/html/help /opt/vmware-console/lib/help-guestinstall
+ dosym /usr/share/doc/${P}/html/help /opt/vmware-console/lib/help-manual
+}
- dodir /usr/lib
- dosym /opt/vmware/lib /usr/lib/vmware
+pkg_postinst() {
+ if use esx; then
+ ewarn "By setting the 'esx' USE flag, the documentation that is accessed from the Help menu will be for ESX Server"
+ ewarn "You can still access the GSX Server documentation in /usr/share/doc/${P}/html"
+ else
+ ewarn "The documentation that is accessed from the Help menu will be for GSX Server"
+ ewarn "You may select ESX Server documentation by setting the 'esx' USE flag"
+ ewarn "You can still access the ESX Server documentation in /usr/share/doc/${P}/html"
+ fi
}