summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-sci/octave/octave-2.0.17.ebuild')
-rw-r--r--app-sci/octave/octave-2.0.17.ebuild19
1 files changed, 6 insertions, 13 deletions
diff --git a/app-sci/octave/octave-2.0.17.ebuild b/app-sci/octave/octave-2.0.17.ebuild
index 4a7e71b87be1..9ccbe832f250 100644
--- a/app-sci/octave/octave-2.0.17.ebuild
+++ b/app-sci/octave/octave-2.0.17.ebuild
@@ -1,9 +1,10 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/app-sci/octave/octave-2.0.17.ebuild,v 1.1 2002/07/13 22:56:47 raker Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/octave/octave-2.0.17.ebuild,v 1.2 2002/09/03 15:47:46 raker Exp $
S=${WORKDIR}/${P}
-DESCRIPTION="GNU Octave is a high-level language (MatLab compatible) intended for numerical computations."
+
+DESCRIPTION="A high-level language (MatLab compatible) intended for numerical computations."
SRC_URI="ftp://ftp.octave.org/pub/octave/${P}.tar.bz2"
HOMEPAGE="http://www.octave.org/"
@@ -19,22 +20,14 @@ SLOT="0"
src_compile() {
# NOTE: This version only works with gcc-2.x not gcc-3.x
- ./configure \
- --prefix=/usr \
- --sysconfdir=/etc \
- --localstatedir=/var/state/octave \
- --infodir=/usr/share/info \
- --mandir=/usr/share/man \
- --build=${CHOST} \
- --host=${CHOST} \
- --target=${CHOST} \
+ econf \
--enable-dl \
--enable-shared \
--enable-rpath \
--enable-lite-kernel \
- ${myconf} || die "./configure failed"
+ ${myconf} || die "configure failed"
- emake || die "emake failed"
+ make || die "make failed"
}