summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/poppler-bindings/poppler-bindings-0.5.3.ebuild')
-rw-r--r--app-text/poppler-bindings/poppler-bindings-0.5.3.ebuild71
1 files changed, 71 insertions, 0 deletions
diff --git a/app-text/poppler-bindings/poppler-bindings-0.5.3.ebuild b/app-text/poppler-bindings/poppler-bindings-0.5.3.ebuild
new file mode 100644
index 000000000000..eabe716a4de7
--- /dev/null
+++ b/app-text/poppler-bindings/poppler-bindings-0.5.3.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/poppler-bindings/poppler-bindings-0.5.3.ebuild,v 1.1 2006/05/31 07:03:43 genstef Exp $
+
+inherit autotools eutils multilib
+
+MY_P=${P/-bindings/}
+DESCRIPTION="Poppler bindings are rendering bindings for GUI toolkits for poppler"
+HOMEPAGE="http://poppler.freedesktop.org"
+SRC_URI="http://poppler.freedesktop.org/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="gtk qt cairo qt4"
+
+RDEPEND="~app-text/poppler-${PV}
+ cairo? ( >=x11-libs/cairo-0.5 )
+ gtk? (
+ >=x11-libs/gtk+-2.6
+ >=gnome-base/libglade-2
+ )
+ qt? ( =x11-libs/qt-3* )
+ qt4? ( =x11-libs/qt-4* )"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ >=sys-devel/automake-1.9.6"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack(){
+ unpack ${A}
+ cd ${S}
+
+ epatch ${FILESDIR}/poppler-0.5.2-bindings.patch
+
+ AT_M4DIR="m4" eautoreconf
+ sed -i s:/usr/lib/qt:/usr/lib/qt4: configure
+}
+
+src_compile() {
+ # Configure needs help finding qt libs on multilib systems
+ export QTLIB="${QTDIR}/$(get_libdir)"
+ echo $QTLIB
+
+ econf --enable-opi \
+ $(use_enable cairo cairo-output) \
+ $(use_enable gtk poppler-glib) \
+ $(use_enable qt poppler-qt) \
+ $(use_enable qt4 poppler-qt4) \
+ || die "configuration failed"
+ cd poppler
+ if use cairo; then
+ emake libpoppler-cairo.la || die "cairo failed"
+ fi
+ if use qt4; then
+ emake libpoppler-arthur.la || die "arthur failed"
+ fi
+ cd ..
+ emake || die "compilation failed"
+}
+
+src_install() {
+ use cairo && dolib.a poppler/libpoppler-cairo.la
+ make DESTDIR=${D} install || die "make install failed"
+}
+
+pkg_postinst() {
+ ewarn "You need to rebuild everything depending on poppler, use revdep-rebuild"
+}