summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-go/go-tools/go-tools-9999.ebuild')
-rw-r--r--dev-go/go-tools/go-tools-9999.ebuild32
1 files changed, 2 insertions, 30 deletions
diff --git a/dev-go/go-tools/go-tools-9999.ebuild b/dev-go/go-tools/go-tools-9999.ebuild
index 20069b4f540c..1c18bcb6f193 100644
--- a/dev-go/go-tools/go-tools-9999.ebuild
+++ b/dev-go/go-tools/go-tools-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-go/go-tools/go-tools-9999.ebuild,v 1.10 2015/07/06 23:34:44 williamh Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-go/go-tools/go-tools-9999.ebuild,v 1.11 2015/08/05 20:38:06 williamh Exp $
EAPI=5
EGO_PN="golang.org/x/tools/..."
@@ -12,6 +12,7 @@ else
EGIT_COMMIT="ac303766f5f240c1796eeea3dc9bf34f1261aa35"
ARCHIVE_URI="https://github.com/golang/tools/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64"
+ inherit golang-vcs-snapshot
fi
inherit golang-build
@@ -25,35 +26,6 @@ IUSE=""
DEPEND="dev-go/go-net:="
RDEPEND=""
-if [[ ${PV} != *9999* ]]; then
-src_unpack() {
- local f
-
- for f in ${A}
- do
- case "${f}" in
- *.tar|*.tar.gz|*.tar.bz2|*.tar.xz)
- local destdir=${WORKDIR}/${P}/src/${EGO_SRC}
-
- debug-print "${FUNCNAME}: unpacking ${f} to ${destdir}"
-
- # XXX: check whether the directory structure inside is
- # fine? i.e. if the tarball has actually a parent dir.
- mkdir -p "${destdir}" || die
- tar -C "${destdir}" -x --strip-components 1 \
- -f "${DISTDIR}/${f}" || die
- ;;
- *)
- debug-print "${FUNCNAME}: falling back to unpack for ${f}"
-
- # fall back to the default method
- unpack "${f}"
- ;;
- esac
- done
-}
-fi
-
src_prepare() {
# disable broken tests
sed -e 's:TestWeb(:_\0:' \