summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-java/commons-net/commons-net-1.1.0.ebuild')
-rw-r--r--dev-java/commons-net/commons-net-1.1.0.ebuild33
1 files changed, 0 insertions, 33 deletions
diff --git a/dev-java/commons-net/commons-net-1.1.0.ebuild b/dev-java/commons-net/commons-net-1.1.0.ebuild
deleted file mode 100644
index 2904eeedee4d..000000000000
--- a/dev-java/commons-net/commons-net-1.1.0.ebuild
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-net/commons-net-1.1.0.ebuild,v 1.8 2004/07/23 21:00:28 axxo Exp $
-
-inherit eutils java-pkg
-
-DESCRIPTION="The purpose of the library is to provide fundamental protocol access, not higher-level abstractions."
-HOMEPAGE="http://jakarta.apache.org/commons/net/index.html"
-SRC_URI="mirror://apache/jakarta/commons/net/source/${P}-src.tar.gz"
-DEPEND=">=virtual/jdk-1.3
- >=dev-java/ant-1.5.4
- >=dev-java/oro-2.0.7"
-RDEPEND=">=virtual/jdk-1.3"
-LICENSE="Apache-1.1"
-SLOT="0"
-KEYWORDS="~x86 ~ppc"
-IUSE="jikes"
-
-src_unpack() {
- unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/gentoo.diff
-}
-
-src_compile() {
- local antflags="-Doro.jar=$(java-config -p oro) jar"
- use jikes && antflags="${antflags} -Dbuild.compiler=jikes"
- ant ${antflags} || die "died on ant"
-}
-
-src_install() {
- java-pkg_dojar target/*.jar || die "died on java-pkg_dojar"
-}