summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-java/cos/cos-20021105-r1.ebuild')
-rw-r--r--dev-java/cos/cos-20021105-r1.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-java/cos/cos-20021105-r1.ebuild b/dev-java/cos/cos-20021105-r1.ebuild
new file mode 100644
index 000000000000..c59e874eb1d2
--- /dev/null
+++ b/dev-java/cos/cos-20021105-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/cos/cos-20021105-r1.ebuild,v 1.1 2007/02/10 19:42:01 nichoj Exp $
+
+inherit java-pkg-2 java-ant-2
+
+MY_PV=05Nov2002
+MY_P=${PN}-${MY_PV}
+DESCRIPTION=" The com.oreilly.servlet package is the \"must have\" class library for servlet developers."
+HOMEPAGE="http://servlets.com/cos/"
+SRC_URI="http://servlets.com/${PN}/${MY_P}.zip"
+
+LICENSE="cos"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+DEPEND=">=virtual/jdk-1.4
+ app-arch/unzip
+ dev-java/ant-core"
+RDEPEND=">=virtual/jre-1.4
+ =dev-java/servletapi-2.3*"
+S=${WORKDIR}
+
+src_unpack() {
+ unpack ${A}
+
+ rm -r lib classes *.war
+ # TODO I'm not sure how to fix the compilation error for this class
+ # so i'll just delete it for now..
+ rm src/com/oreilly/servlet/CacheHttpServlet.java
+
+ cp ${FILESDIR}/build-${PV}.xml build.xml
+ cat > build.properties <<-EOF
+ classpath=$(java-pkg_getjars servletapi-2.3)
+ EOF
+}
+
+src_compile() {
+ eant -Dproject.name=${PN} jar $(use_doc)
+}
+
+src_install() {
+ java-pkg_dojar dist/${PN}.jar
+ dodoc readme.txt license.txt
+
+ use doc && java-pkg_dohtml -r dist/doc/api
+}