summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/mono/mono-0.13.ebuild')
-rw-r--r--dev-lang/mono/mono-0.13.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-lang/mono/mono-0.13.ebuild b/dev-lang/mono/mono-0.13.ebuild
new file mode 100644
index 000000000000..e3de07be9646
--- /dev/null
+++ b/dev-lang/mono/mono-0.13.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/mono-0.13.ebuild,v 1.1 2002/07/27 22:52:33 trance Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Mono runtime"
+SRC_URI="http://www.go-mono.com/archive/${P}.tar.gz"
+HOMEPAGE="http://www.go-mono.com/"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+DEPEND="virtual/glibc"
+RDEPEND="${DEPEND}"
+KEYWORDS="x86 -ppc"
+
+src_compile() {
+ ./configure \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info || die "./configure failed"
+ MAKEOPTS="-j1" emake || die
+}
+
+src_install () {
+ make \
+ prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ install || die
+
+ touch ${D}/usr/include/${PN}/utils/.keep
+
+ dodoc AUTHORS ChangeLog COPYING.LIB NEWS README
+ docinto docs ; dodoc docs/gc-issues docs/jit-thoughts docs/object-layout docs/unmanaged-calls \
+ docs/exceptions docs/jit-trampolines docs/stack-alignment
+}