summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/DirectFB/DirectFB-0.9.16-r1.ebuild')
-rw-r--r--dev-libs/DirectFB/DirectFB-0.9.16-r1.ebuild93
1 files changed, 93 insertions, 0 deletions
diff --git a/dev-libs/DirectFB/DirectFB-0.9.16-r1.ebuild b/dev-libs/DirectFB/DirectFB-0.9.16-r1.ebuild
new file mode 100644
index 000000000000..338ea7775acb
--- /dev/null
+++ b/dev-libs/DirectFB/DirectFB-0.9.16-r1.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/DirectFB/DirectFB-0.9.16-r1.ebuild,v 1.1 2003/02/02 10:23:48 seemant Exp $
+
+IUSE="jpeg gif png truetype mpeg mmx sse"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Thin library on top of the Linux framebuffer devices"
+SRC_URI="http://www.directfb.org/download/DirectFB/${P}.tar.gz"
+HOMEPAGE="http://www.directfb.org/"
+
+SLOT="0"
+LICENSE="LGPL-2.1"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha"
+
+DEPEND="sys-devel/perl
+ gif? ( media-libs/giflib )
+ png? ( media-libs/libpng )
+ jpeg? ( media-libs/jpeg )
+ mpeg? ( media-libs/libmpeg3 )
+ truetype? ( >=media-libs/freetype-2.0.1 )"
+
+
+PDEPEND="=dev-libs/DirectFB-extra-${PV}*"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ cp configure ${T}
+ sed -e 's:ac_safe=`echo "libmpeg3.h:ac_safe=`echo "libmpeg3/libmpeg3.h:' \
+ -e 's:#include <libmpeg3.h>:#include <libmpeg3/libmpeg3.h>:' \
+ ${T}/configure > configure
+}
+
+src_compile() {
+ local myconf=""
+
+ # Bug in the ./configure script that breaks if you
+ # have --enable-mmx
+ use mmx \
+ && myconf="${myconf} --enable-mmx" \
+ || myconf="${myconf} --disable-mmx"
+
+ use sse \
+ && myconf="${myconf} --enable-sse" \
+ || myconf="${myconf} --disable-sse"
+
+ use mpeg \
+ && myconf="${myconf} --enable-libmpeg3" \
+ || myconf="${myconf} --disable-libmpeg3"
+
+ use jpeg \
+ && myconf="${myconf} --enable-jpeg" \
+ || myconf="${myconf} --disable-jpeg"
+
+ use png \
+ && myconf="${myconf} --enable-png" \
+ || myconf="${myconf} --disable-png"
+
+ use gif \
+ && myconf="${myconf} --enable-gif" \
+ || myconf="${myconf} --disable-gif"
+
+ use truetype \
+ && myconf="${myconf} --enable-freetype" \
+ || myconf="${myconf} --disable-freetype"
+
+
+ econf ${myconf} || die
+
+ use mpeg && ( \
+ cd ${S}/interfaces/IDirectFBVideoProvider
+ cp idirectfbvideoprovider_libmpeg3.c ${T}
+
+ sed s':#include <libmpeg3.h>:#include <libmpeg3/libmpeg3.h>:' \
+ ${T}/idirectfbvideoprovider_libmpeg3.c > \
+ idirectfbvideoprovider_libmpeg3.c
+ cd ${S}
+ )
+
+ # add extra -lstdc++ so libpng/libflash link correctly
+ make LDFLAGS="${LDFLAGS} -lstdc++" || die
+}
+
+src_install() {
+ insinto /etc
+ doins fb.modes
+
+ make DESTDIR=${D} install || die
+
+ dodoc AUTHORS COPYING ChangeLog NEWS README* TODO
+ dohtml -r docs/html
+}