summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/beecrypt/beecrypt-3.1.0-r1.ebuild')
-rw-r--r--dev-libs/beecrypt/beecrypt-3.1.0-r1.ebuild15
1 files changed, 2 insertions, 13 deletions
diff --git a/dev-libs/beecrypt/beecrypt-3.1.0-r1.ebuild b/dev-libs/beecrypt/beecrypt-3.1.0-r1.ebuild
index cb63a44b3338..f00805ae3252 100644
--- a/dev-libs/beecrypt/beecrypt-3.1.0-r1.ebuild
+++ b/dev-libs/beecrypt/beecrypt-3.1.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/beecrypt/beecrypt-3.1.0-r1.ebuild,v 1.10 2004/04/12 19:19:01 cretin Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/beecrypt/beecrypt-3.1.0-r1.ebuild,v 1.11 2004/04/13 19:54:56 cretin Exp $
inherit flag-o-matic
@@ -32,24 +32,13 @@ src_unpack() {
fi
# fix for python paths (#39282)
epatch ${FILESDIR}/beecrypt-3.1.0-python2.3.patch
-
- # Athlons are i686
- epatch ${FILESDIR}/beecrypt-3.1.0-athlon.diff
- autoconf
}
src_compile() {
- conf=""
- arch=`get-flag march`
- [ -n "$arch" ] && conf="--with-arch=$arch"
- cpu=`get-flag mcpu`
- [ -n "$cpu" ] && conf="$conf --with-cpu=$cpu"
-
econf \
`use_with python` \
--enable-shared \
- --enable-static \
- $conf || die
+ --enable-static || die
emake || die "emake failed"
}