summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/glib/glib-1.2.10-r4.ebuild')
-rw-r--r--dev-libs/glib/glib-1.2.10-r4.ebuild24
1 files changed, 9 insertions, 15 deletions
diff --git a/dev-libs/glib/glib-1.2.10-r4.ebuild b/dev-libs/glib/glib-1.2.10-r4.ebuild
index 6ccf83d0dccc..fa590f753369 100644
--- a/dev-libs/glib/glib-1.2.10-r4.ebuild
+++ b/dev-libs/glib/glib-1.2.10-r4.ebuild
@@ -1,36 +1,30 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/glib/glib-1.2.10-r4.ebuild,v 1.3 2002/07/24 03:44:56 cselkirk Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/glib/glib-1.2.10-r4.ebuild,v 1.4 2002/08/01 16:50:26 seemant Exp $
S=${WORKDIR}/${P}
DESCRIPTION="The GLib library of C routines"
SRC_URI="ftp://ftp.gtk.org/pub/gtk/v1.2/${P}.tar.gz
ftp://ftp.gnome.org/pub/GNOME/stable/sources/glib/${P}.tar.gz"
HOMEPAGE="http://www.gtk.org/"
+
+SLOT="1"
+LICENSE="LGPL-2.1"
KEYWORDS="x86 ppc"
+
DEPEND="virtual/glibc"
-RDEPEND="virtual/glibc"
-LICENSE="LGPL-2.1"
-SLOT="1"
src_compile() {
- local myconf
- ./configure --host=${CHOST} \
- --prefix=/usr \
- --infodir=/usr/share/info \
- --mandir=/usr/share/man \
- --with-threads=posix \
- --enable-debug=yes || die
+ econf \
+ --with-threads=posix \
+ --enable-debug=yes || die
emake || die
}
src_install() {
- make prefix=${D}/usr \
- infodir=${D}/usr/share/info \
- mandir=${D}/usr/share/man \
- install || die
+ einstall || die
( cd ${D}/usr/lib ; chmod 755 libgmodule-1.2.so.* )