summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libdaemon/libdaemon-0.12.ebuild')
-rw-r--r--dev-libs/libdaemon/libdaemon-0.12.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-libs/libdaemon/libdaemon-0.12.ebuild b/dev-libs/libdaemon/libdaemon-0.12.ebuild
new file mode 100644
index 000000000000..10049f1f3d79
--- /dev/null
+++ b/dev-libs/libdaemon/libdaemon-0.12.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libdaemon/libdaemon-0.12.ebuild,v 1.1 2007/07/11 23:09:32 swegener Exp $
+
+DESCRIPTION="Simple library for creating daemon processes in C"
+HOMEPAGE="http://0pointer.de/lennart/projects/libdaemon/"
+SRC_URI="http://0pointer.de/lennart/projects/libdaemon/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="doc"
+
+DEPEND="doc? ( app-doc/doxygen )"
+
+src_compile() {
+ econf --disable-lynx || die "econf failed"
+ emake || die "emake failed"
+
+ if use doc ; then
+ einfo "Building documentation"
+ make doxygen || die "make doxygen failed"
+ fi
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+
+ if use doc; then
+ ln -sf doc/reference/html reference
+ dohtml -r doc/README.html reference
+ doman doc/reference/man/man*/*
+ fi
+
+ dodoc README
+ docinto examples ; dodoc examples/testd.c
+}