summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/liboil/liboil-0.3.3.ebuild')
-rw-r--r--dev-libs/liboil/liboil-0.3.3.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-libs/liboil/liboil-0.3.3.ebuild b/dev-libs/liboil/liboil-0.3.3.ebuild
new file mode 100644
index 000000000000..9367c1b110ba
--- /dev/null
+++ b/dev-libs/liboil/liboil-0.3.3.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/liboil/liboil-0.3.3.ebuild,v 1.1 2005/10/11 11:49:18 zaheerm Exp $
+
+inherit eutils
+DESCRIPTION="Liboil is a library of simple functions that are optimized for various CPUs."
+HOMEPAGE="http://www.schleef.org/liboil/"
+SRC_URI="http://www.schleef.org/${PN}/download/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0.3"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+#RESTRICT="nostrip"
+DEPEND="=dev-libs/glib-2*"
+#RDEPEND=""
+#S=${WORKDIR}/${P}
+
+src_compile() {
+ econf || die "econf failed"
+ emake -j1 || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+}