summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/async/async-111.25.00.ebuild')
-rw-r--r--dev-ml/async/async-111.25.00.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-ml/async/async-111.25.00.ebuild b/dev-ml/async/async-111.25.00.ebuild
new file mode 100644
index 000000000000..cf3b173f1ed5
--- /dev/null
+++ b/dev-ml/async/async-111.25.00.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/async/async-111.25.00.ebuild,v 1.1 2014/11/10 08:38:10 aballier Exp $
+
+EAPI="5"
+
+OASIS_BUILD_DOCS=1
+OASIS_BUILD_TESTS=1
+
+inherit oasis
+
+MY_P=${PN/-/_}-${PV}
+DESCRIPTION="Jane Street Capital's asynchronous execution library"
+HOMEPAGE="http://www.janestreet.com/ocaml"
+SRC_URI="http://ocaml.janestreet.com/ocaml-core/${PV}/individual/${MY_P}.tar.gz
+ http://dev.gentoo.org/~aballier/distfiles/${MY_P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="examples"
+
+RDEPEND=">=dev-lang/ocaml-4.00.0:=
+ >=dev-ml/async_kernel-${PV}:=
+ >=dev-ml/async_unix-${PV}:=
+ >=dev-ml/async_extra-${PV}:=
+ "
+DEPEND="${RDEPEND}
+ test? ( >=dev-ml/ounit-1.0.2 dev-ml/core_bench )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ oasis_src_install
+ if use examples ; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}