summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/ounit')
-rw-r--r--dev-ml/ounit/ChangeLog7
-rw-r--r--dev-ml/ounit/Manifest10
-rw-r--r--dev-ml/ounit/ounit-1.0.3.ebuild40
3 files changed, 52 insertions, 5 deletions
diff --git a/dev-ml/ounit/ChangeLog b/dev-ml/ounit/ChangeLog
index 1a6ef9d161d8..fec4dcaf1feb 100644
--- a/dev-ml/ounit/ChangeLog
+++ b/dev-ml/ounit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ml/ounit
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/ounit/ChangeLog,v 1.14 2009/06/20 15:32:42 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ounit/ChangeLog,v 1.15 2009/06/20 15:53:35 aballier Exp $
+
+*ounit-1.0.3 (20 Jun 2009)
+
+ 20 Jun 2009; Alexis Ballier <aballier@gentoo.org> +ounit-1.0.3.ebuild:
+ version bump
20 Jun 2009; Alexis Ballier <aballier@gentoo.org> ounit-1.0.2.ebuild:
explicitly assign rdepend
diff --git a/dev-ml/ounit/Manifest b/dev-ml/ounit/Manifest
index 87f7c54475d2..d46186c1f6d7 100644
--- a/dev-ml/ounit/Manifest
+++ b/dev-ml/ounit/Manifest
@@ -2,13 +2,15 @@
Hash: SHA1
DIST ounit-1.0.2.tar.gz 9806 RMD160 9e886bb2d59e90defdb29bfd32514ddb26cfdd97 SHA1 91dbd0c6a7bc055225cabd83ee55392d1ad1f663 SHA256 3ab40dfe4202aa83fa0309d1265b30e1acd633fec1ad728e5b463dde07737e13
+DIST ounit-1.0.3.tar.gz 13572 RMD160 35496f9df16121b4246074e79df0c5396e3faba7 SHA1 fd5674ba094ed8d32c11618cd22d4efa58535a76 SHA256 27c5084d67dcf600f7f8cc85e15bd828cefebdedbf3c39817d00541157a6fed8
EBUILD ounit-1.0.2.ebuild 1096 RMD160 17f7f034284b50ebf9dc662affc701aac74c8321 SHA1 eb4b208e4c589df0097c31825b8195ce6dc2b24f SHA256 c26d4af19c3b7d66ed71ffd9db636daea690bcc872df2c0ceadad692e3e92e4f
-MISC ChangeLog 1847 RMD160 f24d79f909bc91b7c2bac5a46453524cf7df5a04 SHA1 1279e2e3114b3108d14790fb98e9ca0dd8d5aa95 SHA256 46556385dc37abd9e22a1e740a1ed0bf11650e07387987cf472379bd99641202
+EBUILD ounit-1.0.3.ebuild 1099 RMD160 83b691438663c416960c6580680286dae737b069 SHA1 55bad4d2ce5be577dfad19e243111f9871705a2d SHA256 ab755867065b86133645c3c11352cf3fe9f13a19e0439faafc469d8aed6b56ce
+MISC ChangeLog 1964 RMD160 61c5523dc375709c7d277182d4167b3ba74f8197 SHA1 1dc4db750dd15f2d2211c71d52ef6c920406ebbd SHA256 6ddba4ff2e0624d72c66943870ff373c8ef0e3bb787cd62b6df09483b364b2e9
MISC metadata.xml 155 RMD160 dfaa057e679b01302a807c75a32a910098b26809 SHA1 94024f83dcacbb53e92be090dd0f994ec93dc90d SHA256 118048376ebb76f57628b0819f3de4856e73959c2578c88715d37ea2d1e0af81
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.11 (GNU/Linux)
-iEYEARECAAYFAko9ASEACgkQvFcC4BYPU0o1NgCePmMk6IwTvpaBLOFisD5krXoI
-VaUAoM1rXW6zvDRdNrEbpwpOtaZrQHoC
-=0aJQ
+iEYEARECAAYFAko9BgYACgkQvFcC4BYPU0oA/QCgnZEnNhBoxNkKQNTH1aNhXFaW
+Y+gAnRRIx7MO/yYMLxbzmObjvz3UIa3z
+=Wrbf
-----END PGP SIGNATURE-----
diff --git a/dev-ml/ounit/ounit-1.0.3.ebuild b/dev-ml/ounit/ounit-1.0.3.ebuild
new file mode 100644
index 000000000000..a9045490a858
--- /dev/null
+++ b/dev-ml/ounit/ounit-1.0.3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ounit/ounit-1.0.3.ebuild,v 1.1 2009/06/20 15:53:35 aballier Exp $
+
+EAPI="1"
+
+inherit findlib eutils
+
+DESCRIPTION="Unit testing framework for OCaml"
+HOMEPAGE="http://www.xs4all.nl/~mmzeeman/ocaml/"
+SRC_URI="http://www.xs4all.nl/~mmzeeman/ocaml/${P}.tar.gz"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+DEPEND="dev-lang/ocaml"
+RDEPEND="${DEPEND}"
+IUSE="+ocamlopt"
+
+pkg_setup() {
+ if use ocamlopt && ! built_with_use --missing true dev-lang/ocaml ocamlopt; then
+ eerror "In order to build ${PN} with native code support from ocaml"
+ eerror "You first need to have a native code ocaml compiler."
+ eerror "You need to install dev-lang/ocaml with ocamlopt useflag on."
+ die "Please install ocaml with ocamlopt useflag"
+ fi
+}
+
+src_compile() {
+ emake all || die "emake failed"
+ if use ocamlopt; then
+ emake allopt || die "failed to build native code"
+ fi
+}
+
+src_install() {
+ findlib_src_install
+
+ # install documentation
+ dodoc README changelog
+}