summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/Compress-Raw-Zlib/Compress-Raw-Zlib-2.010.ebuild')
-rw-r--r--dev-perl/Compress-Raw-Zlib/Compress-Raw-Zlib-2.010.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-perl/Compress-Raw-Zlib/Compress-Raw-Zlib-2.010.ebuild b/dev-perl/Compress-Raw-Zlib/Compress-Raw-Zlib-2.010.ebuild
new file mode 100644
index 000000000000..ed5dc5fb73e1
--- /dev/null
+++ b/dev-perl/Compress-Raw-Zlib/Compress-Raw-Zlib-2.010.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Compress-Raw-Zlib/Compress-Raw-Zlib-2.010.ebuild,v 1.1 2008/05/09 13:40:35 tove Exp $
+
+MODULE_AUTHOR=PMQS
+
+inherit multilib perl-module
+
+DESCRIPTION="Low-Level Interface to zlib compression library"
+
+LICENSE="|| ( Artistic GPL-2 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="dev-lang/perl
+ sys-libs/zlib"
+
+SRC_TEST="do"
+
+src_unpack() {
+ perl-module_src_unpack
+
+ cat <<-EOF > "${S}/config.in"
+ BUILD_ZLIB = False
+ INCLUDE = /usr/include
+ LIB = /usr/${get_libdir}
+
+ OLD_ZLIB = False
+ GZIP_OS_CODE = AUTO_DETECT
+ EOF
+}