summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/HTML-Mason/HTML-Mason-1.15.ebuild')
-rw-r--r--dev-perl/HTML-Mason/HTML-Mason-1.15.ebuild24
1 files changed, 22 insertions, 2 deletions
diff --git a/dev-perl/HTML-Mason/HTML-Mason-1.15.ebuild b/dev-perl/HTML-Mason/HTML-Mason-1.15.ebuild
index 7e2ea1e5e95c..85ffc9f8bb1e 100644
--- a/dev-perl/HTML-Mason/HTML-Mason-1.15.ebuild
+++ b/dev-perl/HTML-Mason/HTML-Mason-1.15.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/HTML-Mason/HTML-Mason-1.15.ebuild,v 1.2 2002/11/18 02:15:38 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/HTML-Mason/HTML-Mason-1.15.ebuild,v 1.3 2002/11/21 13:00:22 mcummings Exp $
inherit perl-module
@@ -11,7 +11,7 @@ HOMEPAGE="http://www.masonhq.com/"
SLOT="0"
LICENSE="Artistic | GPL-2"
-KEYWORDS="x86 ppc sparc sparc64 alpha"
+KEYWORDS="~x86 ~ppc ~sparc ~sparc64 ~alpha"
DEPEND="${DEPEND}
>=dev-perl/libapreq-1.0-r2
@@ -23,6 +23,26 @@ DEPEND="${DEPEND}
mydoc="CREDITS UPGRADE"
src_install () {
+ #This is a nasty fix for a sandbox violation that Mason wants to do
+ mv -f install/delete_old_pods.pl install/delete_old_pods.pl2
+ sed -e "s/use strict/exit()/" install/delete_old_pods.pl2 > install/delete_old_pods.pl
perl-module_src_install
dohtml htdocs/*
}
+
+
+pkg_postinst() {
+ einfo
+ einfo "Due to a change in documention in HTML-Mason, you will need to note"
+ einfo "that the documentation in the following files is no longer valid."
+ einfo "These files are present only if you had a previous install of "
+ einfo "HTML-Mason. Feel free to remove these docs from your system: "
+ einfo "/usr/lib/perl5/site_perl/PERLVERSION/HTML/Mason/Interp.pod"
+ einfo "/usr/lib/perl5/site_perl/PERLVERSION/HTML/Mason/ApacheHandler.pod"
+ einfo "/usr/lib/perl5/site_perl/PERLVERSION/HTML/Mason/Request.pod"
+ einfo "/usr/lib/perl5/site_perl/PERLVERSION/HTML/Mason/Component.pod"
+ einfo "Where PERLVERSION is your version of perl (5.6.1, 5.8)"
+ einfo
+
+}
+