summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/dulwich/dulwich-0.9.5.ebuild')
-rw-r--r--dev-python/dulwich/dulwich-0.9.5.ebuild39
1 files changed, 0 insertions, 39 deletions
diff --git a/dev-python/dulwich/dulwich-0.9.5.ebuild b/dev-python/dulwich/dulwich-0.9.5.ebuild
deleted file mode 100644
index d2ace6b3ca96..000000000000
--- a/dev-python/dulwich/dulwich-0.9.5.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/dulwich/dulwich-0.9.5.ebuild,v 1.4 2014/08/10 21:09:52 slyfox Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python{2_6,2_7} pypy pypy2_0 )
-
-inherit distutils-r1
-
-DESCRIPTION="Dulwich is a pure-Python implementation of the Git file formats and protocols"
-HOMEPAGE="http://samba.org/~jelmer/dulwich/ http://pypi.python.org/pypi/dulwich"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="doc test"
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/nose[${PYTHON_USEDEP}]
- )"
-RDEPEND=""
-
-DISTUTILS_IN_SOURCE_BUILD=1
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_test() {
- ln -s "${BUILD_DIR}"/lib/dulwich/*.so dulwich/ || die
- nosetests -v || die "Tests failed under ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/build/html/. )
- distutils-r1_python_install_all
-}