summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/hachoir-core')
-rw-r--r--dev-python/hachoir-core/ChangeLog10
-rw-r--r--dev-python/hachoir-core/Manifest6
-rw-r--r--dev-python/hachoir-core/hachoir-core-1.3.3.ebuild31
3 files changed, 42 insertions, 5 deletions
diff --git a/dev-python/hachoir-core/ChangeLog b/dev-python/hachoir-core/ChangeLog
index 57c9ae4960c4..11ba074f2d11 100644
--- a/dev-python/hachoir-core/ChangeLog
+++ b/dev-python/hachoir-core/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/hachoir-core
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/hachoir-core/ChangeLog,v 1.5 2008/08/12 08:07:13 cedk Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/hachoir-core/ChangeLog,v 1.6 2010/03/26 19:31:09 arfrever Exp $
+
+*hachoir-core-1.3.3 (26 Mar 2010)
+
+ 26 Mar 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ -hachoir-core-1.0.1.ebuild, +hachoir-core-1.3.3.ebuild:
+ Version bump. Set SUPPORT_PYTHON_ABIS.
12 Aug 2008; CĂ©dric Krier <cedk@gentoo.org> hachoir-core-1.0.1.ebuild,
hachoir-core-1.1.ebuild:
diff --git a/dev-python/hachoir-core/Manifest b/dev-python/hachoir-core/Manifest
index 465ea6f8ceb3..8a40210fc314 100644
--- a/dev-python/hachoir-core/Manifest
+++ b/dev-python/hachoir-core/Manifest
@@ -1,6 +1,6 @@
-DIST hachoir-core-1.0.1.tar.gz 97951 RMD160 09502aec8ebbece705e9a3b2fb359d598ca953d1 SHA1 7e6d5381ff2c2b7cd5ec61aa190619b6d66ca7f7 SHA256 896f663672e2081400692c90730b04a82902eb7b794f6c0fbff3635194169c98
DIST hachoir-core-1.1.tar.gz 93775 RMD160 fb54886e6120c111eebd852258ba647036acc666 SHA1 acb1176d158f11fc8442fd823bd6183e567371f2 SHA256 9849f998b94b3df855b1ca2ec2cbef235972c1733b1e92ad50433666999c6808
-EBUILD hachoir-core-1.0.1.ebuild 576 RMD160 d36e1294afa8f4ebf144e09f172461e38d421410 SHA1 7127f13c6edb80f4e1166ac920ce5908bb3fde9c SHA256 a671438015545676ea07ccda1b31129b804adb5fc111ad8c38f30959e906597f
+DIST hachoir-core-1.3.3.tar.gz 91504 RMD160 bc29a5433db1fe86fb90928be63b4af569f0d977 SHA1 e1d3b5da7d57087c922942b7653cb3b195c7769f SHA256 ecf5d16eccc76b22071d6062e54edb67595f70d827644d3a6dff04289b4058df
EBUILD hachoir-core-1.1.ebuild 574 RMD160 6f5d5c6a004cd79f93e03293c4d697ef6a14db3d SHA1 3e44bc841643632c2d0b22f54981f3fced7a529c SHA256 a431a0a28593da7c900706a439d39236c45ee17669de206c54e2985002b1f1d8
-MISC ChangeLog 943 RMD160 498e13aed7d9ebbd5e678b1ec0ea46c8c5c64572 SHA1 fece5e006be956a9644e4a11e91b987907abed5c SHA256 0f113cf34467cdff07e04a133d70ea3f794306ed719a97bc7384c06bcb110a64
+EBUILD hachoir-core-1.3.3.ebuild 823 RMD160 2a0a197664b7d939d8ecc329fce1adf1414d17ca SHA1 8fde9cd4090e25aea37d33583f15d96fe7521374 SHA256 504730e3db063f864d69a03e93aaf6de99acd616289ce0c2c2de0bea2c45d0e9
+MISC ChangeLog 1155 RMD160 24f6f63ac62d044b6c80faac8d152dc48debeeef SHA1 a4c6b5c75a742da2b536b777d2bc80f03ae72f33 SHA256 efe80df435e35812124146aa5d1e160d31fa5ae7c2be2ab2e3032703b6ca623b
MISC metadata.xml 532 RMD160 43e77f9530d11328818765fcb77a6ce41423dd73 SHA1 7e16689f7f56c8203dc19223a6710c756533c82c SHA256 23c5cd9440c19924d0fa2d041eaf960243f04a5f69fb3406e0711a0f8087e921
diff --git a/dev-python/hachoir-core/hachoir-core-1.3.3.ebuild b/dev-python/hachoir-core/hachoir-core-1.3.3.ebuild
new file mode 100644
index 000000000000..0205d5e01224
--- /dev/null
+++ b/dev-python/hachoir-core/hachoir-core-1.3.3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/hachoir-core/hachoir-core-1.3.3.ebuild,v 1.1 2010/03/26 19:31:09 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils
+
+DESCRIPTION="Core of Hachoir framework: parse and edit binary files"
+HOMEPAGE="http://bitbucket.org/haypo/hachoir/wiki/hachoir-core http://pypi.python.org/pypi/hachoir-core"
+SRC_URI="http://pypi.python.org/packages/source/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+RESTRICT_PYTHON_ABIS="3.*"
+
+PYTHON_MODNAME="${PN/-/_}"
+
+src_test() {
+ testing() {
+ PYTHONPATH="build-${PYTHON_ABI}/lib" "$(PYTHON)" test_doc.py
+ }
+ python_execute_function testing
+}