summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pastescript/pastescript-1.7.3.ebuild')
-rw-r--r--dev-python/pastescript/pastescript-1.7.3.ebuild34
1 files changed, 17 insertions, 17 deletions
diff --git a/dev-python/pastescript/pastescript-1.7.3.ebuild b/dev-python/pastescript/pastescript-1.7.3.ebuild
index e3a85c6477fc..d832a5703f8c 100644
--- a/dev-python/pastescript/pastescript-1.7.3.ebuild
+++ b/dev-python/pastescript/pastescript-1.7.3.ebuild
@@ -1,10 +1,12 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pastescript/pastescript-1.7.3.ebuild,v 1.4 2010/02/06 15:40:07 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pastescript/pastescript-1.7.3.ebuild,v 1.5 2010/06/27 22:59:32 arfrever Exp $
-EAPI="2"
+EAPI="3"
PYTHON_DEPEND="2"
SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+DISTUTILS_SRC_TEST="nosetests"
inherit distutils
@@ -19,39 +21,37 @@ LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~x86-macos"
IUSE="doc"
-#IUSE="doc test"
-RDEPEND="dev-python/paste
+RDEPEND=">=dev-python/paste-1.3
dev-python/pastedeploy
dev-python/cheetah"
DEPEND="${RDEPEND}
dev-python/setuptools
- doc? ( dev-python/buildutils dev-python/pygments dev-python/pudge )"
-# test? ( dev-python/nose )
-RESTRICT_PYTHON_ABIS="3.*"
+ doc? ( dev-python/pygments dev-python/sphinx )"
# Tests are broken.
RESTRICT="test"
S="${WORKDIR}/${MY_P}"
+
PYTHON_MODNAME="paste/script"
src_compile() {
distutils_src_compile
+
if use doc; then
- einfo "Generating docs as requested..."
- PYTHONPATH=. "$(PYTHON -f)" setup.py pudge || die "generating docs failed"
+ einfo "Generation of documentation"
+ PYTHONPATH="." "$(PYTHON -f)" setup.py build_sphinx || die "Generation of documentation failed"
fi
}
-src_test() {
- testing() {
- PYTHONPATH="build-${PYTHON_ABI}/lib" nosetests-${PYTHON_ABI}
- }
- python_execute_function testing
-}
-
src_install() {
distutils_src_install
- use doc && dohtml -r docs/html/*
+
+ if use doc; then
+ pushd build/sphinx/html > /dev/null
+ docinto html
+ cp -R [a-z]* _static "${ED}usr/share/doc/${PF}/html" || die "Installation of documentation failed"
+ popd > /dev/null
+ fi
}