summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyorbit/pyorbit-2.24.0.ebuild')
-rw-r--r--dev-python/pyorbit/pyorbit-2.24.0.ebuild45
1 files changed, 33 insertions, 12 deletions
diff --git a/dev-python/pyorbit/pyorbit-2.24.0.ebuild b/dev-python/pyorbit/pyorbit-2.24.0.ebuild
index 0a11efe24f68..9a55c6509f74 100644
--- a/dev-python/pyorbit/pyorbit-2.24.0.ebuild
+++ b/dev-python/pyorbit/pyorbit-2.24.0.ebuild
@@ -1,8 +1,14 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyorbit/pyorbit-2.24.0.ebuild,v 1.13 2010/07/20 15:29:05 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyorbit/pyorbit-2.24.0.ebuild,v 1.14 2010/12/21 22:49:06 eva Exp $
-inherit python gnome2 multilib
+EAPI="3"
+GCONF_DEBUG="no"
+PYTHON_DEPEND="2:2.4"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit gnome2 multilib python
DESCRIPTION="ORBit2 bindings for Python"
HOMEPAGE="http://www.pygtk.org/"
@@ -12,32 +18,47 @@ SLOT="0"
KEYWORDS="alpha amd64 arm ia64 ppc ppc64 sh sparc x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~x86-solaris"
IUSE=""
-RDEPEND=">=dev-lang/python-2.4
- >=gnome-base/orbit-2.12"
+RDEPEND=">=gnome-base/orbit-2.12"
DEPEND="${RDEPEND}
>=dev-util/pkgconfig-0.12.0"
DOCS="AUTHORS ChangeLog INSTALL NEWS README TODO"
-src_unpack() {
- unpack ${A}
+src_prepare() {
# disable pyc compiling
mv "${S}"/py-compile "${S}"/py-compile.orig
ln -s $(type -P true) "${S}"/py-compile
+
+ python_copy_sources
+}
+
+src_configure() {
+ python_execute_function -s gnome2_src_configure
+}
+
+src_compile() {
+ python_execute_function -s gnome2_src_compile
+}
+
+src_test() {
+ python_execute_function -s -d
}
src_install() {
- [[ -z ${ED} ]] && local ED=${D}
- gnome2_src_install
+ installation() {
+ gnome2_src_install
- mv "${ED}"$(python_get_sitedir)/{CORBA.py,pyorbit_CORBA.py}
- mv "${ED}"$(python_get_sitedir)/{PortableServer.py,pyorbit_PortableServer.py}
+ mv "${ED}"$(python_get_sitedir)/{CORBA.py,pyorbit_CORBA.py}
+ mv "${ED}"$(python_get_sitedir)/{PortableServer.py,pyorbit_PortableServer.py}
+ }
+ python_execute_function -s installation
+ python_clean_installation_image
}
pkg_postinst() {
- python_mod_optimize $(python_get_sitedir)/{pyorbit_CORBA.py,pyorbit_PortableServer.py}
+ python_mod_optimize pyorbit_CORBA.py pyorbit_PortableServer.py
}
pkg_postrm() {
- python_mod_cleanup $(python_get_sitedir)/{pyorbit_CORBA.py,pyorbit_PortableServer.py}
+ python_mod_cleanup pyorbit_CORBA.py pyorbit_PortableServer.py
}