summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/chunky_png/chunky_png-1.2.4.ebuild')
-rw-r--r--dev-ruby/chunky_png/chunky_png-1.2.4.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-ruby/chunky_png/chunky_png-1.2.4.ebuild b/dev-ruby/chunky_png/chunky_png-1.2.4.ebuild
new file mode 100644
index 000000000000..edea8d03a79b
--- /dev/null
+++ b/dev-ruby/chunky_png/chunky_png-1.2.4.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/chunky_png/chunky_png-1.2.4.ebuild,v 1.1 2011/09/18 13:06:17 flameeyes Exp $
+
+EAPI=4
+
+USE_RUBY="ruby18 ree18 ruby19 jruby"
+
+RUBY_FAKEGEM_TASK_TEST="spec"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_DOCDIR=""
+
+RUBY_FAKEGEM_EXTRADOC="BENCHMARKS.rdoc README.rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Pure Ruby library that can read and write PNG images"
+HOMEPAGE="http://wiki.github.com/wvanbergen/chunky_png"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/rspec )"
+
+all_ruby_prepare() {
+ sed -i -e '/[bB]undler/s:^:#:' {spec,benchmarks}/*.rb
+ rm Gemfile
+}